Bug 539961 - Unable to adjust LCD backlight on macbook pro 5,3
Unable to adjust LCD backlight on macbook pro 5,3
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 522305 (view as bug list)
Depends On:
Blocks: 649084
  Show dependency treegraph
 
Reported: 2009-11-21 14:05 EST by Jereme Kramer
Modified: 2012-08-16 15:57 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 15:57:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jereme Kramer 2009-11-21 14:05:07 EST
Description of problem:

Unable to adjust backlight on MacBook Pro 5,3 

Version-Release number of selected component (if applicable):
hal-0.5.13-9.fc12
kernel-2.6.31.5-127.fc12
DeviceKit-power-012-2.fc12
gnome-power-manager-2.28.1-5.fc12

How reproducible

Always

Steps to Reproduce:

Under gnome, running gnome-power-manager...

1. Press brightness up or down keys, or disconnect from power

Actual results:

No adjustment in screen brightness

Expected results:

Screen brightness should adjust


Additional info:

Based on bug 522305. Re-filed for Fedora 12

output of lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)":
  power_management.quirk.dpms_on = true  (bool)
  power_management.quirk.dpms_suspend = true  (bool)
  power_management.quirk.vbe_post = true  (bool)
  power_management.quirk.vbemode_restore = true  (bool)
  power_management.quirk.vbestate_restore = true  (bool)
  power_management.quirk.vga_mode_3 = true  (bool)
  system.firmware.version = '   MBP53.88Z.00AC.B03.0906151647'  (string)
  system.hardware.product = 'MacBookPro5,3'  (string)
  system.hardware.vendor = 'Apple Inc.'  (string)
  system.hardware.version = '1.0'  (string)
Comment 1 Eric Donkersloot 2009-11-26 15:32:34 EST
How is this bug report any different than 522305 ?
Comment 2 Jereme Kramer 2009-11-26 16:13:14 EST
I filed this one against Fedora 12, rather than 11.  I apologize if this was inappropriate.
Comment 3 Eric Donkersloot 2009-12-01 09:58:37 EST
Please try this workaround: reboot your machine with the 'nomodeset' kernel
parameter. This might be a duplicate of bug 519105 ?
Comment 4 Jereme Kramer 2009-12-01 19:05:33 EST
In order to get any kind of graphical environment in Fedora on these machines, the nomodeset parameter has to be set, so I'm always booting with this parameter.  To be certain, I did verify that it is set in grub.conf.
Comment 5 Jereme Kramer 2009-12-01 22:40:43 EST
I'm going to go ahead and qualify that.  In order to get the graphical installer to work, modesetting had to be disabled, and I had to use the vesa driver.  I'm not certain its necessary once Fedora has been installed
Comment 6 Carl G. 2010-01-16 23:03:51 EST
*** Bug 522305 has been marked as a duplicate of this bug. ***
Comment 7 Carl G. 2010-01-16 23:05:27 EST
Added f11 bug URL in see also.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Takanori MATSUURA 2010-01-17 19:59:15 EST
I'm also facing this issue. My MacBook is:

# lshal | egrep "(system.hardware.product|vendor|version)|system.firmware.version|power_management.quirk)"
  power_management.quirk.vbestate_restore = true  (bool)
  system.firmware.version = '    MB31.88Z.008E.B02.0803051832'  (string)
  system.hardware.product = 'MacBook3,1'  (string)
  system.hardware.vendor = 'Apple Inc.'  (string)
  system.hardware.version = '1.0'  (string)
Comment 9 Pavel Alexeev 2010-03-13 17:29:16 EST
I also have this isssu, but on Acer Aspire 5740 notebook.
Keys produce correct codes, but ACPI does not work. nomodeset kernel option also did not make me happy.

Direct settings like:
echo 2> /sys/class/backlight/acpi_video0/brightness
don't reproducee any errors, but also do nothing.

Also tried pci interface and xbacklight:
# xbacklight -set 90
# setpci -s 00:02.0 F4.B=40
Comment 10 Pavel Alexeev 2010-03-13 17:32:51 EST
Forgot say versions:
# rpm -q hal kernel
hal-0.5.14-2.fc13.i686
kernel-2.6.33-1.fc13.i686

It is Fedora 13 Alpha
Comment 11 Jereme Kramer 2010-05-26 14:18:01 EDT
This problem was fixed with a fresh install of Fedora 13 final release.  Subsequent updates haven't caused any problems.

hal-0.5.14-3.fc13.x86_64
kernel-2.6.33.3-85.fc13.x86_64
kernel-2.6.33.4-95.fc13.x86_64
Comment 12 Pavel Alexeev 2010-05-28 04:01:06 EDT
It still does not work for me with 
kernel-2.6.33.4-95.fc13.i686 and hal-0.5.14-3.fc13.i686
Comment 13 Takanori MATSUURA 2010-05-28 04:32:00 EDT
On MacBook 3,1 (see comment #8), the issue solved on Fedora 13.

hal-0.5.14-3.fc13.x86_64
kernel-2.6.33.4-95.fc13.x86_64
Comment 14 Patrick Dignan 2010-07-01 01:24:28 EDT
This bug is not fixed for me either.

Kernel version: 2.6.33.5-124.fc13.x86_64
HAL: 0.5.14-3.fc13

Fedora 13.  If you have any need for me to help with debugging please contact me via email, as I'd love to help resolve this.
Comment 15 Patrick Dignan 2010-07-01 01:25:44 EDT
Forgot to mention, I am using a 13.3" Macbook Pro Unibody (5,5).
Comment 16 NSLW 2010-08-13 12:40:09 EDT
It's problem for me too on Fedora 13 and Acer Aspire 5930
Comment 17 Robert Story 2010-09-02 15:33:27 EDT
Same here on MacBookPro6,2

kernel-PAE-2.6.33.8-149.fc13.i686
hal-0.5.14-3.fc13.i686


$ lshal | egrep "(system.hardware.(product|vendor|version)|system.firmware.version|power_management.quirk)"
  power_management.quirk.dpms_on = true  (bool)
  power_management.quirk.dpms_suspend = true  (bool)
  power_management.quirk.vbe_post = true  (bool)
  power_management.quirk.vbemode_restore = true  (bool)
  power_management.quirk.vbestate_restore = true  (bool)
  power_management.quirk.vga_mode_3 = true  (bool)
  system.firmware.version = '   MBP61.88Z.0057.B0A.1005121001'  (string)
  system.hardware.product = 'MacBookPro6,2'  (string)
  system.hardware.vendor = 'Apple Inc.'  (string)
  system.hardware.version = '1.0'  (string)
Comment 18 Marius Andreiana 2010-11-12 14:48:03 EST
Still not working in F14 (both screen brightness and keyboard lights)
Comment 19 rgeorge280 2010-11-22 20:53:07 EST
Same here, not working for me on Macbook Pro 7,1 running Fedora 14.  Ubuntu DOES have screen brightness adjustment working by following the instructions under "Screen" in the guide found here https://help.ubuntu.com/community/MacBookPro7-1/Maverick#Screen
Maybe that helps?
Comment 20 Animesh Saxena 2011-06-14 05:44:03 EDT
I came across an interesting issue with brightness.

Brightness as usual works with nouveau driver, but problem in nvidia driver. 

After installing it I tried this….when nvidia puts up rdblacklist=nouveau in the grub.conf file – Remove all those additions. Just put nouveau.modset=1 instead of 0. The 0 is put by nvidia installer which is a problem.

This time your old brightness files path seem to work.

/sys/devices/virtual/backlight/mbp_backlight/brightness

Again there is a catch coz it doesn’t work in your GUI console. Surprisingly if you go to your non gui console. Ctrl Alt Fn (for mac) F1 – then login as root. This time if you change the file

echo 2 > /sys/devices/virtual/backlight/mbp_backlight/brightness

it works perfectly…...

Maybe this is causing the improper working of Function keys in GUI. 

also i have selinux disabled so there can be issue related to rights to the file. 

Any explanations why the same file when changed in GUI Console doesn't do anything but in text console changes the brightness. I am stumped! ??



Animesh


(www.quantanalysis.in)
Comment 21 Fedora End Of Life 2012-08-16 15:57:09 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.