This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 522668 - No USB mouse function
No USB mouse function
Status: CLOSED DUPLICATE of bug 524808
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 22:21 EDT by Dan Beard
Modified: 2009-11-07 19:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 19:20:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Beard 2009-09-10 22:21:53 EDT
Description of problem: Booting 090909 testday liveCD in HP Pavillion dv6-1240us


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Plug in any USB mouse
2.
3.
  
Actual results:
Mouse is powered, but will not respond to motion or clicks (any)

Expected results:


Additional info:
Comment 1 Dan Beard 2009-09-11 12:18:46 EDT
Further info:   No USB devices will function, including thumb drives.   "Unable to ennumerate device on hub *"
Comment 2 Mariusz Smykuła 2009-10-30 14:51:56 EDT
After installing Fedora 12 Beta I lost my mouse (trackpoint is working ok). In Fedora 11 and in Ubuntu 9.10 all  was OK. 

/var/log/messages after connecting Logitech mouse
Oct 30 19:48:41 localhost kernel: usb 6-1: new full speed USB device using uhci_hcd and address 21
Oct 30 19:48:41 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:41 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:41 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:41 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:41 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:41 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:41 localhost kernel: usb 6-1: device descriptor read/64, error -32
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: usb 6-1: device descriptor read/64, error -32
Oct 30 19:48:42 localhost kernel: usb 6-1: new full speed USB device using uhci_hcd and address 22
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: usb 6-1: device descriptor read/64, error -32
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 10947c9c0+64 of device mask ffffffff
Oct 30 19:48:42 localhost kernel: usb 6-1: device descriptor read/64, error -32
Oct 30 19:48:42 localhost kernel: usb 6-1: new full speed USB device using uhci_hcd and address 23
Oct 30 19:48:42 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:43 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:43 localhost kernel: usb 6-1: device not accepting address 23, error -32
Oct 30 19:48:43 localhost kernel: usb 6-1: new full speed USB device using uhci_hcd and address 24
Oct 30 19:48:43 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:43 localhost kernel: nommu_map_single: overflow 136da5c18+8 of device mask ffffffff
Oct 30 19:48:43 localhost kernel: usb 6-1: device not accepting address 24, error -32
Oct 30 19:48:43 localhost kernel: hub 6-0:1.0: unable to enumerate USB device on port 1

Kernel 2.6.31.5-96.fc12.x86_64 #1 SMP
Comment 3 Mariusz Smykuła 2009-11-06 12:12:28 EST
Boot kernel with option
intel_iommu=off 
(Bug 532582)
Comment 4 Adam Williamson 2009-11-07 14:29:40 EST
*** Bug 530455 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2009-11-07 14:29:58 EST
*** Bug 532582 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2009-11-07 14:32:28 EST

*** This bug has been marked as a duplicate of bug 490477 ***
Comment 7 Adam Williamson 2009-11-07 18:42:39 EST
David Woodhouse says the correct master bug for all the 'my USB ain't working!' issues is 524808, adjusting and moving discussion there.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 524808 ***
Comment 8 Adam Williamson 2009-11-07 18:49:29 EST
hmm, actually, it may be premature to mark this as a dupe: we know Mariusz's bug is 524808, but not Dan's. Dan, what's your hardware? Do all your USB peripherals fail to work or just your mouse?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Dan Beard 2009-11-07 18:55:52 EST
Looks like all USB functions, Adam.   HP Pavilion dv6 laptop.   It's the same critter all right.
Comment 10 Adam Williamson 2009-11-07 19:20:03 EST
OK, thanks. (BTW, how much RAM do you have?)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 524808 ***
Comment 11 Dan Beard 2009-11-07 19:23:49 EST
4 gigs on that one.

Note You need to log in before you can comment on or make changes to this bug.