Bug 532582 - usb devices do not work when system boots with more than 2g ram
usb devices do not work when system boots with more than 2g ram
Status: CLOSED DUPLICATE of bug 524808
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-02 16:11 EST by jeremy boyd
Modified: 2009-11-07 18:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 14:29:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg after fix kernel with intel-iommu=off (48.41 KB, text/plain)
2009-11-06 11:59 EST, Mariusz Smykuła
no flags Details
dmeseg log with standard kernel options (105.21 KB, text/plain)
2009-11-06 12:04 EST, Mariusz Smykuła
no flags Details
dmesg with iommu=soft (49.16 KB, text/plain)
2009-11-06 12:35 EST, Mariusz Smykuła
no flags Details

  None (edit)
Description jeremy boyd 2009-11-02 16:11:36 EST
Description of problem: optical mouse does not function after the kernel begins to boot. also, booting fedora 12 beta live media from a usb stick does not work. i found this https://lists.linux-foundation.org/pipermail/bugme-new/2006-May/014325.html and tried adding mem=2g to my boot options and now the mouse works. i have attached a portion of dmesg that looks suspect but can provide you with any more logs or output that you require.

dmesg:
usb 5-1: new low speed USB device using uhci_hcd and address 3
nommu_map_single: overflow 137c1b0d0+8 of device mask ffffffff
nommu_map_single: overflow 136c047c0+64 of device mask ffffffff
nommu_map_single: overflow 135cb8648+8 of device mask ffffffff
nommu_map_single: overflow 136c047c0+64 of device mask ffffffff
nommu_map_single: overflow 135cb8648+8 of device mask ffffffff
nommu_map_single: overflow 136c047c0+64 of device mask ffffffff
usb 5-1: device descriptor read/64, error -32
nommu_map_single: overflow 135cb8648+8 of device mask ffffffff
nommu_map_single: overflow 1355dff00+64 of device mask ffffffff
nommu_map_single: overflow 135cb8648+8 of device mask ffffffff
nommu_map_single: overflow 1355dff00+64 of device mask ffffffff
nommu_map_single: overflow 137c1b0d8+8 of device mask ffffffff
nommu_map_single: overflow 1355dff00+64 of device mask ffffffff
usb 5-1: device descriptor read/64, error -32
usb 5-1: new low speed USB device using uhci_hcd and address 4
nommu_map_single: overflow 137c1b0d8+8 of device mask ffffffff
nommu_map_single: overflow 137c38f80+64 of device mask ffffffff
nommu_map_single: overflow 135cb85c8+8 of device mask ffffffff
nommu_map_single: overflow 137c38f80+64 of device mask ffffffff
nommu_map_single: overflow 135cb85c8+8 of device mask ffffffff
nommu_map_single: overflow 137c38f80+64 of device mask ffffffff
usb 5-1: device descriptor read/64, error -32
nommu_map_single: overflow 135cb85c8+8 of device mask ffffffff
nommu_map_single: overflow 137d0e980+64 of device mask ffffffff
nommu_map_single: overflow 137c1b0e0+8 of device mask ffffffff
nommu_map_single: overflow 137d0e980+64 of device mask ffffffff
nommu_map_single: overflow 137c1b0e0+8 of device mask ffffffff
nommu_map_single: overflow 137d0e980+64 of device mask ffffffff
usb 5-1: device descriptor read/64, error -32
usb 5-1: new low speed USB device using uhci_hcd and address 5
nommu_map_single: overflow 137c1b0e0+8 of device mask ffffffff
nommu_map_single: overflow 137c1b0e0+8 of device mask ffffffff
usb 5-1: device not accepting address 5, error -32
udev: starting version 145
usb 5-1: new low speed USB device using uhci_hcd and address 6
nommu_map_single: overflow 137c1b0e0+8 of device mask ffffffff
nommu_map_single: overflow 137c1b0e0+8 of device mask ffffffff


Version-Release number of selected component (if applicable):kernel 2.6.31.5-96.fc12.x86_64


How reproducible: always


Steps to Reproduce:
1.boot machine using more than 2gigs of ram
2.
3.
  
Actual results:usb mouse and memory stick do not work


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2009-11-04 15:16:08 EST
Please post the entire dmesg. And try adding "intel_iommu=off" to the boot options next time, instead of "mem=2g".
Comment 2 Chuck Ebbert 2009-11-04 15:21:00 EST
Also try "iommu=soft"
Comment 3 Mariusz Smykuła 2009-11-06 11:57:02 EST
I have this problem too, adding intel_iommu=off fix this for me. This bug is related (identical) with this bugs:
Bug 522668 - No USB mouse function
Bug 530455 - Intel 82801I (ICH9 Family) USB and USB2 controller does not function

thanks for this advice :D Is possible to fix this in kernel? Should I use iommu=soft instead?
Comment 4 Mariusz Smykuła 2009-11-06 11:59:51 EST
Created attachment 367844 [details]
dmesg after fix kernel with intel-iommu=off

dmesg after fix kernel with intel-iommu=off, whole usb stack work OK
Comment 5 Mariusz Smykuła 2009-11-06 12:04:38 EST
Created attachment 367847 [details]
dmeseg log with standard kernel options

Whole USB stack is broken (mouse, usb disks, bluetooth)

kernel 2.6.31.5-117.fc12.x86_64
Comment 6 Mariusz Smykuła 2009-11-06 12:33:21 EST
iommu=soft also fix this problem, which one is better?

This bug apply also to kernel 2.6.31.5-122.fc12.x86_64
Comment 7 Mariusz Smykuła 2009-11-06 12:35:24 EST
Created attachment 367855 [details]
dmesg with iommu=soft
Comment 8 Adam Williamson 2009-11-07 14:29:58 EST

*** This bug has been marked as a duplicate of bug 522668 ***
Comment 9 Adam Williamson 2009-11-07 18:44:17 EST

*** This bug has been marked as a duplicate of bug 524808 ***

Note You need to log in before you can comment on or make changes to this bug.