Bug 52309 - No French Canadian Keyboard
Summary: No French Canadian Keyboard
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 52475 55732 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-22 17:36 UTC by Marc Deslauriers
Modified: 2007-04-18 16:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 06:58:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Deslauriers 2001-08-22 17:36:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3)
Gecko/20010801

Description of problem:
During installation, french-canadian is not listed in the keyboard
settings. (Known as "CF" on the console and "ca_enhanced" in X)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start roswell installation
2. No french-canadian in keyboard settings
3.
	

Actual Results:  Option was missing.

Expected Results:  Would expect a "French Canadian" keyboard setting.

Additional info:

This has been an issue since Redhat 6.0

Comment 1 Brent Fox 2001-08-22 20:05:03 UTC
I think if you do a text install then you can select 'cf' in the keyboard list.
 I'll take a look at the GUI installer.

Comment 2 Brent Fox 2001-08-22 20:12:42 UTC
Mike, can we get a French Canadian keyboard added to XFree?  I can't seem to
find one, which would explain why they are available only in the TUI installer
and not in the GUI one.

Comment 3 Marc Deslauriers 2001-08-22 23:17:43 UTC
In order to get the same layout as the console's "cf" in XFree, I have to
manually edit XF86Config-4 to contain the following:

Option "XkbLayout" "ca_enhanced"

Can the cf/ca_enhanced combo be added to the GUI installer under a "French
Canadian" label?

Marc.

Comment 4 Mike A. Harris 2001-08-24 11:43:22 UTC
I don't handle anaconda.  Is this present in Xconfigurator as a
RFE as well?  I can add it there if you let me know what is needed.
The keytables need to exist in X first.

Comment 5 Mike A. Harris 2001-08-24 11:46:24 UTC
Xconfigurator code fragment:

static char *keymap_translate[] = {
  "be-latin1 -> be", "be2-latin1 -> be", "bg -> bg", "cf -> ca_enhanced",
  "de-latin1-nodeadkeys -> de", "de-latin1 -> de", "de -> de",
  "dk-latin1 -> dk", "dk -> dk", "dvorak -> dvorak", "es -> es",
  "fi-latin1 -> fi", "fi -> fi", "fr-latin1 -> fr", "fr -> fr",


So aparently, Xconfigurator already has this change, it is only
missing from anaconda.


Comment 6 Mike A. Harris 2001-08-24 11:53:39 UTC
Just found and fixed in anaconda sources, in kbd.py, piece o cake. ;o)

class Keyboard (SimpleConfigFile):
    # the *first* item in each of these wins conflicts
    console2xlist = [
            ("be-latin1"         , ('pc102', 'be', '')),
            ("be2-latin1"        , ('pc102', 'be', '')),
            ("bg"                , ('pc102', 'bg', '')),
            ("br-abnt2"          , ('pc102', 'br', '')),
            ("cf"                , ('pc102', 'ca_enhanced', '')),

Checked into CVS, someone else will have to build a package.

Comment 7 Matt Wilson 2001-08-24 21:36:00 UTC
*** Bug 52475 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2001-08-30 22:08:58 UTC
Done and seems to work for me

Comment 9 Brent Fox 2001-11-09 01:45:52 UTC
The option for French-Canadian still doesn't appear in the graphical installer.
 This is because there is no entry for it in the
/usr/lib/X11/xkb/rules/xfree86.lst file.  The installer uses this file to get
the list of layouts to present.

mharris, can you add the following line to xfree86.lst:
ca_enhanced   French-Canadian
I think that would fix the problem.

Comment 10 Brent Fox 2001-11-09 01:47:06 UTC
*** Bug 55732 has been marked as a duplicate of this bug. ***

Comment 11 Mike A. Harris 2002-01-23 16:28:11 UTC
Added to XFree86 4.2.0-2.5, please test and confirm, then either
mark RAWHIDE or REOPENED with explanation.

Thanks.

Comment 12 Mike A. Harris 2002-12-20 06:58:27 UTC
Closing as CURRENTRELEASE (7.3 and later)


Note You need to log in before you can comment on or make changes to this bug.