Bug 525306 - ImportError: No module named pkg_resources
Summary: ImportError: No module named pkg_resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jokosher
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christopher Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 20:51 UTC by Michael Schwendt
Modified: 2012-02-28 09:51 UTC (History)
1 user (show)

Fixed In Version: 1.0-0.8.20091128bzr.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 532545 798089 (view as bug list)
Environment:
Last Closed: 2009-12-02 04:46:17 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2009-09-23 20:51:01 UTC
Packaging bug: "jokosher" is missing

  Requires: python-setuptools

[...]

$ jokosher 
Traceback (most recent call last):
  File "/usr/bin/jokosher", line 97, in <module>
    import Jokosher.JokosherApp as JokosherApp
  File "/usr/lib/python2.6/site-packages/Jokosher/JokosherApp.py", line 24, in <module>
    import PreferencesDialog, ExtensionManagerDialog, RecordingView, NewProjectDialog
  File "/usr/lib/python2.6/site-packages/Jokosher/ExtensionManagerDialog.py", line 11, in <module>
    import Globals, Extension
  File "/usr/lib/python2.6/site-packages/Jokosher/Extension.py", line 9, in <module>
    import os, gtk, imp, pickle, pkg_resources
ImportError: No module named pkg_resources

[...]

Additional info:
* Used "yum install jokosher" to install.

[...]
Installing:
 jokosher     noarch     1.0-0.5.20090604svn.fc11     updates             1.5 M
Installing for dependencies:
 gnonlin      i586       0.10.13-1.fc11               updates-testing      70 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 1.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): gnonlin-0.10.13-1.fc11.i586.rpm                   |  70 kB     00:00     
(2/2): jokosher-1.0-0.5.20090604svn.fc11.noarch.rpm      | 1.5 MB     00:02     
[...]

Comment 1 Fedora Update System 2009-11-29 00:07:32 UTC
jokosher-1.0-0.9.20091128bzr.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/jokosher-1.0-0.9.20091128bzr.fc11

Comment 2 Fedora Update System 2009-11-29 00:07:41 UTC
jokosher-1.0-0.8.20091128bzr.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/jokosher-1.0-0.8.20091128bzr.fc12

Comment 3 Christopher Brown 2009-11-29 17:11:23 UTC
*** Bug 532545 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2009-12-01 04:24:35 UTC
jokosher-1.0-0.9.20091128bzr.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jokosher'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12375

Comment 5 Fedora Update System 2009-12-01 04:45:23 UTC
jokosher-1.0-0.8.20091128bzr.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update jokosher'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12447

Comment 6 Fedora Update System 2009-12-02 04:46:07 UTC
jokosher-1.0-0.9.20091128bzr.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2009-12-02 04:47:01 UTC
jokosher-1.0-0.8.20091128bzr.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.