Bug 798089 - ImportError: No module named pkg_resources
ImportError: No module named pkg_resources
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-webassets (Show other bugs)
19
All Linux
low Severity medium
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-27 21:29 EST by Ben Boeckel
Modified: 2013-10-02 21:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-webassets-0.8-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 525306
Environment:
Last Closed: 2013-10-02 21:09:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2012-02-27 21:29:58 EST
The following package is missing a Requires on python-setuptools. It seems to be very similar to Bug #532545.

python-webassets-0.5-2.fc17.noarch
Comment 1 Praveen Kumar 2012-02-29 23:51:14 EST
Will work on this weekend.
Comment 2 Praveen Kumar 2012-03-04 12:06:01 EST
Hi can you please tell how to regenerate this bug, I rebuild it successfully for rawhide without any change in spec file and also after install I tried to import this module and it imported without any issue.
Comment 3 Ben Boeckel 2012-03-04 12:25:40 EST
It's a runtime error. I got it just by running webassets after an install. python-setuptools was not pulled in automatically.
Comment 4 Praveen Kumar 2012-03-09 22:48:33 EST
I added python-setuptools as requires, please try rpm[0] and let me know if problem is fixed or not, I still not able to generate error (I used this module and during run it's does throw any error). Can you please paste a code snippet?

[0] http://koji.fedoraproject.org/koji/getfile?taskID=3876579&name=python-webassets-0.5-2.fc17.noarch.rpm
Comment 5 Ben Boeckel 2012-03-09 22:58:27 EST
The error:

% rpm -q python-setuptools python-webassets
package python-setuptools is not installed
python-webassets-0.5-2.fc17.noarch
% webassets
Traceback (most recent call last):
  File "/bin/webassets", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Comment 6 Ben Boeckel 2012-03-09 23:06:19 EST
I've filed a bug against rpm[1] because this should likely be handled by rpm-build finding dependencies automatically.

[1]Bug #801990
Comment 7 Michael Schwendt 2012-03-10 03:09:40 EST
Note that there have not been any Python module related automatic dependencies before. Only "python(abi) = ..." is automatic.
Comment 8 Ben Boeckel 2012-03-10 03:34:24 EST
Ah. I thought that happened already. Should I just edit that bug to be an RFE?
Comment 9 Fedora End Of Life 2013-04-03 14:44:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 10 Ben Boeckel 2013-06-13 00:14:24 EDT
Looking at git, there's a BuildRequires on python-setuptools, but not a Requires (which appears to still be necessary though I have setuptools installed via other Requires paths).
Comment 11 Praveen Kumar 2013-09-24 01:11:09 EDT
Hi,

I added "python-setuptools" as require for this package and pushed it to rawhide and f20/f19 testing repo.
Comment 12 Fedora Update System 2013-09-24 01:26:33 EDT
python-webassets-0.8-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-webassets-0.8-3.fc20
Comment 13 Fedora Update System 2013-09-24 02:31:27 EDT
python-webassets-0.8-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-webassets-0.8-3.fc19
Comment 14 Fedora Update System 2013-09-24 18:49:24 EDT
Package python-webassets-0.8-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-webassets-0.8-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17504/python-webassets-0.8-3.fc19
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-10-02 21:09:42 EDT
python-webassets-0.8-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-10-02 21:16:24 EDT
python-webassets-0.8-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.