Bug 525449 - Links from evolution are opened in non-default browser
Summary: Links from evolution are opened in non-default browser
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 13:07 UTC by Alexey Torkhov
Modified: 2010-01-28 19:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 559688 (view as bug list)
Environment:
Last Closed: 2009-10-12 11:01:16 UTC


Attachments (Terms of Use)

Description Alexey Torkhov 2009-09-24 13:07:52 UTC
Description of problem:
I've changed default browser from firefox to midori, but links from evolution are still opened in firefox.

Version-Release number of selected component (if applicable):
exo-0.3.101-4.fc12.x86_64
evolution-2.28.0-1.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Change default browser from gnome's default to midori
2. Clink on link in evolution
  
Actual results:
Link opened in firefox

Expected results:
Link opened in midori

Additional info:

Comment 1 Alexey Torkhov 2009-09-24 13:16:40 UTC
Additional info:
This is in rawhide installation with home shared with gnome

Comment 2 Alexey Torkhov 2009-09-24 15:06:18 UTC
And links from pidgin are opened in midori.

Comment 3 Christoph Wickert 2009-09-25 00:13:37 UTC
This is not (really) an Xfce problem I think. Evolution doesn't honor exo-preferred-applications but relies on gnome-default-applications instead. 

We need a "preferred applications" framework that works cross desktop. Gnome still hardcodes all their stuff in GIO, while Xfce has an extensible framework based on current freedesktop.org menu entry specs (see /usr/share/xfce4/helpers/evolution.desktop for an example). I made a proposal on the xdg mailing list for using the Xfce helpers as a starting point, but there was not much feedback from the Gnome site.

Please don't expect this to be fixed any time soon and use gnome-preferred-applications instead. You need to start it from the command line, because I had to remove it from the menu. See bug # 488558 for details.

Comment 4 Kevin Fenzi 2009-09-25 19:16:24 UTC
ok, so what do we do here? Reassign to evolution?

Comment 5 Christoph Wickert 2009-09-30 23:44:21 UTC
I doubt it makes sense because the Gnome guys will surely close it NOTABUG. I would do the same as Evolution is a Gnome application, so it really should follow the settings from gnome-default-applications.

I suggest closing this bug CANTFIX for now, because things like this really need to be sorted out on a higher level with more people from different desktop environments and distributions involved. This is something we cannot offer in this bug report.

Comment 6 Kevin Fenzi 2009-10-01 00:40:45 UTC
Yeah, sadly agreed. ;(

Comment 7 Alexey Torkhov 2009-10-12 09:53:16 UTC
(In reply to comment #5)
> I suggest closing this bug CANTFIX for now, because things like this really
> need to be sorted out on a higher level with more people from different desktop
> environments and distributions involved. This is something we cannot offer in
> this bug report.  

This things are sorted already at freedesktop leve.
There is a command to open link in default browser: xdg-open "url"
I think, it is xfce problem who does not follow this standard and does not change xdg preferred browser in its dialog.

Reopening.

Comment 8 Christoph Wickert 2009-10-12 10:35:35 UTC
(In reply to comment #7)
> This things are sorted already at freedesktop leve.
> There is a command to open link in default browser: xdg-open "url"
> I think, it is xfce problem who does not follow this standard and does not
> change xdg preferred browser in its dialog.

1. We are talking about evolution here, and Evolution is a GNOME application and it's evo that needs to call xdg-open. So it is *not* an Xfce problem.
2. There is no "xdg preferred browser" but only a preferred browser in Gnome (value stored in GConf) and a preferred one in Xfce (value stored in .config/xfce4/helpers.rc).
3. xdg-open is only a wrapper that calls gnome-open (GNOME), exo-open (Xfce) or kfmclient (KDE) depending on the running session. xdg-open itself has no way to read the value of the preferred browser.
4. Until there is no "preferred applications" spec at freedsktop.org (which includes much more than just opening the browser) nether GNOME or Xfce can fix this bug.

Please be so kind as to read the "Desktop Preferred Applications Specification" thread on the xdg mailing list to get a clue how difficult this topic is:
http://lists.freedesktop.org/archives/xdg/2009-June/010483.html

You are free to get involved and come up with a better spec. Until then, please don't make false assumptions. We currently *can*not* fix this bug, so I'm going to close it CANTFIX again. If you really think it can be fixed at the current state, I'm open to suggestions.

BTW: I suggest to move this bug over to the evolution component as it's evo no honoring your settings. Let's see what the evolution devs think.

Comment 9 Alexey Torkhov 2009-10-12 10:41:34 UTC
Thanks for explanation :)
Reassigning to evolution.

Comment 10 Christoph Wickert 2009-10-12 10:51:41 UTC
I doubt you have been reading the thread I asked you to read within only 6 minutes, so you still don't have a clue what you are talking about.

Comment 11 Milan Crha 2009-10-12 11:01:16 UTC
Evolution in rawhide, thus 2.28, is using gtk_show_uri function. And I agree
with comment #5, evolution is a Gnome application, thus it is tight to gnome
settings.

Comment 12 Matthew Barnes 2010-01-28 19:29:33 UTC
*** Bug 559688 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.