Bug 525843 - abort transaction because of scriptlet errors in non-english being logged to history
Summary: abort transaction because of scriptlet errors in non-english being logged to ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 524715 526598 526755 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-26 09:21 UTC by Sergei LITVINENKO
Modified: 2014-01-21 23:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-13 16:25:42 UTC


Attachments (Terms of Use)
Full log of `yum update` session (5.33 KB, application/x-bzip2)
2009-09-26 09:21 UTC, Sergei LITVINENKO
no flags Details

Description Sergei LITVINENKO 2009-09-26 09:21:30 UTC
Created attachment 362748 [details]
Full log of `yum update` session

Description of problem:
yum is aborted on clean phase.

Version-Release number of selected component (if applicable):
yum-3.2.23-3.fc11.noarch

How reproducible:
I do not know

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
yum is crashed with Traceback:
sqlite3.ProgrammingError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.                                                                       
error: python callback <bound method RPMTransaction.callback of <yum.rpmtrans.RPMTransaction instance at 0x92c87ac>> failed, aborting!                        


Expected results:
clean phase is finished OK

Additional info:

Full log of `yum update` session is attached

Comment 1 James Antill 2009-09-28 15:42:39 UTC
Ok, this is history ... bah.

  Cleanup        : cyrus-sasl-2.1.23-3.fc12.i686                                                                                                      126/143 
groupdel: ������������ saslauth ���� ��������������������                                                                                                                       
Non-fatal POSTUN scriptlet failure in rpm package cyrus-sasl                                                                                                  
  Cleanup        : kde-settings-pulseaudio-4.3-10.noarch                                                                                              127/143 
����������������������������: %postun(cyrus-sasl-2.1.23-3.fc12.i686) scriptlet fatus 6                                                                        
Traceback (most recent call last):                                                                                                                            
[...]

sqlite3.ProgrammingError: You must not use 8-bit bytestrings [...]


...thanks for the BZ, although note that you were not using yum-3.2.23-3.fc11 how did you decide on that version number?

Comment 2 Sergei LITVINENKO 2009-09-28 16:40:36 UTC
>>
>> you were not using yum-3.2.23-3.fc11
>> 

Sorry, mistaken window.
Of course, yum version is yum-3.2.24-6.fc12.noarch

Comment 3 Tim Lauridsen 2009-10-01 08:51:04 UTC
*** Bug 526598 has been marked as a duplicate of this bug. ***

Comment 4 Tim Lauridsen 2009-10-01 08:55:34 UTC
*** Bug 524715 has been marked as a duplicate of this bug. ***

Comment 5 James Antill 2009-10-01 17:28:09 UTC
*** Bug 526755 has been marked as a duplicate of this bug. ***

Comment 6 seth vidal 2009-10-13 16:25:42 UTC
fixed in rawhide and upstream


Note You need to log in before you can comment on or make changes to this bug.