Bug 526407 - The Reinstall with IO failed 2008 R2 NIC
Summary: The Reinstall with IO failed 2008 R2 NIC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 532866 566786 (view as bug list)
Depends On: 526393 566786
Blocks: 518435
TreeView+ depends on / blocked
 
Reported: 2009-09-30 06:07 UTC by koka xiong
Modified: 2010-11-16 12:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-09 09:57:07 UTC


Attachments (Terms of Use)
Reinstall with IO_NIC (115.96 KB, image/png)
2009-09-30 06:09 UTC, koka xiong
no flags Details

Description koka xiong 2009-09-30 06:07:44 UTC
Description of problem:
The NIC failed 2008R2 Reinstall with IO testing


Version-Release number of selected component (if applicable):
xenpv-win-64-bit-1.0.90-2.el5.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1.Configure WHQL and do NIC 2008R2 Reinstall with IO testing
2.The test run to the specific step and the windows becomes no response.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 koka xiong 2009-09-30 06:09:19 UTC
Created attachment 363125 [details]
Reinstall with IO_NIC

Comment 2 Paolo Bonzini 2009-11-04 10:45:08 UTC
*** Bug 532866 has been marked as a duplicate of this bug. ***

Comment 3 Paolo Bonzini 2009-11-05 13:24:53 UTC
This can also be reproduced with this script on dom0

#! /bin/sh

dom=${1-'Vista-32'}

if test $# -gt 1; then
  shift
else
  set type=netfront   # also fails with ioemu
done

while sleep 3; do
  for i in `xm network-list $dom | awk '/^[0-9]/ {print $1}' `; do
    xm network-detach $dom $i
  done
  sleep 3
  # also fails with type=ioemu
  xm network-attach $dom "$@"
done

Comment 4 Paolo Bonzini 2009-11-06 13:05:02 UTC
This is indeed the same as bug 526393, just triggered by the backend rather than the frontend.

Comment 5 Paolo Bonzini 2010-02-09 12:27:48 UTC
WHQL test passes with git master.

Comment 6 Paolo Bonzini 2010-03-16 16:52:31 UTC
It is still possible to get access violation exceptions (in the form of bugchecks like SYSTEM_SERVICE_EXCEPTION or PAGE_FAULT_IN_NONPAGED_AREA) with uninstall+reinstall sequences, unlike disable+enable, just not 100% as before

Comment 7 Paolo Bonzini 2010-04-21 13:10:07 UTC
*** Bug 566786 has been marked as a duplicate of this bug. ***

Comment 9 Paolo Bonzini 2010-05-07 14:00:30 UTC
The blue screens (which were due to dom0 corrupting the guest's memory) are fixed (see bug 526410).  There are still failures in this test though.

Comment 11 RHEL Product and Program Management 2010-08-09 18:10:53 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 12 Paolo Bonzini 2010-11-02 11:23:03 UTC
I see in http://mirrorglass.englab.nay.redhat.com:8080/XWiki/bin/view/Main/WHQL%20Test%20Result that this failed only on W2K8R2.  This is different from the previous test run, where it failed on all machines.  Can you please attach the .wtl log (or if applicable screenshots of a hang) so that I can analyze the failure?

Comment 14 Paolo Bonzini 2010-11-09 09:39:28 UTC
It's ASSIGNED because it fails for me, strangely enough. :(  But I think we can set it as CLOSED/CURRENTRELEASE, yes.

Comment 15 Rita Wu 2010-11-09 09:57:07 UTC
Verified it with xenpv-win-1.3.0.

Set it as Closed/CurrentRelease according to #13&14


Note You need to log in before you can comment on or make changes to this bug.