Bug 526842 - Firstboot not run after installation
Firstboot not run after installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks: F12Beta/F12BetaBlocker
  Show dependency treegraph
 
Reported: 2009-10-01 22:01 EDT by A S Alam
Modified: 2013-07-02 20:54 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 527299 (view as bug list)
Environment:
Last Closed: 2009-10-08 01:43:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2009-10-01 22:01:47 EDT
Description of problem:
After Installation, firstboot is not running(1Oct2009 rawhide),


Version-Release number of selected component (if applicable):
firstboot-1.109-1.fc12
initscripts-8.99-1
anaconda-12.32-1.fc12.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. do installation GUI
2. reboot
3.
  
Actual results:
firstboot was not running

Expected results:
Can be

Additional info:
Comment 1 A S Alam 2009-10-01 22:50:01 EDT
some error on VT1*
--
firstboot ERROR: X Server failed to start
Traceback (most recent call last):
 File"/usr/sbin/firstboot)", line 167, in <module>
config.frontend.start()
File "/usr/lib64/python2.6/site-packages/firstboot/xfronted.py" line 87, in start
raise RuntimeError, "X Server failed to start"
RuntimeError: X server failed to start
plymouthd: ply-keyboard.c:447:ply_keyboard_add_input_handler: Assertion `keyboard !=((void*)0)' failed.
error: unexpectedly disconnected from boot status daemon [FAILED]
--------


But GUI (gdm and gnome is working fine on my machine.

* this is not copy paste, (may be mistake somewhere)
Comment 2 A S Alam 2009-10-01 23:00:49 EDT
runn as Root from Virtual Terminal, firstboot working
Comment 3 Chris Lumens 2009-10-02 10:08:32 EDT
*** Bug 526856 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-10-02 14:11:40 EDT
I believe this is due to a known Xorg VT switching crash.
Comment 5 Will Woods 2009-10-02 14:12:05 EDT
Works OK here on a KVM-based x86_64 install of the F12 Beta test compose. Same
firstboot/initscripts/anaconda version.

So it's not happening for *every* install, anyway.
Comment 6 Robert Laverick 2009-10-04 06:07:22 EDT
I get this error using rawhide nightly 20091001.15 i386

same error output as S A Alam reported

Smolt: http://www.smolts.org/client/show/pub_a06b74a6-bd35-4178-87e7-ca58c6c533b4

I did the install with use entire drive and no encryption.
Comment 7 Ray Strode [halfline] 2009-10-05 11:19:46 EDT
plymouthd is blowing an assertion, must be a plymouth problem.  reassigning
Comment 8 Jesse Keating 2009-10-05 15:54:57 EDT
Not sure this is plymouthd, at least I can successfully get a segfault from X every time I vt switch and switch back.  Is plymouth/firstboot/etc doing any vt switching?

See http://jkeating.fedorapeople.org/x-radeon-vt-crash.jpg
Comment 9 Ray Strode [halfline] 2009-10-05 16:08:22 EDT
ah there are two bugs here, i'll clone the plymouth one off, since it's less blocker-y
Comment 10 Jesse Keating 2009-10-05 19:07:32 EDT
ati build done and tagged.  Just needs a retest.
Comment 11 Ray Strode [halfline] 2009-10-07 18:32:51 EDT
Talked to Jesse on IRC.  We debugged and this actually needed plymouth fixes as well...

Fixed in  plymouth-0.8.0-0.2009.29.09.6.fc12
Comment 12 A S Alam 2009-10-07 21:39:10 EDT
I tried plymouth-0.8.0-0.2009.29.09.6.fc12 with rawhide (installed with single user mode), firstboot is working. wait for build available in rawhide
Comment 13 Jesse Keating 2009-10-08 01:43:48 EDT
And tagged for the release.

Note You need to log in before you can comment on or make changes to this bug.