Bug 527299 - plymouthd: ply-keyboard.c:447:ply_keyboard_add_input_handler: Assertion `keyboard !=((void*)0)' failed. on firstboot's --hide-splash
plymouthd: ply-keyboard.c:447:ply_keyboard_add_input_handler: Assertion `keyb...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Desktop
: 526856 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-05 16:11 EDT by Ray Strode [halfline]
Modified: 2013-01-10 00:30 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 526842
Environment:
Last Closed: 2009-10-07 07:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2009-10-05 16:11:26 EDT
+++ This bug was initially created as a clone of Bug #526842 +++

Description of problem:
After Installation, firstboot is not running(1Oct2009 rawhide),


Version-Release number of selected component (if applicable):
firstboot-1.109-1.fc12
initscripts-8.99-1
anaconda-12.32-1.fc12.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. do installation GUI
2. reboot
3.
  
Actual results:
firstboot was not running

Expected results:
Can be

Additional info:

--- Additional comment from aalam@redhat.com on 2009-10-01 22:50:01 EDT ---

some error on VT1*
--
firstboot ERROR: X Server failed to start
Traceback (most recent call last):
 File"/usr/sbin/firstboot)", line 167, in <module>
config.frontend.start()
File "/usr/lib64/python2.6/site-packages/firstboot/xfronted.py" line 87, in start
raise RuntimeError, "X Server failed to start"
RuntimeError: X server failed to start
plymouthd: ply-keyboard.c:447:ply_keyboard_add_input_handler: Assertion `keyboard !=((void*)0)' failed.
error: unexpectedly disconnected from boot status daemon [FAILED]
--------


But GUI (gdm and gnome is working fine on my machine.

* this is not copy paste, (may be mistake somewhere)

--- Additional comment from aalam@redhat.com on 2009-10-01 23:00:49 EDT ---

runn as Root from Virtual Terminal, firstboot working

--- Additional comment from clumens@redhat.com on 2009-10-02 10:08:32 EDT ---

*** Bug 526856 has been marked as a duplicate of this bug. ***

--- Additional comment from clumens@redhat.com on 2009-10-02 14:11:40 EDT ---

I believe this is due to a known Xorg VT switching crash.

--- Additional comment from wwoods@redhat.com on 2009-10-02 14:12:05 EDT ---

Works OK here on a KVM-based x86_64 install of the F12 Beta test compose. Same
firstboot/initscripts/anaconda version.

So it's not happening for *every* install, anyway.

--- Additional comment from robert@scabserver.com on 2009-10-04 06:07:22 EDT ---

I get this error using rawhide nightly 20091001.15 i386

same error output as S A Alam reported

Smolt: http://www.smolts.org/client/show/pub_a06b74a6-bd35-4178-87e7-ca58c6c533b4

I did the install with use entire drive and no encryption.

--- Additional comment from rstrode@redhat.com on 2009-10-05 11:19:46 EDT ---

plymouthd is blowing an assertion, must be a plymouth problem.  reassigning

--- Additional comment from jkeating@redhat.com on 2009-10-05 15:54:57 EDT ---

Not sure this is plymouthd, at least I can successfully get a segfault from X every time I vt switch and switch back.  Is plymouth/firstboot/etc doing any vt switching?

See http://jkeating.fedorapeople.org/x-radeon-vt-crash.jpg

--- Additional comment from rstrode@redhat.com on 2009-10-05 16:08:22 EDT ---

ah there are two bugs here, i'll clone the plymouth one off, since it's less blocker-y
Comment 1 Ray Strode [halfline] 2009-10-05 17:16:54 EDT
this should be fixed as of 0.8.0-0.2009.29.09.2
Comment 2 Ray Strode [halfline] 2009-10-05 17:45:59 EDT
make that

0.8.0-0.2009.29.09.3

I was a little to hasty in my build and didn't apply the patch.
Comment 3 A S Alam 2009-10-05 22:24:23 EDT
I tried to use 0.8.0-0.2009.29.09.3 package, but getting same error
with (plymouthd: ply-keyboard.c:447...) 
firstboot still not running.
---
1) fresh install
2) install new packages and reboot machine
3) after boot, same error and Directly GDM screen without any user
--
Is there anything wrong with my steps?
Comment 4 Jens Petersen 2009-10-05 22:50:51 EDT
*** Bug 526856 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2009-10-05 22:52:30 EDT
I did an en install yesterday and ja install today
and both had firstboot come up normally so worksforme.
Comment 6 Ray Strode [halfline] 2009-10-07 07:51:47 EDT
(In reply to comment #3)
> I tried to use 0.8.0-0.2009.29.09.3 package, but getting same error
> with (plymouthd: ply-keyboard.c:447...) 
> firstboot still not running.
> ---
> 1) fresh install
> 2) install new packages and reboot machine
> 3) after boot, same error and Directly GDM screen without any user
> --
> Is there anything wrong with my steps?  


After installing the packages you have to make sure plymouth gets in the initrd.

You can get that by installing a new kernel, or by running:

sudo new-kernel-pkg --package kernel --mkinitrd --dracut --depmod --install $(uname -r)

Note You need to log in before you can comment on or make changes to this bug.