Bug 526856 - firstboot crashing at startup
firstboot crashing at startup
Status: CLOSED DUPLICATE of bug 527299
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-02 02:17 EDT by Jens Petersen
Modified: 2009-10-05 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 10:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-10-02 02:17:12 EDT
Description of problem:
firstboot seems to be crashing at startup consistently
with current rawhide

Version-Release number of selected component (if applicable):
firstboot-1.109-1.fc12
plymouth-0.8.0-0.2009.29.09.1.fc12 (version date!)

How reproducible:
every time

Steps to Reproduce:
1. install and boot rawhide
  
Actual results:
console shows (cleanup output):

firstboot ERROR: X server failed to start
Traceback (most recent call last):
File "/usr/sbin/firstboot", line 167, in <module> config.frontend.start()
File "/usr/lib64/python2.6/site-packages/firstboot/xfrontend.py", line 87, in start
  raise RuntimeError, "X server failed to start"
  RuntimeError: X server failed to start
  plymouthd: ply-keyboard.c:447: ply_keyboard_add_input_handler: Assertion `keyboard != ((void *)0)' failed.
  error: unexpectedly disconnected from boot status daemon
[FAILED]

Expected results:
no backtrace

Additional info:
firstboot starts ok as root on desktop.
Comment 1 Chris Lumens 2009-10-02 10:08:32 EDT

*** This bug has been marked as a duplicate of bug 526842 ***
Comment 2 Jens Petersen 2009-10-05 22:47:50 EDT
This wasn't ATI but the plymouth bit:
anyway it is fixed now in recent rawhide since yesterday
at least.
Comment 3 Jens Petersen 2009-10-05 22:50:51 EDT

*** This bug has been marked as a duplicate of bug 527299 ***

Note You need to log in before you can comment on or make changes to this bug.