Bug 584910 - microcode_ctl init script syntax error
microcode_ctl init script syntax error
Status: CLOSED DUPLICATE of bug 552246
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: microcode_ctl (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: Anton Arapov
: Reopened
Depends On: 527701
  Show dependency treegraph
Reported: 2010-04-22 13:26 EDT by Orion Poplawski
Modified: 2014-06-18 04:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 527701
Last Closed: 2010-04-23 16:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
New version of script that should fix AMD OK/FAILURE problem (1.41 KB, text/plain)
2010-04-22 15:08 EDT, Philip Pokorny
no flags Details

  None (edit)
Description Orion Poplawski 2010-04-22 13:26:08 EDT
+++ This bug was initially created as a clone of Bug #527701 +++

Created an attachment (id=363962)
init script with both problems fixed

Description of problem:
[root@ejs-desktop ~]# /etc/rc.d/init.d/microcode_ctl start
/etc/rc.d/init.d/microcode_ctl: line 52: syntax error near unexpected token `}'
/etc/rc.d/init.d/microcode_ctl: line 52: `}'

Also, on fixing the syntax error, it doesn't print the "[  OK  ]" or "[FAILED]" anymore.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. (as root) service microcode_ctl start
Actual results:
Syntax error.

Expected results:
Applying Intel CPU microcode update:                       [  OK  ]

Additional info:
It looks like bash doesn't allow empty functions. The empty stop function and references to it could be removed.

--- Additional comment from fedora-triage-list@redhat.com on 2009-11-16 08:21:32 EST ---

This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:

--- Additional comment from ejs1920@yahoo.co.uk on 2009-11-23 15:45:35 EST ---

microcode_ctl-1.17-1.55.fc12 isn't in Fedora 12 or even rawhide, only koji.

--- Additional comment from xose.vazquez@gmail.com on 2009-12-07 11:08:15 EST ---

microcode_ctl-1.17-1.56.fc12 from updates-testing is still broken:

# /etc/init.d/microcode_ctl start
/etc/init.d/microcode_ctl: line 59: syntax error near unexpected token `}'
/etc/init.d/microcode_ctl: line 59: `}'

--- Additional comment from frankly3d@gmail.com on 2009-12-15 06:21:39 EST ---

Seems to be now fixed with:

--- Additional comment from ejs1920@yahoo.co.uk on 2009-12-16 16:21:29 EST ---

Created an attachment (id=378853)
Fix init script output

There's no syntax error in microcode_ctl-1.17-1.57.fc12, but the init script still doesn't output the [  OK  ] or [FAILED], the line that is printed is with "echo -n" so the message from whatever starts next will be printed on the same line.

Also the init script's "Usage:" line doesn't print out correctly due to a stray $ (the first one).

--- Additional comment from ejs1920@yahoo.co.uk on 2009-12-16 16:38:41 EST ---


--- Additional comment from redhat-bugzilla@linuxnetz.de on 2009-12-26 11:02:48 EST ---

Still busted. Note, the initscript misses a "\n" as well, it's just 2 lines
and not three as bugzilla will make it. The third line with the prompt is
directly appended to the second.

[root@tux ~]# /etc/init.d/microcode_ctl start 
Applying Intel CPU microcode update: Applying Intel CPU microcode update: [root@tux ~]#

--- Additional comment from ppokorny@penguincomputing.com on 2010-04-22 13:12:20 EDT ---

Also an issue with Red Hat 6 beta.
Comment 2 Philip Pokorny 2010-04-22 15:03:08 EDT
The attachment to the parent cloned bug has an additional issue that AMD microcode updates won't print OK/FAILURE due to the script logic.
Comment 3 Philip Pokorny 2010-04-22 15:08:17 EDT
Created attachment 408423 [details]
New version of script that should fix AMD OK/FAILURE problem

Re-arranged the if/then/else blocks so that the OK/FAILURE always prints
Comment 4 RHEL Product and Program Management 2010-04-22 16:13:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
Comment 5 Bill Nottingham 2010-04-23 16:02:51 EDT

*** This bug has been marked as a duplicate of bug 552246 ***

Note You need to log in before you can comment on or make changes to this bug.