This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 528638 - system-config-httpd is crashing (not even starting)
system-config-httpd is crashing (not even starting)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
12
All Linux
low Severity urgent
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
: 542534 542792 544191 544202 544208 554623 557675 561460 561601 565596 570049 572251 573688 578792 583174 584214 586084 586666 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 03:32 EDT by Renich Bon Ciric
Modified: 2015-03-04 20:20 EST (History)
34 users (show)

See Also:
Fixed In Version: system-config-httpd-1.5.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 14:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
s-c-h - result in terminal (17.14 KB, text/plain)
2009-10-20 14:53 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Renich Bon Ciric 2009-10-13 03:32:53 EDT
Description of problem:
When I try to run system-config-httpd, it never starts

Version-Release number of selected component (if applicable):
system-config-httpd-1.4.4-6.fc12.noarch

How reproducible:
Try running this tool and it will not work

Steps to Reproduce:
1. Open a terminal
2. type: su -c 'system-config-httpd'
3. provide the root password
  
Actual results:
It crashes

Expected results:
It should work

Additional info:
abrt didn't detect the crash.


- Stack Trace:

[root@introdesk ~]# gdb system-config-httpd 
GNU gdb (GDB) Fedora (6.8.91.20090930-2.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/system-config-httpd...Reading symbols from /usr/lib/debug/usr/bin/consolehelper.debug...done.
done.
(gdb) run
Starting program: /usr/bin/system-config-httpd 
Executing new program: /usr/bin/consolehelper-gtk
[Thread debugging using libthread_db enabled]
Detaching after fork from child process 8686.
/usr/share/system-config-httpd/ApacheBase.py:7: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  from md5 import md5
*** buffer overflow detected ***: /usr/bin/python terminated
======= Backtrace: =========
/lib64/libc.so.6(__fortify_fail+0x37)[0x34af0fa507]
/lib64/libc.so.6[0x34af0f8470]
/lib64/libc.so.6(__strncpy_chk+0x17b)[0x34af0f772b]
/usr/lib64/libalchemist.so.0(refstr_nget+0x270)[0x7feac8423a20]
/usr/lib64/libalchemist.so.0(AdmContext_new+0x99)[0x7feac841c4d9]
/usr/lib64/libalchemist.so.0(_adm_parse_start_element+0x98e)[0x7feac841fece]
/lib64/libglib-2.0.so.0[0x38f183f482]
/lib64/libglib-2.0.so.0(g_markup_parse_context_parse+0x1052)[0x38f1840eb2]
/usr/lib64/libalchemist.so.0(AdmContext_fromXML+0x7b)[0x7feac841f3bb]
/usr/lib64/python2.6/site-packages/_alchemistmodule.so(+0x553c)[0x7feac863253c]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5282)[0x34c24dca82]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x34c24de4e5]
/usr/lib64/libpython2.6.so.1.0[0x34c246dbcb]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0[0x34c2458a5f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x34c24d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyInstance_New+0x76)[0x34c24581b6]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x4d8d)[0x34c24dc58d]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5877)[0x34c24dd077]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x34c24de4e5]
/usr/lib64/libpython2.6.so.1.0[0x34c246dbcb]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0[0x34c2458a5f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x34c24d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyInstance_New+0x76)[0x34c24581b6]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x4d8d)[0x34c24dc58d]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x34c24de4e5]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCode+0x32)[0x34c24de5f2]
/usr/lib64/libpython2.6.so.1.0(PyImport_ExecCodeModuleEx+0xc2)[0x34c24ee582]
/usr/lib64/libpython2.6.so.1.0[0x34c24eea66]
/usr/lib64/libpython2.6.so.1.0[0x34c24eff85]
/usr/lib64/libpython2.6.so.1.0[0x34c24f0214]
/usr/lib64/libpython2.6.so.1.0[0x34c24f0862]
/usr/lib64/libpython2.6.so.1.0(PyImport_ImportModuleLevel+0x44)[0x34c24f0dc4]
/usr/lib64/libpython2.6.so.1.0[0x34c24d674f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x34c24d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x1e31)[0x34c24d9631]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x34c24de4e5]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCode+0x32)[0x34c24de5f2]
/usr/lib64/libpython2.6.so.1.0(PyImport_ExecCodeModuleEx+0xc2)[0x34c24ee582]
/usr/lib64/libpython2.6.so.1.0[0x34c24eea66]
/usr/lib64/libpython2.6.so.1.0[0x34c24eff85]
/usr/lib64/libpython2.6.so.1.0[0x34c24f0214]
/usr/lib64/libpython2.6.so.1.0[0x34c24f0862]
/usr/lib64/libpython2.6.so.1.0(PyImport_ImportModuleLevel+0x44)[0x34c24f0dc4]
/usr/lib64/libpython2.6.so.1.0[0x34c24d674f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x34c2443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x34c24d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x1e31)[0x34c24d9631]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x34c24de4e5]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCode+0x32)[0x34c24de5f2]
/usr/lib64/libpython2.6.so.1.0[0x34c24f965c]
/usr/lib64/libpython2.6.so.1.0(PyRun_FileExFlags+0x90)[0x34c24f9730]
/usr/lib64/libpython2.6.so.1.0(PyRun_SimpleFileExFlags+0xdc)[0x34c24fab0c]
/usr/lib64/libpython2.6.so.1.0(Py_Main+0xaa9)[0x34c2507389]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x34af01eb4d]
/usr/bin/python[0x400649]
======= Memory map: ========
00400000-00401000 r-xp 00000000 fd:00 14565                              /usr/bin/python
00600000-00602000 rw-p 00000000 fd:00 14565                              /usr/bin/python
00b5b000-01699000 rw-p 00000000 00:00 0                                  [heap]
34aec00000-34aec20000 r-xp 00000000 fd:00 903                            /lib64/ld-2.10.90.so
34aee1f000-34aee20000 r--p 0001f000 fd:00 903                            /lib64/ld-2.10.90.so
34aee20000-34aee21000 rw-p 00020000 fd:00 903                            /lib64/ld-2.10.90.so
34aee21000-34aee22000 rw-p 00000000 00:00 0 
34af000000-34af176000 r-xp 00000000 fd:00 904                            /lib64/libc-2.10.90.so
34af176000-34af376000 ---p 00176000 fd:00 904                            /lib64/libc-2.10.90.so
34af376000-34af37a000 r--p 00176000 fd:00 904                            /lib64/libc-2.10.90.so
34af37a000-34af37b000 rw-p 0017a000 fd:00 904                            /lib64/libc-2.10.90.so
34af37b000-34af380000 rw-p 00000000 00:00 0 
34af400000-34af402000 r-xp 00000000 fd:00 4951                           /lib64/libdl-2.10.90.so
34af402000-34af602000 ---p 00002000 fd:00 4951                           /lib64/libdl-2.10.90.so
34af602000-34af603000 r--p 00002000 fd:00 4951                           /lib64/libdl-2.10.90.so
34af603000-34af604000 rw-p 00003000 fd:00 4951                           /lib64/libdl-2.10.90.so
34af800000-34af818000 r-xp 00000000 fd:00 11420                          /lib64/libpthread-2.10.90.so
34af818000-34afa17000 ---p 00018000 fd:00 11420                          /lib64/libpthread-2.10.90.so
34afa17000-34afa18000 r--p 00017000 fd:00 11420                          /lib64/libpthread-2.10.90.so
34afa18000-34afa19000 rw-p 00018000 fd:00 11420                          /lib64/libpthread-2.10.90.so
34afa19000-34afa1d000 rw-p 00000000 00:00 0 
34afc00000-34afc83000 r-xp 00000000 fd:00 905                            /lib64/libm-2.10.90.so
34afc83000-34afe82000 ---p 00083000 fd:00 905                            /lib64/libm-2.10.90.so
34afe82000-34afe83000 r--p 00082000 fd:00 905                            /lib64/libm-2.10.90.so
34afe83000-34afe84000 rw-p 00083000 fd:00 905                            /lib64/libm-2.10.90.so
34b0000000-34b0015000 r-xp 00000000 fd:00 3685                           /lib64/libz.so.1.2.3
34b0015000-34b0214000 ---p 00015000 fd:00 3685                           /lib64/libz.so.1.2.3
34b0214000-34b0215000 rw-p 00014000 fd:00 3685                           /lib64/libz.so.1.2.3
34b0400000-34b0407000 r-xp 00000000 fd:00 11435                          /lib64/librt-2.10.90.so
34b0407000-34b0606000 ---p 00007000 fd:00 11435                          /lib64/librt-2.10.90.so
34b0606000-34b0607000 r--p 00006000 fd:00 11435                          /lib64/librt-2.10.90.so
34b0607000-34b0608000 rw-p 00007000 fd:00 11435                          /lib64/librt-2.10.90.so
34b0800000-34b081c000 r-xp 00000000 fd:00 8090                           /lib64/libselinux.so.1
34b081c000-34b0a1b000 ---p 0001c000 fd:00 8090                           /lib64/libselinux.so.1
34b0a1b000-34b0a1c000 r--p 0001b000 fd:00 8090                           /lib64/libselinux.so.1
34b0a1c000-34b0a1d000 rw-p 0001c000 fd:00 8090                           /lib64/libselinux.so.1
34b0a1d000-34b0a1e000 rw-p 00000000 00:00 0 
34b1000000-34b1016000 r-xp 00000000 fd:00 8066                           /lib64/libresolv-2.10.90.so
34b1016000-34b1216000 ---p 00016000 fd:00 8066                           /lib64/libresolv-2.10.90.so
34b1216000-34b1217000 r--p 00016000 fd:00 8066                           /lib64/libresolv-2.10.90.so
34b1217000-34b1218000 rw-p 00017000 fd:00 8066                           /lib64/libresolv-2.10.90.so
34b1218000-34b121a000 rw-p 00000000 00:00 0 
34b1800000-34b1802000 r-xp 00000000 fd:00 4729                           /usr/lib64/libXau.so.6.0.0
34b1802000-34b1a02000 ---p 00002000 fd:00 4729                           /usr/lib64/libXau.so.6.0.0
34b1a02000-34b1a03000 rw-p 00002000 fd:00 4729                           /usr/lib64/libXau.so.6.0.0
34b1c00000-34b1d39000 r-xp 00000000 fd:00 5324                           /usr/lib64/libX11.so.6.3.0
34b1d39000-34b1f39000 ---p 00139000 fd:00 5324                           /usr/lib64/libX11.so.6.3.0
34b1f39000-34b1f3f000 rw-p 00139000 fd:00 5324                           /usr/lib64/libX11.so.6.3.0
34b2000000-34b201b000 r-xp 00000000 fd:00 4780                           /usr/lib64/libxcb.so.1.1.0
34b201b000-34b221a000 ---p 0001b000 fd:00 4780                           /usr/lib64/libxcb.so.1.1.0
34b221a000-34b221b000 rw-p 0001a000 fd:00 4780                           /usr/lib64/libxcb.so.1.1.0
34b2800000-34b2811000 r-xp 00000000 fd:00 7229                           /usr/lib64/libXext.so.6.4.0
34b2811000-34b2a11000 ---p 00011000 fd:00 7229                           /usr/lib64/libXext.so.6.4.0
34b2a11000-34b2a12000 rw-p 00011000 fd:00 7229                           /usr/lib64/libXext.so.6.4.0
34b2c00000-34b2c26000 r-xp 00000000 fd:00 1337                           /lib64/libexpat.so.1.5.2
34b2c26000-34b2e25000 ---p 00026000 fd:00 1337                           /lib64/libexpat.so.1.5.2
34b2e25000-34b2e28000 rw-p 00025000 fd:00 1337                           /lib64/libexpat.so.1.5.2
34b3400000-34b3496000 r-xp 00000000 fd:00 1210                           /usr/lib64/libfreetype.so.6.3.20
34b3496000-34b3695000 ---p 00096000 fd:00 1210                           /usr/lib64/libfreetype.so.6.3.20
34b3695000-34b369b000 rw-p 00095000 fd:00 1210                           /usr/lib64/libfreetype.so.6.3.20
34b4000000-34b4026000 r-xp 00000000 fd:00 4501                           /usr/lib64/libpng12.so.0.39.0
34b4026000-34b4225000 ---p 00026000 fd:00 4501                           /usr/lib64/libpng12.so.0.39.0
34b4225000-34b4226000 rw-p 00025000 fd:00 4501                           /usr/lib64/libpng12.so.0.39.0
34b4400000-34b4434000 r-xp 00000000 fd:00 1463                           /usr/lib64/libfontconfig.so.1.4.3
34b4434000-34b4634000 ---p 00034000 fd:00 1463                           /usr/lib64/libfontconfig.so.1.4.3
34b4634000-34b4636000 rw-p 00034000 fd:00 1463                           /usr/lib64/libfontconfig.so.1.4.3
34b4800000-34b480f000 r-xp 00000000 fd:00 7315                           /usr/lib64/libXi.so.6.1.0
34b480f000-34b4a0e000 ---p 0000f000 fd:00 7315                           /usr/lib64/libXi.so.6.1.0
34b4a0e000-34b4a0f000 rw-p 0000e000 fd:00 7315                           /usr/lib64/libXi.so.6.1.0
34b4c00000-34b4c09000 r-xp 00000000 fd:00 5551                           /usr/lib64/libXrender.so.1.3.0
34b4c09000-34b4e09000 ---p 00009000 fd:00 5551                           /usr/lib64/libXrender.so.1.3.0
34b4e09000-34b4e0a000 rw-p 00009000 fd:00 5551                           /usr/lib64/libXrender.so.1.3.0
34b5400000-34b5405000 r-xp 00000000 fd:00 7561                           /usr/lib64/libXfixes.so.3.1.0
34b5405000-34b5604000 ---p 00005000 fd:00 7561                           /usr/lib64/libXfixes.so.3.1.0
34b5604000-34b5605000 rw-p 00004000 fd:00 7561                           /usr/lib64/libXfixes.so.3.1.0
34b5800000-34b5809000 r-xp 00000000 fd:00 7566                           /usr/lib64/libXcursor.so.1.0.2
34b5809000-34b5a09000 ---p 00009000 fd:00 7566                           /usr/lib64/libXcursor.so.1.0.2
34b5a09000-34b5a0a000 rw-p 00009000 fd:00 7566                           /usr/lib64/libXcursor.so.1.0.2
34b5c00000-34b5c08000 r-xp 00000000 fd:00 7413                           /usr/lib64/libXrandr.so.2.2.0
34b5c08000-34b5e07000 ---p 00008000 fd:00 7413                           /usr/lib64/libXrandr.so.2.2.0
34b5e07000-34b5e08000 rw-p 00007000 fd:00 7413                           /usr/lib64/libXrandr.so.2.2.0
34b6000000-34b6002000 r-xp 00000000 fd:00 7260                           /usr/lib64/libXinerama.so.1.0.0
34b6002000-34b6201000 ---p 00002000 fd:00 7260                           /usr/lib64/libXinerama.so.1.0.0
34b6201000-34b6202000 rw-p 00001000 fd:00 7260                           /usr/lib64/libXinerama.so.1.0.0
34b6800000-34b6858000 r-xp 00000000 fd:00 929                            /usr/lib64/libpixman-1.so.0.16.2
34b6858000-34b6a58000 ---p 00058000 fd:00 929                            /usr/lib64/libpixman-1.so.0.16.2
34b6a58000-34b6a5b000 rw-p 00058000 fd:00 929                            /usr/lib64/libpixman-1.so.0.16.2
34b7800000-34b7802000 r-xp 00000000 fd:00 7574                           /usr/lib64/libXdamage.so.1.1.0
34b7802000-34b7a01000 ---p 00002000 fd:00 7574                           /usr/lib64/libXdamage.so.1.1.0
34b7a01000-34b7a02000 rw-p 00001000 fd:00 7574                           /usr/lib64/libXdamage.so.1.1.0
34b8400000-34b8402000 r-xp 00000000 fd:00 7572                           /usr/lib64/libXcomposite.so.1.0.0
34b8402000-34b8601000 ---p 00002000 fd:00 7572                           /usr/lib64/libXcomposite.so.1.0.0
34b8601000-34b8602000 rw-p 00001000 fd:00 7572                           /usr/lib64/libXcomposite.so.1.0.0
34b9400000-34b9476000 r-xp 00000000 fd:00 6269                           /usr/lib64/libcairo.so.2.10800.8
34b9476000-34b9676000 ---p 00076000 fd:00 6269                           /usr/lib64/libcairo.so.2.10800.8
34b9676000-34b9679000 rw-p 00076000 fd:00 6269                           /usr/lib64/libcairo.so.2.10800.8
34b9c00000-34b9c1a000 r-xp 00000000 fd:00 15157                          /usr/lib64/libmagic.so.1.0.0
34b9c1a000-34b9e1a000 ---p 0001a000 fd:00 15157                          /usr/lib64/libmagic.so.1.0.0
34b9e1a000-34b9e1b000 rw-p 0001a000 fd:00 15157                          /usr/lib64/libmagic.so.1.0.0
34ba800000-34ba817000 r-xp 00000000 fd:00 13377                          /usr/lib64/libICE.so.6.3.0
34ba817000-34baa17000 ---p 00017000 fd:00 13377                          /usr/lib64/libICE.so.6.3.0
34baa17000-34baa18000 rw-p 00017000 fd:00 13377                          /usr/lib64/libICE.so.6.3.0
34baa18000-34baa1c000 rw-p 00000000 00:00 0 
34bb000000-34bb145000 r-xp 00000000 fd:00 75765                          /usr/lib64/libxml2.so.2.7.5
34bb145000-34bb345000 ---p 00145000 fd:00 75765                          /usr/lib64/libxml2.so.2.7.5
34bb345000-34bb34e000 rw-p 00145000 fd:00 75765                          /usr/lib64/libxml2.so.2.7.5
34bb34e000-34bb34f000 rw-p 00000000 00:00 0 
34bb400000-34bb403000 r-xp 00000000 fd:00 19288                          /lib64/libcom_err.so.2.1/usr/share/system-config-httpd/system-config-httpd: line 4:  8691 Aborted                 (core dumped) /usr/bin/python /usr/share/system-config-httpd/ApacheConf.py

Program exited with code 0206.
(gdb)
Comment 1 Flóki Pálsson 2009-10-20 14:53:41 EDT
Created attachment 365400 [details]
s-c-h - result in terminal

Crash in new  
system-config-httpd-1.4.6-1.fc12.noarch

see atthacment 
stared from terminal , root password, logg from terminal
Comment 2 Renich Bon Ciric 2009-11-11 02:09:55 EST
ping!
Comment 3 Bug Zapper 2009-11-16 08:35:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Watanabe Takashi 2009-11-21 00:11:48 EST
Hello.

This bug may be buffer overrun in alchemist.

diff -up alchemist-1.0.37/src/refstr.c.orig alchemist-1.0.37/src/refstr.c
--- alchemist-1.0.37/src/refstr.c.orig	2009-11-20 02:47:57.739762988 +0900
+++ alchemist-1.0.37/src/refstr.c	2009-11-20 02:47:40.739667841 +0900
@@ -123,7 +123,7 @@ refstr_malloc_refstr(const char * str, s
 	char *string;
 
 	/* malloc space for the meta data and the string */
-	rstr_h_p = (refstr_head *) malloc (sizeof(refstr_head) + s_len); 
+	rstr_h_p = (refstr_head *) malloc (sizeof(refstr_head) + s_len + 1); 
 
 	/* copy the string, the length, and init the refcount */
 	string = (char *) &rstr_h_p->string;
Comment 5 Robert Laverick 2009-12-04 04:16:40 EST
I'm still seeing this error, and I don't see any builds of system-config-httpd or alchemist in koji, is someone able to apply the patch in comment #4 ?
Comment 6 Robert Laverick 2009-12-04 05:14:40 EST
ok, I've done the decent thing and worked out how to test the patch myself, with the code change from comment #4 I am still unable to run system-config-httpd, I get the same error with only the addresses different (obviosuly).

So as far as I can tell this isn't related to the code change mentioned. I'm new to all this, and don't even know any c so I'm hardly in a position to know if the fix mentioned is relevant or not, but for me it doesn't seem to fix the problem.
Comment 7 Phil Knirsch 2009-12-08 07:54:04 EST
*** Bug 542534 has been marked as a duplicate of this bug. ***
Comment 8 Phil Knirsch 2009-12-08 07:54:56 EST
*** Bug 542792 has been marked as a duplicate of this bug. ***
Comment 9 Phil Knirsch 2009-12-08 08:10:02 EST
*** Bug 544202 has been marked as a duplicate of this bug. ***
Comment 10 Phil Knirsch 2009-12-08 08:13:51 EST
Sorry for the late response, been a bit underwater here lately with work.

Anyway, this looks like a bug in alchemist, but i wanted to get rid of using it
for a while anyway.

So most likely i'll just rewrite the backend code of s-c-h. I hope to get to
that over the holidays, so bear with me till early January for a fix.

I might be able to come up with a "workaround" but need to see if i can still
find the old code for my alchemist written completely in python.

Thanks & regards, Phil
Comment 11 Renich Bon Ciric 2009-12-08 12:18:19 EST
Thank you very much, Phil, for the effort ;)
Comment 12 Phil Knirsch 2009-12-09 09:28:57 EST
Ok, very brief heads up: As it really bothered my yesterday evening i dug out some very old code i had where i implemented the alchemist completely in python in single day.

It needed a bit of tweaking here and there but it's working now on my local box so the C part of alchemist isn't needed anymore, at least for my code. And as far as i can tell s-c-h is the last consumer of alchemist, so we might be able to just drop it completely real soon then.

I'll run a few more tests in the next few days. If all goes well i'll post a workaround here for now. You'll basically have to copy 2 files into your /usr/lib[64]/python2.6/site-packages directory then, one of them basically enhancing the original Alchemist.py to support PyAlchemist and the PyAlchemist.py itself.

Thanks & regards, Phil
Comment 13 Shawn Rhode 2010-01-08 12:12:35 EST
Phil,
  Were you able to get the workaround tested for this yet?
Comment 14 Phil Knirsch 2010-01-11 07:59:23 EST
Ah ye, i did the tests and they seem to work nicely. I'll put up the new files on my fedora page today or tomorrow with a quick guide how to use them here.

Sorry for the delay.

Thanks & regards, Phil
Comment 15 Phil Knirsch 2010-01-14 07:43:45 EST
OK, finally copied the files over. Quick guide for the workaround:

Copy the files

http://pknirsch.fedorapeople.org/src/Alchemist.py
http://pknirsch.fedorapeople.org/src/PyAlchemist.py

to your python site packages directory, which can be typically found here:

/usr/lib/python2.6/site-packages

or

/usr/lib64/python2.6/site-packages

Afterwards just start system-config-httpd as before and it shouldn't crash anymore. It might be a tad slower and use a bit more memory, but for the amount of data we use in Alchemist this shouldn't be noticeable.

Please give me a heads-up if this works for you and i'll coordinate with Tim Waugh (maintainer of alchemist) to drop Alchemist and i'll integrate those changes directly into s-c-h.

Thanks & regards, Phil
Comment 16 Robert Laverick 2010-01-14 07:57:30 EST
That hasn't worked for me, I still get the crash.

Do I need to un-install the current alchemist?

I noticed that the pyalchemist files that are already in that directory are not currently capitalised as your file names are, could that be an issue?
Comment 17 Robert Laverick 2010-01-14 08:00:57 EST
actually strike that, it doesn't look like the same crash...

*** buffer overflow detected ***: /usr/bin/python terminated
======= Backtrace: =========
/lib64/libc.so.6(__fortify_fail+0x37)[0x3754cf75e7]
/lib64/libc.so.6[0x3754cf5600]
/lib64/libc.so.6(__strncpy_chk+0x17b)[0x3754cf48bb]
/usr/lib64/libalchemist.so.0(refstr_nget+0x270)[0x7f38b610ca20]
/usr/lib64/libalchemist.so.0(AdmContext_new+0x99)[0x7f38b61054d9]
/usr/lib64/libalchemist.so.0(_adm_parse_start_element+0x98e)[0x7f38b6108ece]
/lib64/libglib-2.0.so.0[0x375683f482]
/lib64/libglib-2.0.so.0(g_markup_parse_context_parse+0x1052)[0x3756840eb2]
/usr/lib64/libalchemist.so.0(AdmContext_fromXML+0x7b)[0x7f38b61083bb]
/usr/lib64/python2.6/site-packages/_alchemistmodule.so(+0x553c)[0x7f38b631b53c]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5282)[0x37614dca82]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x37614de4e5]
/usr/lib64/libpython2.6.so.1.0[0x376146dbcb]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0[0x3761458a5f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x37614d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyInstance_New+0x76)[0x37614581b6]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x4d8d)[0x37614dc58d]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5877)[0x37614dd077]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x37614de4e5]
/usr/lib64/libpython2.6.so.1.0[0x376146dbcb]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0[0x3761458a5f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x37614d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyInstance_New+0x76)[0x37614581b6]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x4d8d)[0x37614dc58d]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x37614de4e5]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCode+0x32)[0x37614de5f2]
/usr/lib64/libpython2.6.so.1.0(PyImport_ExecCodeModuleEx+0xc2)[0x37614ee582]
/usr/lib64/libpython2.6.so.1.0[0x37614eea66]
/usr/lib64/libpython2.6.so.1.0[0x37614eff85]
/usr/lib64/libpython2.6.so.1.0[0x37614f0214]
/usr/lib64/libpython2.6.so.1.0[0x37614f0862]
/usr/lib64/libpython2.6.so.1.0(PyImport_ImportModuleLevel+0x44)[0x37614f0dc4]
/usr/lib64/libpython2.6.so.1.0[0x37614d674f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x37614d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x1e31)[0x37614d9631]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x37614de4e5]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCode+0x32)[0x37614de5f2]
/usr/lib64/libpython2.6.so.1.0(PyImport_ExecCodeModuleEx+0xc2)[0x37614ee582]
/usr/lib64/libpython2.6.so.1.0[0x37614eea66]
/usr/lib64/libpython2.6.so.1.0[0x37614eff85]
/usr/lib64/libpython2.6.so.1.0[0x37614f0214]
/usr/lib64/libpython2.6.so.1.0[0x37614f0862]
/usr/lib64/libpython2.6.so.1.0(PyImport_ImportModuleLevel+0x44)[0x37614f0dc4]
/usr/lib64/libpython2.6.so.1.0[0x37614d674f]
/usr/lib64/libpython2.6.so.1.0(PyObject_Call+0x53)[0x3761443b33]
/usr/lib64/libpython2.6.so.1.0(PyEval_CallObjectWithKeywords+0x43)[0x37614d6cc3]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x1e31)[0x37614d9631]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x875)[0x37614de4e5]
/usr/lib64/libpython2.6.so.1.0(PyEval_EvalCode+0x32)[0x37614de5f2]
/usr/lib64/libpython2.6.so.1.0[0x37614f965c]
/usr/lib64/libpython2.6.so.1.0(PyRun_FileExFlags+0x90)[0x37614f9730]
/usr/lib64/libpython2.6.so.1.0(PyRun_SimpleFileExFlags+0xdc)[0x37614fab0c]
/usr/lib64/libpython2.6.so.1.0(Py_Main+0xaa9)[0x3761507389]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x3754c1eb1d]
/usr/bin/python[0x400649]
======= Memory map: ========
00400000-00401000 r-xp 00000000 fd:00 42749                              /usr/bin/python
00600000-00602000 rw-p 00000000 fd:00 42749                              /usr/bin/python
00d8e000-01773000 rw-p 00000000 00:00 0                                  [heap]
3754800000-375481e000 r-xp 00000000 fd:00 5756                           /lib64/ld-2.11.1.so
3754a1d000-3754a1e000 r--p 0001d000 fd:00 5756                           /lib64/ld-2.11.1.so
3754a1e000-3754a1f000 rw-p 0001e000 fd:00 5756                           /lib64/ld-2.11.1.so
3754a1f000-3754a20000 rw-p 00000000 00:00 0 
3754c00000-3754d6f000 r-xp 00000000 fd:00 11744                          /lib64/libc-2.11.1.so
3754d6f000-3754f6f000 ---p 0016f000 fd:00 11744                          /lib64/libc-2.11.1.so
3754f6f000-3754f73000 r--p 0016f000 fd:00 11744                          /lib64/libc-2.11.1.so
3754f73000-3754f74000 rw-p 00173000 fd:00 11744                          /lib64/libc-2.11.1.so
3754f74000-3754f79000 rw-p 00000000 00:00 0 
3755000000-3755002000 r-xp 00000000 fd:00 82190                          /lib64/libdl-2.11.1.so
3755002000-3755202000 ---p 00002000 fd:00 82190                          /lib64/libdl-2.11.1.so
3755202000-3755203000 r--p 00002000 fd:00 82190                          /lib64/libdl-2.11.1.so
3755203000-3755204000 rw-p 00003000 fd:00 82190                          /lib64/libdl-2.11.1.so
3755400000-3755417000 r-xp 00000000 fd:00 14026                          /lib64/libpthread-2.11.1.so
3755417000-3755616000 ---p 00017000 fd:00 14026                          /lib64/libpthread-2.11.1.so
3755616000-3755617000 r--p 00016000 fd:00 14026                          /lib64/libpthread-2.11.1.so
3755617000-3755618000 rw-p 00017000 fd:00 14026                          /lib64/libpthread-2.11.1.so
3755618000-375561c000 rw-p 00000000 00:00 0 
3755800000-3755883000 r-xp 00000000 fd:00 9817                           /lib64/libm-2.11.1.so
3755883000-3755a82000 ---p 00083000 fd:00 9817                           /lib64/libm-2.11.1.so
3755a82000-3755a83000 r--p 00082000 fd:00 9817                           /lib64/libm-2.11.1.so
3755a83000-3755a84000 rw-p 00083000 fd:00 9817                           /lib64/libm-2.11.1.so
3755c00000-3755c15000 r-xp 00000000 fd:00 82186                          /lib64/libz.so.1.2.3
3755c15000-3755e14000 ---p 00015000 fd:00 82186                          /lib64/libz.so.1.2.3
3755e14000-3755e15000 rw-p 00014000 fd:00 82186                          /lib64/libz.so.1.2.3
3756000000-3756007000 r-xp 00000000 fd:00 14226                          /lib64/librt-2.11.1.so
3756007000-3756206000 ---p 00007000 fd:00 14226                          /lib64/librt-2.11.1.so
3756206000-3756207000 r--p 00006000 fd:00 14226                          /lib64/librt-2.11.1.so
3756207000-3756208000 rw-p 00007000 fd:00 14226                          /lib64/librt-2.11.1.so
3756400000-375641c000 r-xp 00000000 fd:00 3479                           /lib64/libselinux.so.1
375641c000-375661b000 ---p 0001c000 fd:00 3479                           /lib64/libselinux.so.1
375661b000-375661c000 r--p 0001b000 fd:00 3479                           /lib64/libselinux.so.1
375661c000-375661d000 rw-p 0001c000 fd:00 3479                           /lib64/libselinux.so.1
375661d000-375661e000 rw-p 00000000 00:00 0 
3756800000-37568e4000 r-xp 00000000 fd:00 13990                          /lib64/libglib-2.0.so.0.2200.3
37568e4000-3756ae4000 ---p 000e4000 fd:00 13990                          /lib64/libglib-2.0.so.0.2200.3
3756ae4000-3756ae5000 rw-p 000e4000 fd:00 13990                          /lib64/libglib-2.0.so.0.2200.3
3756ae5000-3756ae6000 rw-p 00000000 00:00 0 
3756c00000-3756c43000 r-xp 00000000 fd:00 82194                          /lib64/libgobject-2.0.so.0.2200.3
3756c43000-3756e43000 ---p 00043000 fd:00 82194                          /lib64/libgobject-2.0.so.0.2200.3
3756e43000-3756e45000 rw-p 00043000 fd:00 82194                          /lib64/libgobject-2.0.so.0.2200.3
3757000000-3757015000 r-xp 00000000 fd:00 82207                          /lib64/libresolv-2.11.1.so
3757015000-3757215000 ---p 00015000 fd:00 82207                          /lib64/libresolv-2.11.1.so
3757215000-3757216000 r--p 00015000 fd:00 82207                          /lib64/libresolv-2.11.1.so
3757216000-3757217000 rw-p 00016000 fd:00 82207                          /lib64/libresolv-2.11.1.so
3757217000-3757219000 rw-p 00000000 00:00 0 
3757400000-375743f000 r-xp 00000000 fd:00 81288                          /lib64/libdbus-1.so.3.4.0
375743f000-375763f000 ---p 0003f000 fd:00 81288                          /lib64/libdbus-1.so.3.4.0
375763f000-3757640000 r--p 0003f000 fd:00 81288                          /lib64/libdbus-1.so.3.4.0
3757640000-3757641000 rw-p 00040000 fd:00 81288                          /lib64/libdbus-1.so.3.4.0/usr/share/system-config-httpd/system-config-httpd: line 4: 20129 Aborted                 (core dumped) /usr/bin/python /usr/share/system-config-httpd/ApacheConf.py
Comment 18 Robert G. 'Doc' Savage 2010-01-14 09:19:36 EST
I can confirm Robert Laverick's report. Same error.
Comment 19 Domingo Becker 2010-01-14 11:02:15 EST
Same error too, as comment 17.
Comment 20 Shawn Rhode 2010-01-14 11:23:42 EST
***This may show up twice due to email delays, but I want to make sure it is here***
Phil,
  The issue is that the updated Alchemist.py file has use_pyalchemist set to False.  This causes it to not use the PyAlchemist file that you posted above and to use the old files that cause the issue.  Here is the diff output that shows the change I made.  It works after doing this:

--- Alchemist.py.1      2010-01-14 07:39:24.000000000 -0500
+++ Alchemist.py        2010-01-14 11:13:15.802182977 -0500
@@ -18,7 +18,7 @@
 ## along with this program; if not, write to the Free Software
 ## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-use_pyalchemist = False
+use_pyalchemist = True
 
 if use_pyalchemist:
        from PyAlchemist import *
Comment 21 Domingo Becker 2010-01-14 11:34:08 EST
I can confirm it works with use_pyalchemist = True

Many thanks
Comment 22 Robert G. 'Doc' Savage 2010-01-14 12:52:18 EST
There are a couple of new warnings reported in the calling window, but nothing serious:

# system-config-httpd
/usr/share/system-config-httpd/ApacheConf.py:55: Warning: g_set_prgname() called multiple times
  gnome.program_init(PROGNAME, "1.4.5")
/usr/share/system-config-httpd/ApacheConf.py:68: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  xml = gtk.glade.XML (glade_file, domain=PROGNAME)
/usr/share/system-config-httpd/CheckList.py:12: DeprecationWarning: use gtk.TreeView
  CList.__init__ (self, 2)
/usr/share/system-config-httpd/ApacheConf.py:122: DeprecationWarning: use gtk.TreeView
  gtk.CList.__init__ (self, 3, [_("Error Code"), _("Behavior"), _("Location")])

The GUI that opens up seems to work just fine. Thanks a bunch.
Comment 23 Phil Knirsch 2010-01-15 08:40:05 EST
Ah, ye, forgot to change the flag there. Fixed in the latest upload now by default.

But if this works fine with everyone i'll talk with Tim Waugh to make the transition away from the original alchemist work.

Thanks everyone for testing!

Regards, Phil
Comment 24 Phil Knirsch 2010-01-15 08:45:19 EST
And ye, i know about the warnings, they come from the fact that the glade and UI stuff is basically still using very old and outdated widgets. Hopefully i'll find some time soon to fix those and rework the UI to use modern widgets, but no promises at the moment.

Thanks & regards, Phil
Comment 25 Phil Knirsch 2010-01-25 09:36:28 EST
*** Bug 557675 has been marked as a duplicate of this bug. ***
Comment 26 Runwalsoft 2010-01-26 08:09:53 EST
i also have same kind of problem.
Comment 27 Phil Knirsch 2010-02-18 07:09:39 EST
*** Bug 561460 has been marked as a duplicate of this bug. ***
Comment 28 Phil Knirsch 2010-02-18 07:10:03 EST
*** Bug 565596 has been marked as a duplicate of this bug. ***
Comment 29 Phil Knirsch 2010-02-18 07:13:23 EST
*** Bug 561601 has been marked as a duplicate of this bug. ***
Comment 30 Phil Knirsch 2010-02-18 07:14:03 EST
*** Bug 554623 has been marked as a duplicate of this bug. ***
Comment 31 Phil Knirsch 2010-03-03 05:24:11 EST
*** Bug 570049 has been marked as a duplicate of this bug. ***
Comment 32 Sascha Zantis 2010-03-08 05:30:30 EST
Works fine for me, but use_pyalchemist is still false by default.
Thanks for the workaround.
Comment 33 Duncan Starkey 2010-03-16 18:56:00 EDT

How to reproduce
-----
1.Gnome=>System=>Administration=>HTTP
2.
3.
Comment 34 Laurent Le Calvez 2010-03-18 05:10:05 EDT
Hopefully i discovered the problem yesterday and the solution is perfectly working.
Thanks
Comment 35 Gilles J. Seguin 2010-03-19 11:52:18 EDT
Same as #22
Comment 36 Phil Knirsch 2010-03-22 12:41:04 EDT
Sorry for not updating here in a while, but i've just been insanely busy lately.

I'll try to get new packages built real soon now(tm), but it needed to be coordinated with the alchemist maintainer, but we're in sync now for a while so it shouldn't cause too much havok. :)

I'll update the bz as soon as new packages are built.

And again, sorry for the delay here, and thanks everyone for testing the changes!

Regards, Phil
Comment 37 jcope 2010-03-29 14:33:30 EDT

Comment
-----
no idea.
Comment 38 jcope 2010-03-29 16:12:48 EDT

Comment
-----
no idea.
Comment 39 Patrick Massey 2010-04-02 15:54:43 EDT
Fix works perfect on F12 x64.
Comment 40 Phil Knirsch 2010-04-13 11:01:58 EDT
*** Bug 578792 has been marked as a duplicate of this bug. ***
Comment 41 Phil Knirsch 2010-04-13 11:03:18 EDT
*** Bug 573688 has been marked as a duplicate of this bug. ***
Comment 42 Phil Knirsch 2010-04-13 11:03:35 EDT
*** Bug 572251 has been marked as a duplicate of this bug. ***
Comment 43 John J. McDonough 2010-04-21 08:46:05 EDT
Same result F13 Beta updated as of today. (1.4.6-1)
Comment 44 Cia Watson 2010-05-09 11:58:27 EDT
Same here as 43, system-config-httpd-1.4.6-1.fc13.noarch and just adding myself to the mail list.
Comment 45 Phil Knirsch 2010-05-18 05:22:05 EDT
*** Bug 584214 has been marked as a duplicate of this bug. ***
Comment 46 Phil Knirsch 2010-05-19 04:37:56 EDT
Alright, after such an insane delay i've finally had some time to fix up the last few tidbits for a release.

Rawhide build is done, can be found here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2196408

Please give it a whirl and let me know if it works for you. If so, then i'll go and do updates for F12 and F13 afterwards.

Again sorry for the insane delay here.

Thanks & regards, Phil
Comment 47 Robert G. 'Doc' Savage 2010-05-19 08:48:47 EDT
Phil,

Looks pretty good. I did find one minor error.
---------------------------
Click on  + Add
Select    * Listen to all addresses
Click on  OK
Error:    Inserted IP address is not valid
---------------------------
Simple work around: Use 0.0.0.0 as listen address.

Also three minor warnings in the calling window:

/usr/share/system-config-httpd/ApacheConf.py:68: GtkWarning: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  xml = gtk.glade.XML (glade_file, domain=PROGNAME)
/usr/share/system-config-httpd/CheckList.py:12: DeprecationWarning: use gtk.TreeView
  CList.__init__ (self, 2)
/usr/share/system-config-httpd/ApacheConf.py:122: DeprecationWarning: use gtk.TreeView
  gtk.CList.__init__ (self, 3, [_("Error Code"), _("Behavior"), _("Location")])

--Doc
Comment 48 Phil Knirsch 2010-05-19 09:31:30 EDT
Ok, fixed the first one, easy fix.

The warnings in the console come from the fact that i haven't had time yet to properly convert s-c-h to gnome-2, so thats expected. Not sure when (if) i find the time to do so anytime soon, but you never know. :)

I'll get s-c-h-1.5.1 built in a few minutes with the fix for the IP dialog.

Thanks & regards, Phil
Comment 49 Phil Knirsch 2010-05-19 09:44:58 EDT
Build just finished:

http://kojipkgs.fedoraproject.org/packages/system-config-httpd/1.5.1/1.fc14/noarch/system-config-httpd-1.5.1-1.fc14.noarch.rpm

That should fix the ip address problem.
Comment 50 Robert G. 'Doc' Savage 2010-05-19 10:10:40 EDT
Phil,

That did it. Looks ready to go. Thanks very much.

--Doc

(BTW, I'm testing on 64-bit F13beta w/updates.)
Comment 51 Need Real Name 2010-05-19 10:23:28 EDT
Working here on fedora 12.

Thanks for your efforts.  I know in the big picture this is a small thing, cli option is fine, but this is definitely is a nice to have.
Comment 52 Elad Alfassa 2010-05-19 11:54:52 EDT
can you push that as an update for fedora 13?
Comment 53 Fedora Update System 2010-05-20 07:26:31 EDT
system-config-httpd-1.5.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-httpd-1.5.1-1.fc13
Comment 54 Fedora Update System 2010-05-20 07:35:14 EDT
system-config-httpd-1.5.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-httpd-1.5.1-1.fc12
Comment 55 Phil Knirsch 2010-05-20 07:38:18 EDT
Alright, seems it works for most folks, so i'll go ahead and do proper builds
for F12 and F13 today.

Builds and update requests are done. Thanks again everyone for being so patient!

Regards, Phil
Comment 56 Phil Knirsch 2010-05-20 12:52:19 EDT
*** Bug 586666 has been marked as a duplicate of this bug. ***
Comment 57 Phil Knirsch 2010-05-20 12:56:57 EDT
*** Bug 586084 has been marked as a duplicate of this bug. ***
Comment 58 Phil Knirsch 2010-05-20 12:57:39 EDT
*** Bug 583174 has been marked as a duplicate of this bug. ***
Comment 59 Phil Knirsch 2010-05-20 12:59:29 EDT
*** Bug 544191 has been marked as a duplicate of this bug. ***
Comment 60 Phil Knirsch 2010-05-20 13:00:10 EDT
*** Bug 544208 has been marked as a duplicate of this bug. ***
Comment 61 Fedora Update System 2010-05-20 14:47:31 EDT
system-config-httpd-1.5.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-httpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-httpd-1.5.1-1.fc12
Comment 62 Fedora Update System 2010-05-20 14:48:06 EDT
system-config-httpd-1.5.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 63 Fedora Update System 2010-06-07 18:17:45 EDT
system-config-httpd-1.5.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.