Bug 52950 - Voodoo4 3D scrambled
Summary: Voodoo4 3D scrambled
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Triaged
: 53589 54954 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 09:04 UTC by Harald Hoyer
Modified: 2007-04-18 16:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 12:07:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
atlatis screensaver (99.22 KB, image/png)
2001-08-31 09:05 UTC, Harald Hoyer
no flags Details
sproingies screensaver (101.76 KB, image/png)
2001-08-31 09:06 UTC, Harald Hoyer
no flags Details
XFree86.0.log (23.38 KB, text/plain)
2001-08-31 09:08 UTC, Harald Hoyer
no flags Details
XF86Config-4 (2.11 KB, text/plain)
2001-08-31 09:09 UTC, Harald Hoyer
no flags Details
see the fish corrupted at the border of the window (32.15 KB, image/png)
2001-08-31 09:15 UTC, Harald Hoyer
no flags Details

Description Harald Hoyer 2001-08-31 09:04:46 UTC
3D looks like some points have (0,0,0)

XFree86-4.1.0-1, kernel-2.4.7-3, Mesa-3.4.2-7

01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 4 (rev 
01) (prog-if 00 [VGA])
        Subsystem: 3Dfx Interactive, Inc.: Unknown device 0004
        Flags: 66Mhz, fast devsel, IRQ 11
        Memory at c8000000 (32-bit, non-prefetchable) [size=128M]
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at d800 [size=256]
        Expansion ROM at d7ff0000 [disabled] [size=64K]
        Capabilities: [54] AGP version 2.0
        Capabilities: [60] Power Management version 2

Comment 1 Harald Hoyer 2001-08-31 09:05:53 UTC
Created attachment 30274 [details]
atlatis screensaver

Comment 2 Harald Hoyer 2001-08-31 09:06:52 UTC
Created attachment 30275 [details]
sproingies screensaver

Comment 3 Harald Hoyer 2001-08-31 09:08:02 UTC
Created attachment 30276 [details]
XFree86.0.log

Comment 4 Harald Hoyer 2001-08-31 09:09:07 UTC
Created attachment 30277 [details]
XF86Config-4

Comment 5 Harald Hoyer 2001-08-31 09:09:55 UTC
The first picture is from atlantis. As soon as the fish reach the window 
border, it gets corrupted...  The next is from sproingies. This is like quake, 
totally scrambled... 


Comment 6 Harald Hoyer 2001-08-31 09:11:07 UTC
And the fish get also scrambled, if a window is over the atlantis window.



Comment 7 Harald Hoyer 2001-08-31 09:15:32 UTC
Created attachment 30278 [details]
see the fish corrupted at the border of the window

Comment 8 Mike A. Harris 2001-10-11 19:17:51 UTC
Could be issue with Glide.

Comment 9 Mike A. Harris 2001-10-15 09:31:59 UTC
*** Bug 53589 has been marked as a duplicate of this bug. ***

Comment 10 Mike A. Harris 2002-03-14 17:38:36 UTC
Deferring for future

Comment 11 Mike A. Harris 2002-11-04 12:03:20 UTC
I've got an Austrian Voodoo 5 card now.  Here me now, and believe me latah
and we'll talk about it some othah time.

Comment 12 Mike A. Harris 2002-12-19 09:24:56 UTC
*** Bug 54954 has been marked as a duplicate of this bug. ***

Comment 14 Harald Hoyer 2004-09-27 07:46:51 UTC
sorry, I do not have the card anymore :-/

Comment 15 Mike A. Harris 2004-10-14 19:00:38 UTC
No prob, I've got one here to poke at sometime...

Going to downgrade this bug from FC3Target to FC4Target though
as we don't know if the bug is actually reproduceable in FC3
or not.

Setting status to "DEFERRED" for review in FC4 devel cycle.

Comment 16 Mike A. Harris 2005-04-20 12:07:33 UTC
We don't support 3Dfx 3D accel anymore...  Closing WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.