Bug 530085 - [or_IN] [mr_IN] [hi_IN] window titlebar has horizontal line
[or_IN] [mr_IN] [hi_IN] window titlebar has horizontal line
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-themes (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 574354
  Show dependency treegraph
 
Reported: 2009-10-21 09:59 EDT by A S Alam
Modified: 2013-07-02 20:55 EDT (History)
9 users (show)

See Also:
Fixed In Version: gnome-themes-2.28.1-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 526396
: 574354 (view as bug list)
Environment:
Last Closed: 2010-04-10 06:30:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
or_IN Screenshot with gedit, kwrite, and gnome-terminal, (95.12 KB, image/png)
2009-10-21 09:59 EDT, A S Alam
no flags Details
taken evince screenshot in kannada locale (24.61 KB, image/png)
2010-03-22 04:10 EDT, Pravin Satpute
no flags Details
Patch for gnome-themes Clearlooks/metacity-theme-1.xml (3.60 KB, patch)
2010-03-29 05:38 EDT, fujiwara
no flags Details | Diff
Patch for gnome-themes Clearlooks/metacity-theme-1.xml (6.33 KB, patch)
2010-03-29 07:19 EDT, fujiwara
no flags Details | Diff
Patch for gnome-themes Clearlooks/metacity-theme-1.xml (25.75 KB, patch)
2010-03-30 04:12 EDT, fujiwara
no flags Details | Diff

  None (edit)
Description A S Alam 2009-10-21 09:59:46 EDT
Created attachment 365513 [details]
or_IN Screenshot with gedit, kwrite, and gnome-terminal,

Bug is clone because of Nature for Bug is same, Actually Bug for Ref is Bz #523454

+++ This bug was initially created as a clone of Bug #526396 +++

Created an attachment (id=363117)
The affected theme snapshot with meera font

Description of problem:
For any editor e.g. oowriter, gedit, when smc-meera-font is selected, its showing underline below the Title, making the editor look ugly.
Seems a clearlooks-compact-gnome-theme bug.

Version-Release number of selected component (if applicable):
metacity-2.26.0-1.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1. Login system with malayalam locale. (ml_IN)
2. Go to System --> Preferences --> Appearance
3. Select Theme as "Clearlooks"
4. Open and Observe any editor or the theme window title itself.
  
Actual results:
The Underline appears on the Title Window with meera font and clearlooks combination.

Expected results:
Underline should not appear.
Comment 1 A S Alam 2009-10-21 10:02:10 EDT
Detail

Language: Oriya (or_IN)
Font: lohit-oriya-fonts-2.4.3-2.fc12.noarch
fontconfig-2.7.3-1.fc12.x86_64
Fedora: Rawhide (20Oct2009)
Installation: Fresh installation
Comment 2 Pravin Satpute 2009-10-23 07:29:28 EDT
here we dont have a scaling rules, like we have for meera fonts
so dont looks like fontconfig bug,

i guess there is some problem in fedora default theme only
reassigning to gnome-theme

while testing this bug, after login in or_IN locale, bug appears with Kwrite and firefox application

if we set window title font Lohit-Hindi, then everything works fine
Comment 3 Bug Zapper 2009-11-16 08:57:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Pravin Satpute 2009-12-10 04:16:40 EST
while testing same for other locale i found problem there as well
Comment 5 Manoj Kumar Giri 2009-12-21 06:58:34 EST
I faced the same problem while testing for Oriya interface (or_IN) in most of the applications in Rawhide.
Comment 6 Pravin Satpute 2010-03-22 03:37:03 EDT
i tested with changing 'hhea' true type fonts table in lohit fonts.
but this is different problem

whenever we login in any indic locale or sinhala says, things work well as far
windows title bar text is in local script.

but as soon as we open any application having titlebar in ascii, title bar
border gets displaced and its make appearances bad.

just border line placements keeps on varying as per default local script fonts
and ascii script fonts
Comment 7 Pravin Satpute 2010-03-22 04:10:19 EDT
Created attachment 401665 [details]
taken evince screenshot in kannada locale

if we open any other application having titlebar test in current locale script, it show titlebar proper without any problem of border misplacement
Comment 8 Pravin Satpute 2010-03-24 05:24:13 EDT
filed upstream bug against GTK+

https://bugzilla.gnome.org/show_bug.cgi?id=613778
Comment 9 fujiwara 2010-03-26 05:55:34 EDT
I guess bug 574354 is duplicated.

Fedora theme is ClearLooks and some other themes work fine.
Probably I think downing the line position is better than narrowing the title height.
The following is the workaround but still needs the better fix.

--- /usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml.orig	2010-03-25 22:15:04.000000000 +0900
+++ /usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml	2010-03-26 18:39:30.000000000 +0900
@@ -223,7 +223,7 @@
 		<color value="shade/gtk:bg[SELECTED]/1.02"/>
 	</gradient>
 
-	<line color="shade/gtk:bg[SELECTED]/0.7" x1="1" y1="title_height + 6" x2="width - 2" y2="title_height + 6"/>
+	<line color="shade/gtk:bg[SELECTED]/0.7" x1="1" y1="title_height + 10" x2="width - 2" y2="title_height + 10"/>
 
 	<!-- ** border outline ** -->
 	<line color="shade/gtk:bg[NORMAL]/0.45" x1="0" y1="title_height + 6" x2="0" y2="height"/>
@@ -290,7 +290,7 @@
 		<color value="shade/gtk:bg[NORMAL]/0.95"/>
 	</gradient>
 
-	<line color="shade/gtk:bg[NORMAL]/0.65" x1="1" y1="title_height + 6" x2="width - 2" y2="title_height + 6"/>
+	<line color="shade/gtk:bg[NORMAL]/0.65" x1="1" y1="title_height + 10" x2="width - 2" y2="title_height + 10"/>
 	<rectangle color="shade/gtk:bg[NORMAL]/0.55" filled="false" x="0" y="0" width="width - 1" height="height - 1"/>
 </draw_ops>
Comment 10 fujiwara 2010-03-29 05:38:32 EDT
Created attachment 403248 [details]
Patch for gnome-themes Clearlooks/metacity-theme-1.xml

If my suggestion is ok, I'll file an upstream bug later.

fill_env() assigns title_height and top_height in metacity ui/theme.c

fill_env ()
{
      env->top_height = info->fgeom->top_height;
  env->title_height = info->title_layout_height;
}

meta_frame_style_draw_with_style() calculates the font height and assigns the value in title_height.

meta_frame_style_draw_with_style ()
{
    pango_layout_get_pixel_extents (title_layout,
                                    NULL, &extents);

  draw_info.title_layout_height = title_layout ? extents.height : 0;
}

But meta_frame_layout_get_borders() calculates top_height with text_height + title_border.top + title_border.bottom so I think using top_height makes sense for the title vertical line.

meta_frame_layout_get_borders ()
{
  buttons_height = layout->button_height +
    layout->button_border.top + layout->button_border.bottom;
  title_height = text_height +
    layout->title_vertical_pad +
    layout->title_border.top + layout->title_border.bottom;

  if (top_height)
    {
      *top_height = MAX (buttons_height, title_height);
    }
}

fill_env() doesn't use info->fgeom->bottom_titlebar_edge so my suggestion is to use "top_height - 3".
Comment 11 fujiwara 2010-03-29 05:42:05 EDT
(In reply to comment #10)
> But meta_frame_layout_get_borders() calculates top_height with text_height +
> title_border.top + title_border.bottom so I think using top_height makes sense
> for the title vertical line.

s/vertical line/horizontal line/
Comment 12 Pravin Satpute 2010-03-29 06:10:43 EDT
hi
i tried patch in comment #10 in fedora 13 but still no positive result

i followed following stpes:

1) apply patch to /usr/share/themes/Clearlooks/metacity-1/metacity-theme-1.xml
2) logoff and login in kn_IN (Kannada) locale
3) open any application having titlebar in latin/ascii 
4) open gnome-terminal or evince
5) Maximize windows you can see underline again in titlebar

looks like we need some fix from GTK or metacity itself
Comment 13 fujiwara 2010-03-29 06:37:27 EDT
Thanks for the quick test.

(In reply to comment #12)
> 5) Maximize windows you can see underline again in titlebar

Ah, I forgot to modify the maximize property.
The value is also saved in the same metacity-theme-1.xml

I'll update it tomorrow.
Comment 14 fujiwara 2010-03-29 07:19:25 EDT
Created attachment 403267 [details]
Patch for gnome-themes Clearlooks/metacity-theme-1.xml

(In reply to comment #13)
> I'll update it tomorrow.    

Revised the patch.
Comment 15 Pravin Satpute 2010-03-29 08:06:29 EDT
fujiwara thats great!!
It works fine now, i also tested for other locale things look fine 
so it is not creating any regression as well

it is also fixing long standing https://bugzilla.redhat.com/show_bug.cgi?id=523454


Matthias can you take a look at it?
Comment 16 fujiwara 2010-03-30 04:12:14 EDT
Created attachment 403428 [details]
Patch for gnome-themes Clearlooks/metacity-theme-1.xml

Also applied the similar fix to ClearlooksClassic, Glossy and Inverted metacity themes.

It seems today gnome-themes was updated in rawhide. I'll check it later.
Comment 18 A S Alam 2010-04-02 22:39:43 EDT
Fedora 13, with gnome-2-30 (gnome-themes-2.30.0-2.fc13.noarch), Punjabi (pa_IN)
locale is effected.
Comment 19 Fedora Update System 2010-04-07 07:15:40 EDT
gnome-themes-2.28.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gnome-themes-2.28.1-3.fc12
Comment 20 Fedora Update System 2010-04-08 21:38:17 EDT
gnome-themes-2.28.1-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-themes'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-themes-2.28.1-3.fc12
Comment 21 Pravin Satpute 2010-04-09 00:34:49 EDT
did we missed pushing this update for F13?
i have tested same for F13 and its working fine, so i can quickly add 1 karma for it :)
Comment 22 Fedora Update System 2010-04-10 06:30:09 EDT
gnome-themes-2.28.1-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.