Bug 53192 - xsnow is behind nautilus
Summary: xsnow is behind nautilus
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: xsnow (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: FutureFeature
: 52132 53194 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-05 00:01 UTC by Tommy McNeely
Modified: 2007-04-18 16:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-20 14:01:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tommy McNeely 2001-09-05 00:01:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD Netscape [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
It appears that ANY application that draws to the "root" window does not
work with nautilus since nautilus hides the root window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Everything install of Roswell2
2. login
3. start XSnow, Xfishtank, Xearth, etc
	

Actual Results:  nothing shows up

Expected Results:  snow, fish, earth?

Additional info:

if you remove nautilus (from the session manager) the root window is
brought back to the front, making the snow/fish/whatever visable again.

Comment 1 Havoc Pennington 2001-09-05 00:33:25 UTC
Well, if I maximize mozilla I can't see the root window either. It's not really
a bug; just that xsnow relies on the root window being visible. The root window
isn't necessarily.

We could somehow make the Nautilus window ID available to xsnow, but xsnow also
relies on another not-guaranteed-to-be-true thing: no one but xsnow is handling
root window drawing. This would not be true for the Nautilus window.

So, root window hacks are dead when using Nautilus. They have to be done as
Nautilus features. Someone could maybe add a feature to Nautilus to let them be
done as dynamic Nautilus modules or something.

Anyhow, I have no idea how to fix this so that xsnow works, though I could
imagine adding an xsnow-like feature to Nautilus, I can't tell you how low on
the priority queue that is. ;-) We are taking patches basically.

Comment 2 Tommy McNeely 2001-09-05 01:27:09 UTC
Subject: 
               Re: is this a bug?
         Date: 
               04 Sep 2001 18:23:08 -0400
         From: 
               teg@redhat.com (Trond Eivind Glomsrxd)
     Reply-To: 
               roswell-list@redhat.com
 Organization: 
               Red Hat, Inc.
           To: 
               roswell-list@redhat.com
   References: 
               1




Tommy McNeely <Tommy.McNeely@Sun.COM> writes:

> when nautilus is on, xsnow doesnt work.
> 
> I think its cause nautilus hides the "root" display, that xsnow is
> drawing on... it also affects xfishtank (although that did not make it
> from powertools to the distro :(  )

That's a bug - please put it in bugzilla (https://bugzilla.redhat.com/bugzilla)

-- 
Trond Eivind Glomsrxd
Red Hat, Inc.



_______________________________________________
Roswell-list mailing list
Roswell-list@redhat.com
https://listman.redhat.com/mailman/listinfo/roswell-list

Comment 3 Tommy McNeely 2001-09-05 01:34:42 UTC
[FOOT] -> Programs -> Games -> xsnow

I am not just pulling this out of my "ear" ... this is part of the distro. I
would suggest removing xsnow if nautilus is going to be enabled by default....
IS there a reason WHY nautilus hides/covers the root window. It seems to cause
lots of other problems (thumbs through other bug reports).. I will point out
that it was filed as LOW priority.

Tommy

Comment 4 Tommy McNeely 2001-09-05 03:38:26 UTC
Changing category to XSNOW and RFE

Comment 5 Ngo Than 2001-12-20 11:37:26 UTC
*** Bug 52132 has been marked as a duplicate of this bug. ***

Comment 6 Ngo Than 2001-12-20 11:39:02 UTC
*** Bug 53194 has been marked as a duplicate of this bug. ***

Comment 7 Chris Ricker 2001-12-20 14:01:38 UTC
So far all the bug reports blame nautilus.

The problem isn't nautilus.  Xsnow doesn't work with KDE either.


Comment 8 Ngo Than 2001-12-21 12:25:39 UTC
It's fixed in 1.42-1. On KDE-2.2.1+ you must enable the Support Programs in
Desktop Window option under Control Center -> Look & Feel -> Desktop.


Comment 9 Chris Ricker 2001-12-21 16:10:13 UTC
Where can I find 1.42-1?  It's not in rawhide or in updates....

Comment 10 Ngo Than 2001-12-21 22:29:39 UTC
You find it on ftp://people.redhat.com/than/7.2


Note You need to log in before you can comment on or make changes to this bug.