Bug 533081 - publican --version does not work.
publican --version does not work.
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
: 541450 564401 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-04 17:17 EST by eric@christensenplace.us
Modified: 2010-11-23 23:18 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.3-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 23:14:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2009-11-04 17:17:57 EST
Description of problem: When doing a "publican --version" I receive the following:

[christensene@desk pdf]$ publican --version
Unknown option: version


Usage:
    publican <global options>

    publican <action> <options>

    Global Options

        --help      Display help message
        --man               Display Full man page
        --help_actions      Display a list of valid actions
        --version   Display the version of Publican

    Run: 'publican <action> --help' for details on action usage

    Valid actions are:

        build         Transform XML to other formats (pdf, html, html-single)
        clean         Remove all temporary files and directories
        clean_ids     Run clean ids for source XML
        cleanset      Remove local copies remote set books
        create        Create a new Book|Set|Article|brand
        create_brand  Create a new Brand
        help_config   Display help text for the configuration file
        installbrand  Install a brand to the supplied location
        old2new       Create a publican.cfg file for an old Book|Article|Set Makefile
        package       Package a language for shipping
        printtree     Print a tree of the xi:includes
        update_po     Update the PO files
        update_pot    Update the POT files



Version-Release number of selected component (if applicable): 1.1-0.fc12
Comment 1 Jeff Fearn 2009-11-05 00:31:30 EST
I've checked a fix for this in to the repo.

A work around for this is to use -v which does work.

$ publican -v
version=1.2

The next version will support both --version and -v.
Comment 2 eric@christensenplace.us 2009-11-05 09:13:56 EST
Heck, I didn't even think about trying that.  Thanks.
Comment 3 Jeff Fearn 2009-11-10 20:04:59 EST
I had to change the behavior because

publican --version

clashes with

publican create --version 3.0 ...

So in publican 1.3 only 'publican -v' will get the version of publican and '--version' will only be used when creating books.

Sorry for any inconvenience.

Cheers, Jeff.
Comment 4 eric@christensenplace.us 2009-11-10 20:33:13 EST
Cool.  I think it was listed in the publican --help menu.
Comment 5 Jeff Fearn 2009-11-10 23:10:44 EST
I fixed the help text:

]$ publican --help


Usage:
    publican <global options>

    publican <action> <options>

    Global Options

        --help              Display help message
        --man               Display Full man page
        --help_actions      Display a list of valid actions
        -v                  Display the version of Publican
...
Comment 6 eric@christensenplace.us 2009-11-11 08:19:49 EST
Works for me.
Comment 7 Bug Zapper 2009-11-16 10:06:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Jeff Fearn 2009-11-25 18:03:19 EST
*** Bug 541450 has been marked as a duplicate of this bug. ***
Comment 9 Jared MORGAN 2009-11-25 18:15:42 EST
Sorry for the duplicate Jeff.

I just downloaded 1.2 this morning.  And I successfully used publican -v.

But the publican --help command still displays the --version usage info.  Is the new -v parameter help info scheduled for the 1.3 release, or was it meant to make it into 1.2?

[jmorgan@jmorgan ~]$ publican -v
version=1.2
[jmorgan@jmorgan ~]$ publican -help


Usage:
    publican <global options>

    publican <action> <options>

    Global Options

        --help      Display help message
        --man               Display Full man page
        --help_actions      Display a list of valid actions
        --version   Display the version of Publican

    Run: 'publican <action> --help' for details on action usage

    Valid actions are:

        build         Transform XML to other formats (pdf, html, html-single)
        clean         Remove all temporary files and directories
        clean_ids     Run clean ids for source XML
        cleanset      Remove local copies remote set books
        create        Create a new Book|Set|Article|brand
        create_brand  Create a new Brand
        help_config   Display help text for the configuration file
        installbrand  Install a brand to the supplied location
        old2new       Create a publican.cfg file for an old Book|Article|Set Makefile
        package       Package a language for shipping
        printtree     Print a tree of the xi:includes
        update_po     Update the PO files
        update_pot    Update the POT files

[jmorgan@jmorgan ~]$
Comment 10 Jeff Fearn 2009-11-25 18:30:51 EST
(In reply to comment #3)
> So in publican 1.3 only 'publican -v' will get the version of publican and
> '--version' will only be used when creating books.

Making this clearer.
Comment 11 Fedora Update System 2009-12-07 21:14:29 EST
publican-1.3-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc12
Comment 12 Fedora Update System 2009-12-07 21:17:52 EST
publican-1.3-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc11
Comment 13 Fedora Update System 2009-12-09 23:13:29 EST
publican-1.3-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-12-09 23:26:20 EST
publican-1.3-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Jeff Fearn 2010-02-14 19:25:44 EST
*** Bug 564401 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.