This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 538850 - system-config-kdump fails to start, generates errors
system-config-kdump fails to start, generates errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-kdump (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
: Reopened
: 551105 556297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 10:09 EST by Marc Milgram
Modified: 2014-01-12 19:10 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.0.2-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-04 20:41:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing error messages (655.74 KB, image/png)
2009-11-19 10:09 EST, Marc Milgram
no flags Details
grub.comf (764 bytes, text/plain)
2009-11-20 08:55 EST, Marc Milgram
no flags Details
My screenshot with kdump errors. (787.30 KB, image/png)
2010-01-05 08:18 EST, Stanislaw Gruszka
no flags Details

  None (edit)
Description Marc Milgram 2009-11-19 10:09:28 EST
Created attachment 370364 [details]
Screenshot showing error messages

Description of problem:
When starting system-config-kdump, I get errors, and the command won't start.
The errors are displayed in an attachment.

Version-Release number of selected component (if applicable):
system-config-kdump-2.0.1-1.fc12.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Start system-config-kdump
  
Actual results:
system-config-kdump opens an error window, but no configuration window.

Expected results:
system-config-kdump doesn't display any errors, and starts configuration window.

Additional info:
I recently upgraded my system from F11 to F12.  6 months ago I upgraded it from F10 to F11, so It hasn't been reinstalled since F10.

This is similar to bug 524532, but the output is slightly different.
Comment 1 Roman Rakus 2009-11-19 11:19:08 EST
Thanks for the report.
Can you please post a content of grub.conf (or any other bootloaders conf file)?
Comment 2 Marc Milgram 2009-11-20 08:55:21 EST
Created attachment 372494 [details]
grub.comf
Comment 3 Fedora Update System 2009-12-07 11:10:03 EST
system-config-kdump-2.0.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-kdump-2.0.2-1.fc12
Comment 4 Fedora Update System 2009-12-09 23:30:55 EST
system-config-kdump-2.0.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Stanislaw Gruszka 2010-01-05 08:18:17 EST
I'm using system-config-kdump 2.0.2-1 and it still not work. I'm reopening this bug report as call traces looks similar.
Comment 6 Stanislaw Gruszka 2010-01-05 08:18:59 EST
Created attachment 381755 [details]
My screenshot with kdump errors.
Comment 7 Roman Rakus 2010-02-01 10:57:53 EST
This one is another bug. It is fixed in git. I will include the patch in F12
Comment 8 Roman Rakus 2010-02-01 11:02:51 EST
Just to be sure, can you please run /usr/share/system-config-kdump/system-config-kdump-backend.py by hand in root env? And post here any error.
Comment 9 Stanislaw Gruszka 2010-02-02 05:37:19 EST
[root@yellow ~]# /usr/share/system-config-kdump/system-config-kdump-backend.py
Traceback (most recent call last):
  File "/usr/share/system-config-kdump/system-config-kdump-backend.py", line 31, in <module>
    import rhpl.translate as translate
ImportError: No module named rhpl.translate
Comment 10 Roman Rakus 2010-02-02 08:43:15 EST
Thanks. This is exactly what I expected. Will patch soon...
Comment 11 Fedora Update System 2010-02-02 09:15:02 EST
system-config-kdump-2.0.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-kdump-2.0.2-2.fc12
Comment 12 Roman Rakus 2010-02-02 12:18:10 EST
*** Bug 551105 has been marked as a duplicate of this bug. ***
Comment 13 Roman Rakus 2010-02-02 12:18:22 EST
*** Bug 556297 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2010-02-04 20:41:04 EST
system-config-kdump-2.0.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.