Bug 539503 - [abrt] crash in jpeg_idct_ifast (rhythmbox-0.12.5-8.fc12)
[abrt] crash in jpeg_idct_ifast (rhythmbox-0.12.5-8.fc12)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:97619c24644218492dc6e21d27e...
:
: 539803 544820 544904 545288 546961 547960 549071 553928 560432 575003 577510 579353 587123 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-20 07:12 EST by Ahmad Zulkarnain
Modified: 2010-05-03 05:06 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-08 12:57:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (99.11 KB, text/plain)
2009-11-20 07:13 EST, Ahmad Zulkarnain
no flags Details
As per requested. (405.97 KB, image/jpeg)
2009-11-24 11:10 EST, Ahmad Zulkarnain
no flags Details

  None (edit)
Description Ahmad Zulkarnain 2009-11-20 07:12:53 EST
abrt detected a crash.

Attached file: backtrace
cmdline: /usr/libexec/rhythmbox-metadata unix:tmpdir=/tmp
component: rhythmbox
executable: /usr/libexec/rhythmbox-metadata
kernel: 2.6.31.5-127.fc12.x86_64
package: rhythmbox-0.12.5-8.fc12
rating: 2
reason: Process was terminated by signal 11
Comment 1 Ahmad Zulkarnain 2009-11-20 07:13:06 EST
Created attachment 372473 [details]
File: backtrace
Comment 2 Bastien Nocera 2009-11-20 07:28:25 EST
Gstreamer seems to try and load metadata from a jpeg file.

Could you please make the file mentioned in there available:
#3  0x0000000000409f78 in rb_metadata_load (md=0x17f3080 [RBMetaData], uri=
    0x19165d0 "file:///media/MP3/%5B2007.12%5D%20In%20Rainbows/Extras/artwork/wax_houses_inside_out.jpg", error=<value optimized out>)
Comment 3 Ahmad Zulkarnain 2009-11-24 11:10:19 EST
Created attachment 373477 [details]
As per requested.

i have the feeling that it has something to do with the media being in NTFS format which I mounted.
Comment 4 Victoria Earl 2009-11-24 11:51:50 EST
Acording to the automatic bug reporter I have had the same crash, as far as I can tell it is from the Desktop Art plugin attempting to load while compiz is turned off.  Rhythmbox does not actually shut down in this case but gives an error.
Comment 5 Bastien Nocera 2009-12-08 11:57:57 EST
Whee!

$ gst-launch playbin2 uri=file:///home/hadess/Desktop/rb-crasher.jpg 

(gst-launch-0.10:9785): GLib-WARNING **: g_set_prgname() called multiple times
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Caught SIGSEGV accessing address (nil)

This is the bt:
#0  0x00000030818167d2 in jpeg_idct_ifast (cinfo=<value optimized out>, compptr=<value optimized out>, coef_block=<value optimized out>, output_buf=<value optimized out>, output_col=<value optimized out>) at ./jidctfst.c:347
#1  0x000000308181524f in decompress_onepass (cinfo=<value optimized out>, output_buf=<value optimized out>) at ./jdcoefct.c:197
#2  0x000000308180e611 in jpeg_read_raw_data (cinfo=0x80fd08, data=0x7ffff0e3a9c0, max_lines=16) at ./jdapistd.c:210
#3  0x00007ffff0e4361d in gst_jpeg_dec_decode_indirect (r_h=<value optimized out>, r_v=<value optimized out>, height=1500, width=<value optimized out>, last=<value optimized out>, base=<value optimized out>, dec=<value optimized out>) at gstjpegdec.c:740
#4  gst_jpeg_dec_chain (r_h=<value optimized out>, r_v=<value optimized out>, height=1500, width=<value optimized out>, last=<value optimized out>, base=<value optimized out>, dec=<value optimized out>) at gstjpegdec.c:1177
#5  0x000000308b0610a5 in gst_pad_chain_data_unchecked (pad=0x810990 [GstPad], is_buffer=1, data=0x7fffec049760) at gstpad.c:4116
#6  0x000000308b061b7e in gst_pad_push_data (pad=0x7bafc0 [GstPad], is_buffer=1, data=0x7fffec049760) at gstpad.c:4345
#7  0x00007ffff19136ed in gst_type_find_element_chain (pad=0x7ba3b0 [GstTypeFindElement], buffer=0x7fffec049760) at gsttypefindelement.c:697
#8  0x000000308b0610a5 in gst_pad_chain_data_unchecked (pad=0x7bab40 [GstPad], is_buffer=1, data=0x7fffec049760) at gstpad.c:4116
#9  0x000000308b061b7e in gst_pad_push_data (pad=0x7bb580 [GstProxyPad], is_buffer=1, data=0x7fffec049760) at gstpad.c:4345
#10 0x000000308b0610a5 in gst_pad_chain_data_unchecked (pad=0x7bb7d0 [GstGhostPad], is_buffer=1, data=0x7fffec049760) at gstpad.c:4116
#11 0x000000308b061b7e in gst_pad_push_data (pad=0x7b78f0 [GstPad], is_buffer=1, data=0x7fffec049760) at gstpad.c:4345
#12 0x000000308da1c882 in ?? () from /usr/lib64/libgstbase-0.10.so.0
#13 0x000000308b085c7e in gst_task_func (task=0x7d84b0 [GstTask]) at gsttask.c:234
#14 0x0000003074063ab2 in g_thread_pool_thread_proxy (data=<value optimized out>) at gthreadpool.c:265
#15 0x00000030740624c4 in g_thread_create_proxy (data=0x7d8730) at gthread.c:635
#16 0x0000003073406a3a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#17 0x00000030728de6dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#18 0x0000000000000000 in ?? ()

Reassigning to libjpeg.
Comment 6 Bastien Nocera 2009-12-08 11:58:40 EST
*** Bug 539803 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2009-12-08 12:32:35 EST
*** Bug 544820 has been marked as a duplicate of this bug. ***
Comment 8 Bastien Nocera 2009-12-08 12:35:38 EST
*** Bug 544904 has been marked as a duplicate of this bug. ***
Comment 9 Bastien Nocera 2009-12-08 12:37:37 EST
*** Bug 545288 has been marked as a duplicate of this bug. ***
Comment 10 Bastien Nocera 2009-12-08 12:57:31 EST
Filed upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=604106
Comment 11 Bastien Nocera 2009-12-17 10:12:42 EST
*** Bug 546961 has been marked as a duplicate of this bug. ***
Comment 12 Bastien Nocera 2009-12-17 10:12:47 EST
*** Bug 547960 has been marked as a duplicate of this bug. ***
Comment 13 Peter Robinson 2010-02-03 17:40:16 EST
*** Bug 560432 has been marked as a duplicate of this bug. ***
Comment 14 Bastien Nocera 2010-03-15 11:43:00 EDT
*** Bug 553928 has been marked as a duplicate of this bug. ***
Comment 15 Bastien Nocera 2010-03-15 11:46:02 EDT
*** Bug 549071 has been marked as a duplicate of this bug. ***
Comment 16 Benjamin Otte 2010-03-31 03:34:25 EDT
*** Bug 577510 has been marked as a duplicate of this bug. ***
Comment 17 Peter Robinson 2010-05-03 05:04:50 EDT
*** Bug 575003 has been marked as a duplicate of this bug. ***
Comment 18 Peter Robinson 2010-05-03 05:05:01 EDT
*** Bug 587123 has been marked as a duplicate of this bug. ***
Comment 19 Peter Robinson 2010-05-03 05:06:32 EDT
*** Bug 579353 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.