Bug 55124 - iptables will not accept a rule with a numeric TOS set
iptables will not accept a rule with a numeric TOS set
Status: CLOSED DUPLICATE of bug 54280
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 16:51 EDT by Tom Diehl
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 04:02:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (474 bytes, patch)
2001-10-26 01:59 EDT, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Tom Diehl 2001-10-25 16:51:48 EDT
Description of Problem:If the TOS is set to say 8 iptables complains that 
this is not valid. Set it to Maximize-Throughput and the rule will load.
The man page and iptables -j TOS -h indicate the following:
TOS target v1.2.3 options:
  --set-tos value                   Set Type of Service field to one of 
the
                                following numeric or descriptive values:
                                     Minimize-Delay 16 (0x10)
                                     Maximize-Throughput 8 (0x08)
                                     Maximize-Reliability 4 (0x04)
                                     Minimize-Cost 2 (0x02)
                                     Normal-Service 0 (0x00)


Version-Release number of selected component (if applicable):


How Reproducible:Every time


Steps to Reproduce:
1. Load a rule with --set-tos set to a numeric value.
2. this used to work under iptables rules loaded on a 7.0 system.
3. IIRC iptables did not come with 7.0. I got the rpms for 7.0 directly 
from the netfilter web site. the man page still indicates what I am doing 
is valid.

Actual Results:Iptables complains that the numeric values (I tried them 
all just for giggles) are invalid. the descriptive values appear to work.


Expected Results:The rule should load without error


Additional Information:FYI: I entered bug 55123 which is the same type of 
problem but related to logging level.
Comment 1 Michael Schwendt 2001-10-26 01:58:44 EDT
Same here as with bug #55123. Fixed with iptables-1.2.4.
Comment 2 Michael Schwendt 2001-10-26 01:59:08 EDT
Created attachment 35162 [details]
patch
Comment 3 Michael Schwendt 2001-10-26 02:23:37 EDT
Btw, also covered in bug #54280 with a longer patch which patches the IPv6
files, too.
Comment 4 Ben Liblit 2001-10-26 04:02:08 EDT
Note that "iptables-save" uses hex constants (0x10, for example) when writing
out /etc/sysconfig/iptables, so anyone who uses "service iptables save" with
--set-tos rules will run into this bug.
Comment 5 Bernhard Rosenkraenzer 2001-10-30 06:53:14 EST

*** This bug has been marked as a duplicate of 54280 ***

Note You need to log in before you can comment on or make changes to this bug.