Bug 560369 - package-cleanup didn't work
package-cleanup didn't work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 539288 543410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-31 05:25 EST by Jens Maucher
Modified: 2014-01-21 18:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-01 15:34:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Maucher 2010-01-31 05:25:20 EST
Description of problem:
package-cleanup didn't work

Version-Release number of selected component (if applicable):
yum-utils-1.1.24-2.fc12.noarch

How reproducible:
(as root)
package-cleanup --all

Actual results:

File "/usr/bin/package-cleanup", line 382, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 58, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 302, in main
    self.optparser.print_help()
  File "/usr/lib64/python2.6/optparse.py", line 1651, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
  File "/usr/lib64/python2.6/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1706: ordinal not in range(128)
Comment 1 Jens Maucher 2010-01-31 05:40:13 EST
I also tried yum-utils 1.1.25-1 from updates-testing and get the same result.
Comment 2 Tim Lauridsen 2010-02-01 11:58:57 EST
does 

LANG=C package-cleanup --all

work ?
Comment 3 Jens Maucher 2010-02-01 13:05:58 EST
It shows me the ouput from 

package-cleanup --help
Comment 4 Tim Lauridsen 2010-02-01 14:47:50 EST
What locale are you using

echo $LANG
Comment 5 Tim Lauridsen 2010-02-01 14:52:17 EST
ok, i can reproduce with

LANG=de_DE.utf8 package-cleanup --all
Comment 7 Tim Lauridsen 2010-02-01 15:38:07 EST
*** Bug 543410 has been marked as a duplicate of this bug. ***
Comment 8 Tim Lauridsen 2010-02-01 15:39:31 EST
*** Bug 539288 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Wickert 2010-02-01 15:52:46 EST
When will this fix land in release? I don't see it in koji or bodhi, although the bug is closed.
Comment 10 seth vidal 2010-02-01 15:58:49 EST
It's closed 'upstream' which means it was fixed there. It will be in a fedora release most likely when we make a yum-utils release and/or if a patch-release is warranted.
Comment 11 Frank Murphy 2011-05-09 15:13:51 EDT
I just got this bug, Fedora 14 x86_64, Testing app-market (going by abrt)

traceback comes after the search is complete.

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 258, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 113, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 396, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/lib/yum-plugins/appmarket.py", line 119, in doCommand
    print '%s : %s' % (app.name, app.description)
  File "/usr/lib64/python2.7/codecs.py", line 351, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 345: ordinal not in range(128)



Package:    	yum-3.2.28-5.fc14
Latest Crash:	Mon 09 May 2011 19:54:04 
Command:    	/usr/bin/python /usr/bin/yum app-search cron
Reason:     	codecs.py:351:write:UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 398: ordinal not in range(128)
Comment:    	as user ran "yum app-search cron"

also crashes as "sudo yum app-search cron"
--ditto-- app-search browser
"yum app-search mikl" no error




yum-plugin-downloadonly-1.1.28-1.fc14.noarch
yum-utils-1.1.28-1.fc14.noarch
yum-plugin-appmarket-1.0-1.noarch
yum-plugin-protectbase-1.1.28-1.fc14.noarch
yum-presto-0.6.2-2.fc14.noarch
yum-langpacks-0.1.5-3.fc14.noarch
yum-plugin-local-1.1.28-1.fc14.noarch
yum-plugin-remove-with-leaves-1.1.28-1.fc14.noarch
yum-metadata-parser-1.1.4-2.fc14.x86_64
yum-plugin-fastestmirror-1.1.28-1.fc14.noarch
yum-plugin-keys-1.1.28-1.fc14.noarch
yum-updateonboot-1.1.28-1.fc14.noarch
yum-3.2.28-5.fc14.noarch
anaconda-yum-plugins-1.0-5.fc12.noarch
PackageKit-yum-0.6.12-2.fc14.x86_64
PackageKit-yum-plugin-0.6.12-2.fc14.x86_64

Note You need to log in before you can comment on or make changes to this bug.