Bug 546205 - No restart after 'critical' update
No restart after 'critical' update
Status: CLOSED DUPLICATE of bug 590140
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
: Triaged
: 561096 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 06:53 EST by Martin Kho
Modified: 2010-05-09 10:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-09 10:55:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2009-12-10 06:53:23 EST
Description of problem:
After a 'critical' update - via update manager (kpackagekit) - is installed
a notification pop up tells that a restart is necessary. You can chose
between: "Restart" or "Not Now". When choosing "Restart" nothing happens.

Version-Release number of selected component (if applicable):
kpackagekit-0.5.1.1-1.fc12.x86_64.rpm
PackageKit-0.5.4-0.4.20091029git.fc12.x86_64.rpm

How reproducible:
1. Wait until KPackageKitSmartIcon notifies that a 'critical' update - e.g. kernel, glibc - is available
2. Update packages
3. Press "Restart"-button in notification dialogbox.

Actual results:
Dialogbox disappears and no reboot

Expected results:
System reboots

Additional info:
Comment 1 Steven M. Parrish 2009-12-11 12:40:34 EST
kpackagekit-0.5.2 has been pushed to updates-testing.  Please try it and see if it fixes your issue.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Martin Kho 2009-12-16 16:21:39 EST
I'll try it as soon as PackegeKit-0.5.5-1 is pushed for update. You'll hear from me :-)

Thanks,

Martin Kho
Comment 3 Steven M. Parrish 2009-12-22 09:21:42 EST
This bug has been triaged

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Martin Kho 2009-12-23 04:47:06 EST
Hi,

I couldn't wait, and updated PackageKit and kpackagekit from updates-testing :-) Now it looks like I have an other problem. I don't get any notification that there are updates at all. So I have to update my system from System Setting -> Add and Remove Software. The last time a restart wasn't necessary :-(

Any idea how I can test the newly pushed (k)packagekit?

Martin Kho
Comment 5 Martin Kho 2009-12-24 18:05:06 EST
kpackagekit-0.5.2 (and PackageKit-0.5.5-1) doesn't see available updates.

a. When I run "yum check-update" five updates show up.
b. When I press the Refresh-button in System Settings -> Add and Remove Software -> Software Update the updates doesn't show up.

Btw. When I did the same on Rawhide I got a crash. KDED4 and kpackagekitsmarticon crashed. Maybe this can give a clue. Reports can be found at bug [1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=548195

So I still can't tell if the original issue is solved :-)

Martin Kho
Comment 6 Martin Kho 2009-12-30 19:18:52 EST
Hi,

It took a while but now I got a crash with kpackagekit-0.5.2. I'll create a new bug report for this.

Martin Kho
Comment 7 Martin Naď 2010-02-02 12:34:50 EST
*** Bug 561096 has been marked as a duplicate of this bug. ***
Comment 8 Martin Kho 2010-02-02 18:13:09 EST
Hi,

Kpackagekit is back to live, but this issue still exists. Currently I use:

kpackagekit-0.5.4-2.fc12.x86_64 (from updates-testing) and
PackageKit-0.5.6-1.fc12.x86_64

Not only the "Restart" button doesn't restart the system, also the "Logout" button doesn't do anything. The notification pop up is dismissed as if the "Not now" button is pressed.

Martin Kho
Comment 9 Martin Kho 2010-03-22 17:53:02 EDT
Hi,

Update:
kpackagekit is updated to stable, same version as in comment #8
PackageKit is updated to PackageKit-0.5.7-1.fc12.x86_64

Issue still exists.

Martin Kho
Comment 10 Martin Kho 2010-05-07 15:03:17 EDT
Hi,

Please close this report. I'll open a new report for issues with the current versions of Kpackagekit and Packagekit.

Thanks,

Martin Kho
Comment 11 Kevin Kofler 2010-05-09 10:55:30 EDT

*** This bug has been marked as a duplicate of bug 590140 ***

Note You need to log in before you can comment on or make changes to this bug.