Bug 54840 - RFE: provide a way to abort an install/upgrade
RFE: provide a way to abort an install/upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-20 13:31 EDT by Aleksey Nogin
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 12:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2001-10-20 13:31:48 EDT
I am doing an FTP upgrade of a RH7.1 system. There does not seem to be a
way  to abort the upgrade. Even when it truns out that there is
unsufficient space to perform an upgrade, there does not seem to be a way
to tell it not to perform an upgrade - the only choice I am presented with
is to go back and change some options.

Of course i can always do Ctrl-Alt-Del and just reboot a machine, but in
this case the filesystems will not be cleanly unmounted, which is
especially frustrating in the presence of bug 54839 (my ext3 filesystems
are mounted as ext2 by the installer).
Comment 1 Brent Fox 2001-10-23 23:36:06 EDT
This is basically a dupe of #54841 in that there's no way gracefully get out of
an upgrade that can't proceed because of lack of space.  I'm going to dupe this
against 54841 because fixing one bug would fix the other.

*** This bug has been marked as a duplicate of 54841 ***
Comment 2 Aleksey Nogin 2001-10-24 11:16:23 EDT
I disagree. This bug asks for an "Abort upgrade" option that would cleanly
unmount the partitions and halt. Bug 54841 asks for an option to change the
"upgrade with default set of pkgs" into "upgrade custom set of packages"
*without* having to restart upgrade.
Comment 3 Brent Fox 2001-10-25 17:05:44 EDT
Implemented in cvs.

Note You need to log in before you can comment on or make changes to this bug.