Bug 54913 - Unable to print with EPSON Stylus COLOR 800
Unable to print with EPSON Stylus COLOR 800
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
: 53467 53882 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 01:01 EDT by Need Real Name
Modified: 2009-12-20 11:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 08:45:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
status file with error messages (9.62 KB, text/plain)
2001-10-23 01:03 EDT, Need Real Name
no flags Details
dmesg output (7.52 KB, text/plain)
2001-10-23 01:05 EDT, Need Real Name
no flags Details
Printer file generated for Epson 980 in /var/spool/lpd/lp (deleted)
2001-10-29 14:31 EST, Walt Jamros
no flags Details
Printer file generated for Epson 980 in /var/spool/lpd/lp (deleted)
2001-10-29 14:32 EST, Walt Jamros
no flags Details
file generated in /var/spool/lpd/lp for Epson 980 (deleted)
2001-10-29 14:33 EST, Walt Jamros
no flags Details

  None (edit)
Description Need Real Name 2001-10-23 01:01:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.10-ac12 i686)

Description of problem:
Unable to print with an Epson Stylus Color/800 printer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to print anything.  "lpr .bashrc" reproduces bug.
2. Shutdown lpd, "cat .bashrc > /dev/lp0" prints ok.
3. Restart lpd, "lpr .bashrc" fails to print.
	

Actual Results:  status.mq reports "Unknown option: d" and lpdomatic exits
shortly after with an error.

Expected Results:  Print

Additional info:

I'll attach a dmesg output and the status.mq file so you can see that the
printer is detected (autoprobe) and the actual errors generated from
lpdomatic.

/proc/sys/dev/parport/parport0/autoprobe reports:
CLASS:PRINTER;
MODEL:Stylus COLOR 800;
MANUFACTURER:EPSON;
COMMAND SET:ESCPL2,PRPXL24,BDC;
Comment 1 Need Real Name 2001-10-23 01:03:44 EDT
Created attachment 34681 [details]
status file with error messages
Comment 2 Need Real Name 2001-10-23 01:05:47 EDT
Created attachment 34682 [details]
dmesg output
Comment 3 Need Real Name 2001-10-24 23:11:15 EDT
Upgraded to foomatic-1.1-0.20011018.1 + ghostscript-6.51-16 + Omni-0.5.0-3 +
printconf-0.3.52-1 and added all current rh72 updates; Tried again to print
after restarting lpd ...

Still ends with "JREMOVE" error.
Comment 4 Walt Jamros 2001-10-25 18:29:09 EDT
Same error with Epson 880 (stp driver). Prints "**** Unable to open the initial
device, quitting."  Changed driver (using printconf-gui) to stcolor (listed
under Epson 800) and was able to print the Redhat postscript test page. The
problem seems to be with the stp driver.
Comment 5 Olivier Baudron 2001-10-25 19:03:21 EDT
I also have an Epson Stylus Color 800, and it works fine.
My config is:

LPRng-3.7.4-28
Omni-0.5.0-3
Omni-foomatic-0.5.0-3
foomatic-1.1-0.20011018.1
ghostscript-6.51-16
ghostscript-fonts-5.50-4
gnome-print-0.29-6

All of these are the latest rawhide version.
Comment 6 Olivier Baudron 2001-10-25 19:05:25 EDT
I forgot to mention that I am using the stp driver.
Comment 7 Need Real Name 2001-10-25 21:09:36 EDT
I was trying to use the stc800p.upp/stc800pl.upp/stc800ih.upp drivers.  (These
are what I was using with rh7.0 and it worked perfectly)

Per instruction, tried:
	rm /var/cache/foomatic/pcache/* /var/cache/foomatic/compiled/*
	/usr/sbin/printconf-backend --force-rebuild
Still no luck.

Changed to stcolor driver, and its able to pint - but it only at low quality.
'stp' driver works, but only after you goto the options page and select high
quality.  (It defaults to 180dpi)

Thanks for the suggestions !
Comment 8 Olivier Baudron 2001-10-26 06:32:31 EDT
In printconf, "stp" is the driver suggested for the stylus color 800 (see
Printer Notes).
Comment 9 Walt Jamros 2001-10-29 14:54:57 EST
    I found my Epson 880 will work with the stp driver if I set the printer
model to Epson 980. Did a "diff" on  /var/spool/lpd/lp/stp-317865.foo (Epson
980) and /var/spool/lpd/lp/stp317801.foo (Epson 880). The 880 file has support
for "{'1440x720DPIHighestQuality'}". The 980 does not.
    
    The 980 file works (Redhat postscript test page prints). The 880 file does
not (printer just prints "**** Unable to open the initial device, quitting.)" I
also got this error when I tried to use the stp driver under Epson 800 (in
printconf-gui). 

    Sorry for the bad stp-317865.foo attachments, I tried to attach the file but
I kept getting an error complaining about Oracle table space. 

    Anyway, my printer is working now. Here are the levels of the rpm's:

printconf-gui-0.3.44-1
libgnomeprint15-0.29-6
gnome-print-0.29-6
printconf-0.3.44-1
LPRng-3.7.4-28
ghostscript-fonts-5.50-3
ghostscript-6.51-12

Comment 10 mike 2001-10-29 20:07:32 EST
I have the same problem reported here (printer just prints "**** 
Unable to open the initial device, quitting").  This is on a RH7.2 
system, with a remote samba printer, print queue deleted and 
recreated using printtool and the Epson 880 driver.
Comment 11 mike 2001-10-29 20:43:18 EST
Here is the status log in the /var/spool/lpd directory after a print 
attempt.The only thing I notice is the complaint about the -sModel 
flag to gs about halfway through.

BTW, for me it makes no difference which (880/980) driver I 
select. 
 
IF filter 'mf_wrapper' filter msg - 
'/usr/share/printconf/util/printconf_mfomatic.pl: postscript job 
line1=>%!PS-Adobe-2.0' at 2001-10-29-20:37:04.518 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<' at 2001-10-29-20:37:04.518 
## A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - 
'/usr/share/printconf/util/printconf_mfomatic.pl: prepended:' at 
2001-10-29-20:37:04.520 ## A=root@localhost+221 number=221 
process=11223
IF filter 'mf_wrapper' filter msg - 'gs  PID pid2=11241' at 
2001-10-29-20:37:04.520 ## A=root@localhost+221 number=221 
process=11223
IF filter 'mf_wrapper' filter msg - '<</PageSize[612 
792]/ImagingBBox null>>setpagedevice' at 2001-10-29-20:37:04.521 
## A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</stpMediaType(Plain 
Paper)>>setpagedevice' at 2001-10-29-20:37:04.521 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</HWResolution[720 
720]>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Quality(720 DPI Highest 
Quality)>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</ImageType 0>>setpagedevice' 
at 2001-10-29-20:37:04.522 ## A=root@localhost+221 number=221 
process=11223
IF filter 'mf_wrapper' filter msg - '<</Dither(Adaptive 
Hybrid)>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Gamma 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Density 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Brightness 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Saturation 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Contrast 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Cyan 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Magenta 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - '<</Yellow 
1.000000>>setpagedevice' at 2001-10-29-20:37:04.522 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - 'Printer must be specified with 
-sModel' at 2001-10-29-20:37:04.677 ## A=root@localhost+221 
number=221 process=11223
IF filter 'mf_wrapper' filter msg - 'tail process done writing data 
to *main::STDOUT' at 2001-10-29-20:37:04.681 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at 
2001-10-29-20:37:04.687 ## A=root@localhost+221 number=221 
process=11223
IF filter 'mf_wrapper' filter msg - 'Error closing pipe to gs -q 
-dSAFER -dNOPAUSE -dBATCH -sDEVICE=stp  -sOutputFile=- - at 
/usr/share/printconf/util/printconf_mfomatic.pl line
397, <STDIN> line 416.' at 2001-10-29-20:37:04.687 ## 
A=root@localhost+221 number=221 process=11223
IF filter 'mf_wrapper' filter exit status 'JFAIL' at 
2001-10-29-20:37:04.689 ## A=root@localhost+221 number=221 
process=11223
printing finished at 2001-10-29-20:37:04.689 ## 
A=root@localhost+221 number=221 process=11223
waiting for printer filter to exit at 2001-10-29-20:37:04.691 ## 
A=root@localhost+221 number=221 process=11223
accounting at end at 2001-10-29-20:37:04.691 ## 
A=root@localhost+221 number=221 process=11223
finished 'root@localhost+221', status 'JSUCC' at 
2001-10-29-20:37:04.692 ## A=root@localhost+221 number=221 
process=11223
subserver pid 11223 exit status 'JSUCC' at 2001-10-29-20:37:04.692 
## A=<NULL> number=0 process=11222
epson@localhost.localdomain: job 'cfA221localhost.localdomain' 
printed at 2001-10-29-20:37:04.692 ## A=<NULL> number=221 
process=11222
job 'cfA221localhost.localdomain' removed at 
2001-10-29-20:37:04.693 ## A=<NULL> number=221 process=11222
Comment 12 Need Real Name 2001-11-06 06:27:22 EST
I also have this problem with an Epson Stylus Photo 870; all updates as of 
2001-11-04 applied; stp driver.  It seems to be caused by foomatic not giving
ghostscript the -sModel argument required by the stp driver.

Using the new Omni driver does work.

A quote from the status file:

IF filter 'mf_wrapper' filter msg - 'foomatic-gswrapper: gs '-dSAFER' 
'-dNOPAUSE' '-dBATCH' '-sDEVICE=stp' '-sOutputFile=|cat >&3' '-' 3>&1 1>&2' at 
2001-11-06-09:31:21.539 ## A=<NULL> number=385 process=21415
IF filter 'mf_wrapper' filter msg - 'GNU Ghostscript 6.51 (2001-03-28)' at 
2001-11-06-09:31:21.580 ## A=<NULL> number=385 process=21415
IF filter 'mf_wrapper' filter msg - 'Copyright (C) 2001 artofcode LLC, Benicia,
CA.  All rights reserved.' at 2001-11-06-09:31:21.581 ## A=<NULL> number=385 
process=21415
IF filter 'mf_wrapper' filter msg - 'This software comes with NO WARRANTY: see 
the file COPYING for details.' at 2001-11-06-09:31:21.581 ## A=<NULL> 
number=385
process=21415
IF filter 'mf_wrapper' filter msg - 'Printer must be specified with -sModel' at
2001-11-06-09:31:21.915 ## A=<NULL> number=385 process=21415
IF filter 'mf_wrapper' filter msg - '**** Unable to open the initial device, 
quitting.' at 2001-11-06-09:31:21.915 ## A=<NULL> number=385 process=21415
Comment 13 Tim Waugh 2002-01-08 11:14:47 EST
Since 2001-11-04 there has been another printing-related update.  Has that 
helped, or does the problem still persist?
Comment 14 Tim Waugh 2002-01-10 04:20:31 EST
*** Bug 53882 has been marked as a duplicate of this bug. ***
Comment 15 Tim Waugh 2002-01-10 08:09:02 EST
*** Bug 53467 has been marked as a duplicate of this bug. ***
Comment 16 Need Real Name 2002-01-10 08:45:44 EST
Yes it has.  With all the current printing related updates applied, I can now 
print fine to my Epson Stylus 870.  Setup with printconf works, no errors, as 
far as I can see all options working fine.

Thanks for the fixes,

John
Comment 17 Tim Waugh 2002-01-10 08:49:09 EST
Great.  Closing.

Note You need to log in before you can comment on or make changes to this bug.