Bug 549687 - kdm: no autologin on first start
kdm: no autologin on first start
Status: CLOSED DUPLICATE of bug 555593
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 560465 563603 (view as bug list)
Depends On: 545267 555593
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2009-12-22 06:23 EST by Sebastian Vahl
Modified: 2015-01-14 18:24 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 12:41:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (61.36 KB, text/plain)
2009-12-22 11:26 EST, Sebastian Vahl
no flags Details

  None (edit)
Description Sebastian Vahl 2009-12-22 06:23:47 EST
Description of problem:
With recent kdm the autologin isn't possible on first start of kdm right after boot. If you switch to a tty and kill -9 kdm the autologin would succeed.


Version-Release number of selected component (if applicable):
kdm-4.3.85-1.fc13

How reproducible:
ever

Steps to Reproduce:
1. run a recent nightly build of the kde images.
2. boot
3.
  
Actual results:
no autologin

Expected results:
autologin
Comment 1 Sebastian Vahl 2009-12-22 06:24:26 EST
Just forgotten: There is no relevant output in kdm.log or /var/log/messages for this.
Comment 2 Rex Dieter 2009-12-22 08:26:45 EST
blocking kde-4.4 tracker (may move to F13Blocker-kde later, if this ends up being f13/rawhide specific).
Comment 3 Sebastian Vahl 2009-12-22 11:26:05 EST
Created attachment 379860 [details]
/var/log/messages

I've attached /var/log/messages. These lines appear when the user isn't logged in automatically:

Dec 22 17:18:45 localhost kdm: :0[1533]: Cannot open ConsoleKit session: Unable to open session: Method "OpenSessionWithParameters" with signature "a(sv)" on interface "org.freedesktop.ConsoleKit.Manager" doesn't exist
Dec 22 17:18:45 localhost kdm: :0[1533]: Client start failed
Dec 22 17:18:45 localhost kdm: :0[1533]: Cannot close ConsoleKit session: Unable to close session: no session open

After killing kdm there is no kdm related output (I've put a line as a marker in the attached messages).
Comment 4 Rex Dieter 2009-12-22 11:47:15 EST
OK, similar symptoms as bug #545639 (and dup'd bug #545267 ) then, ie, ConsoleKit failing on the first attempt.

rpm -q ConsoleKit dbus hal

please.  given that we can double check whether this is addressed in rawhide yet.
Comment 5 Sebastian Vahl 2009-12-22 12:00:28 EST
ConsoleKit-0.4.1-3.fc13.i686
hal-0.5.14-1.fc13.i686
dbus-1.2.16-8.fc12.i686

Full package list: http://www.deadbabylon.de/fedora/livecd/packagelists/f13/long-F13-KDE-012-i686.txt
Comment 6 Rex Dieter 2009-12-22 12:17:17 EST
Re-assigning to ConsoleKit, seems the ck_connector_open_session_with_parameters call here is failing,

    dbus_error_init( &error );
    ckStatus = ck_connector_open_session_with_parameters( ckConnector, &error,
                "unix-user", &p->pw_uid,
                "x11-display-device", &ckDevice,
                "x11-display", &td->name,
                "is-local", &isLocal, /* meaning not entirely clear per doc */
# ifdef XDMCP
                "remote-host-name", remoteHostName ?
                               (const char **)&remoteHostName : &spaceStr,
# endif
                (char *)0 );
Comment 7 dominique 2009-12-23 13:12:31 EST
Hi all...
I have same problem, with the no-password option in Kdm.
When I am on lo-gin screen, I press "Enter", I have a black screen and return on lo-gin screen.
I re-press "Enter" and My session launch.
With password option in Kdm, no problem.

Trace in /var/log/message:
Dec 23 17:44:39 localhost kdm: :0[1379]: Cannot open ConsoleKit session: Unable to open session: Method "OpenSessionWithParameters" with signature "a(sv)" on interface "org.freedesktop.ConsoleKit.Manager" doesn't exist
Dec 23 17:44:39 localhost kdm: :0[1379]: Client start failed
Dec 23 17:44:39 localhost kdm: :0[1379]: Cannot close ConsoleKit session: Unable to close session: no session open
Dec 23 17:44:43 localhost acpid: client 1352[0:0] has disconnected
Dec 23 17:44:43 localhost acpid: client connected from 1467[0:0]
Comment 8 dominique 2009-12-23 13:19:43 EST
Hi all...
I have same problem, with the no-password option in Kdm.
When I am on lo-gin screen, I press "Enter", I have a black screen and return on lo-gin screen.
I re-press "Enter" and My session launch.
With password option in Kdm, no problem.

Trace in /var/log/message:
Dec 23 17:44:39 localhost kdm: :0[1379]: Cannot open ConsoleKit session: Unable to open session: Method "OpenSessionWithParameters" with signature "a(sv)" on interface "org.freedesktop.ConsoleKit.Manager" doesn't exist
Dec 23 17:44:39 localhost kdm: :0[1379]: Client start failed
Dec 23 17:44:39 localhost kdm: :0[1379]: Cannot close ConsoleKit session: Unable to close session: no session open
Dec 23 17:44:43 localhost acpid: client 1352[0:0] has disconnected
Dec 23 17:44:43 localhost acpid: client connected from 1467[0:0]
Comment 9 Kevin Kofler 2009-12-23 13:21:59 EST
Looks like the versions of libck-connector and ConsoleKit in Rawhide are not compatible with each other.
Comment 10 Kevin Kofler 2010-01-19 09:39:25 EST
Ping? Are the versions of libck-connector and ConsoleKit in Rawhide not compatible with each other?
Comment 11 Rex Dieter 2010-02-01 12:04:56 EST
davidz thinks this is related to dbus activation (ala bug #545267), but I'd have assumed that should be fixed in rawhide already.  If that's the expectation, then this bug serves to dispell that notion.
Comment 12 Kevin Kofler 2010-02-09 10:29:33 EST
The strange things are:
* F12 has the same version of ConsoleKit as F13, so is this also happening on F12?
* libck-connector and the ConsoleKit daemon come from the same tarball, how can they get out of sync?
Comment 13 Kevin Kofler 2010-02-09 11:00:44 EST
Hmmm, why does it say 'Method "OpenSessionWithParameters" with signature "a(sv)" on interface "org.freedesktop.ConsoleKit.Manager" doesn't exist'? That method is definitely there, maybe access is getting blocked by some security policy?
Comment 14 Kevin Kofler 2010-02-12 16:11:47 EST
*** Bug 563603 has been marked as a duplicate of this bug. ***
Comment 15 Rex Dieter 2010-02-23 16:06:32 EST
There's a good chance this is the kdm equivalent of gdm bug #555593
Comment 16 Karsten Roch 2010-02-24 16:36:45 EST
*** Bug 560465 has been marked as a duplicate of this bug. ***
Comment 17 Sven Lankes 2010-02-26 04:55:21 EST
I can no longer reproduce "only 2nd login works" on F13. Maybe ConsoleKit-0.4.1-5.fc13.x86_64 fixed it?
Comment 18 Rex Dieter 2010-02-26 12:41:10 EST
I bet so.

*** This bug has been marked as a duplicate of bug 555593 ***
Comment 19 dominique 2010-02-26 14:12:10 EST
I confirm comment 17 from Sven Lankes, I update to ConsoleKit-0.4.1-5.fc13.x86_64 and now that work fine...

Note You need to log in before you can comment on or make changes to this bug.