Bug 555593 - No "user list", no sound in greeter, most of the time......
No "user list", no sound in greeter, most of the time......
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 549687 551247 561590 566690 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker 549687
  Show dependency treegraph
 
Reported: 2010-01-14 16:28 EST by Tom London
Modified: 2015-01-14 18:24 EST (History)
17 users (show)

See Also:
Fixed In Version: ConsoleKit-0.4.1-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 06:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/gdm/:0-greeter.log when I get no sounds/users (29.40 KB, text/plain)
2010-01-14 16:28 EST, Tom London
no flags Details
/var/log/gdm/:0-greeter.log when I do get sounds/users (35.09 KB, text/plain)
2010-01-14 16:28 EST, Tom London
no flags Details
:0-greeter.log produced from fresh boot, no sound, no listed users (15.80 KB, text/plain)
2010-01-16 13:30 EST, Tom London
no flags Details
:0-greeter.log produced by logging out of above session and logging in. Sound and users listed. (13.99 KB, text/plain)
2010-01-16 13:31 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2010-01-14 16:28:08 EST
Created attachment 384454 [details]
/var/log/gdm/:0-greeter.log when I get no sounds/users

Description of problem:
Most of the time when I login after booting, I get a greeter screen without a "list of users" (just "other") and no sounds (e.g., clicks, funny noise on entering an incorrect password).

I intermittently do get sound/users on the greeter screen. 

I attach :0-greeter.log for a session where there are no sounds nor users, and for a session when I get both.

Here is the first few lines of "diff" from these two files (edited to remove process numbers):

5,6c5,8
< (polkit-gnome-authentication-agent-1:1844): polkit-gnome-1-WARNING **: Unable to determine the session we are in: Remote Exception invoking org.freedesktop.ConsoleKit.Manager.GetSessionForUnixProcess() on /org/freedesktop/ConsoleKit/Manager at name org.freedesktop.ConsoleKit: org.freedesktop.ConsoleKit.Manager.GeneralError: Unable to lookup session information for process '1844' org.freedesktop.ConsoleKit.Manager.GeneralError Unable%20to%20lookup%20session%20information%20for%20process%20%271844%27
< ** (process:): DEBUG: Greeter session pid= display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-kX95Cx/database
---
> (polkit-gnome-authentication-agent-1:1854): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'
> 
> (polkit-gnome-authentication-agent-1:1854): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
> ** (process:): DEBUG: Greeter session pid= display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-UcdgC2/database

Lines from '<' are from the session without sounds/users; lines from '>' are from the session with them.

Complete log files attached.

Version-Release number of selected component (if applicable):
gdm-plugin-fingerprint-2.29.4-1.fc13.x86_64
polkit-desktop-policy-0.95-2.fc13.noarch
gdm-2.29.4-1.fc13.x86_64
polkit-0.95-2.fc13.x86_64
polkit-gnome-0.95-2.fc13.x86_64
gdm-user-switch-applet-2.29.4-1.fc13.x86_64


How reproducible:
"Fails" most of the time on first login after boot.

Steps to Reproduce:
1. Boot
2. wait for gdm-greeter screen
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2010-01-14 16:28:47 EST
Created attachment 384456 [details]
/var/log/gdm/:0-greeter.log when I do get sounds/users
Comment 2 Tom London 2010-01-16 13:29:32 EST
A bit more on this:

I updated to 
gdm-plugin-fingerprint-2.29.4-2.fc13.x86_64
polkit-desktop-policy-0.96-1.fc13.noarch
gdm-user-switch-applet-2.29.4-2.fc13.x86_64
gdm-2.29.4-2.fc13.x86_64
polkit-gnome-0.96-1.fc13.x86_64
polkit-0.96-1.fc13.x86_64

but still have the same issue.

I have noticed that when logging out (that is, not rebooting) gdm-greeter invariably lists users and produces sounds when selecting, etc.

For completeness, I attach 2 more greeter log files produced "in sequence"; that is, the first from boot, the second produced by logging out and logging back in.

The first had no sound nor users listed, the second did.

Something more I can provide?
Comment 3 Tom London 2010-01-16 13:30:12 EST
Created attachment 384836 [details]
:0-greeter.log produced from fresh boot, no sound, no listed users
Comment 4 Tom London 2010-01-16 13:31:05 EST
Created attachment 384837 [details]
:0-greeter.log produced by logging out of above session and logging in.  Sound and users listed.
Comment 5 Tom London 2010-01-16 13:32:02 EST
Forgot to mention, attachments in 3 and 4 above have process ids removed (so I could diff them....)
Comment 6 Michael Stoykov 2010-02-18 07:56:53 EST
I confirm the bug ( I didn't notice the missing sound though)
Comment 7 Tom London 2010-02-18 09:11:22 EST
Entering an incorrect password generates a "popping" noise when the user list is displayed.

Does not do so when just "Other" is displayed.
Comment 8 Adam Williamson 2010-02-22 20:51:57 EST
*** Bug 566690 has been marked as a duplicate of this bug. ***
Comment 9 Adam Williamson 2010-02-22 20:52:25 EST
this seems to have been broken for ever, I sorta expected it'd get fixed by now.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Christopher Beland 2010-02-23 04:05:50 EST
"No user list" symptoms are also reported in bug 551247 (F12, reason unknown) and bug 561590 (F13, manually setting disable_user_list to false cured it).
Comment 11 Ray Strode [halfline] 2010-02-23 15:01:13 EST
The problem first manifested in F-12 when hal lost it's ConsoleKit support.

See bug 545267

The problem was caused by several bugs in the dbus and ConsoleKit packages.

Apparently, I didn't apply the fix properly in rawhide at the time.  See this gem of a diff:

http://cvs.fedoraproject.org/viewvc/F-13/ConsoleKit/ConsoleKit.spec?r1=1.52&r2=1.53&pathrev=ConsoleKit-0_4_1-4_fc13&

Note I only rev the release number and add a changelog entry.  I don't actually apply the patch I added to cvs.

This should be fixed in -5.  Moving to modified.
Comment 12 Fedora Update System 2010-02-23 15:02:20 EST
ConsoleKit-0.4.1-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ConsoleKit-0.4.1-5.fc13
Comment 13 Ray Strode [halfline] 2010-02-23 15:04:53 EST
*** Bug 551247 has been marked as a duplicate of this bug. ***
Comment 14 Ray Strode [halfline] 2010-02-23 15:07:06 EST
*** Bug 561590 has been marked as a duplicate of this bug. ***
Comment 15 Erwan LE PENNEC 2010-02-23 16:14:04 EST
I've tried to rebuilt the package on Fedora 12 and I've stumble across an xml related error:
/usr/bin/xmlto  xhtml-nochunks -m ../../doc/dbus/config.xsl ConsoleKit.xml
xmlto: /home/rpmbuild/rpmbuild/BUILD/ConsoleKit-0.4.1/doc/dbus/ConsoleKit.xml does not validate (status 3)
xmlto: Fix document syntax or use --skip-validation option
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
/home/rpmbuild/rpmbuild/BUILD/ConsoleKit-0.4.1/doc/dbus/ConsoleKit.xml:9: warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"

  Is there anything I can do to fix it?
Comment 16 Ray Strode [halfline] 2010-02-23 16:56:12 EST
You shouldn't need to rebuild the package for Fedora 12.  Fedora 12 got updates a while ago:

https://admin.fedoraproject.org/updates/F12/FEDORA-2009-13408
Comment 17 Tom London 2010-02-23 17:05:26 EST
After updating my Rawhide system with

ConsoleKit-0.4.1-5.fc13.x86_64
ConsoleKit-x11-0.4.1-5.fc13.x86_64
ConsoleKit-libs-0.4.1-5.fc13.x86_64
ConsoleKit-debuginfo-0.4.1-5.fc13.x86_64

I've rebooted twice in a row, and gotten the "user list" both times. [Hadn't seen this on a fresh reboot in quite a while!]

Believe this is "working for me".

Thanks!
Comment 18 antonio montagnani 2010-02-23 17:38:53 EST
Such packages were not pushed to 

http://download.fedoraproject.org/pub/fedora/linux/updates/$releasever/$basearch/
Comment 19 Adam Williamson 2010-02-23 19:27:34 EST
read comment #12.
Comment 20 Fedora Update System 2010-02-24 02:59:16 EST
ConsoleKit-0.4.1-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ConsoleKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-2802
Comment 21 Fedora Update System 2010-02-26 06:47:43 EST
ConsoleKit-0.4.1-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Rex Dieter 2010-02-26 12:41:10 EST
*** Bug 549687 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.