Bug 55037 - Anaconda does not include updated driver in the initrd image
Anaconda does not include updated driver in the initrd image
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 54330 59202 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 14:11 EDT by Boji Tony Kannanthanam
Modified: 2008-01-29 21:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-24 17:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boji Tony Kannanthanam 2001-10-24 14:11:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Trying to come up with a workaround for RH 7.2 installation on Intel/ICP
RAID controllers (bug #53505).

The installer does not use the latest updated driver (from a driver disk)
when creating an initrd image for subsequent boots after installation.
Instead the driver packaged into the initrd image is the one which comes
with RH7.2.
I was able to workaround this problem by using the "updates" option and by
changing bootloader.py such that it recreates the initrd.img file after the
updated driver is copied over to the
/mnt/sysimage/lib/modules/2.4.7-10/kernel/driver/scsi.

I have included the patch.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Created RH7.2 driver disk for "gdth" driver using the Driver module kit
at http://people.redhat.com/~dledford/mod_devel_kit.tgz
2. Used the driver disk during installation using "expert" and "linux dd"
modes.
3. Standard server install (both GUI and text) on a RAID volume goes fine.
4. On Reboot; when the "gdth" driver is loaded; it does not initialize.
This because the gdth driver included with the initrd image
(initrd-2.4.7-10.img) is a older version (the one supplied with RH7.2 and
NOT the one from the driver disk). I have verified this by copying the
initrd image generated during installation.	

Actual Results:  The system is unable to boot since it couldn't mount the
root filesystem

Expected Results:  Successful booting of the system. The root filesystem on
the RAID volume is successfully mounted.

Additional info:

here is the patch for bootloader.py which will solve this issue.

--- bootloader.py.orig  Wed Oct 24 11:01:26 2001
+++ bootloader.py       Wed Oct 24 11:03:39 2001
@@ -772,15 +772,15 @@

     w.pop()

-# note that this function no longer actually creates an initrd.
-# the kernel's %post does this now
+#Recreate initrd
 def makeInitrd (kernelTag, instRoot):
-    if iutil.getArch() == 'ia64':
-       initrd = "/boot/efi/initrd%s.img" % (kernelTag, )
-    else:
-       initrd = "/boot/initrd%s.img" % (kernelTag, )
+     initrd = "initrd%s.img" % (kernelTag, )
+     iutil.execWithRedirect("/sbin/mkinitrd", [ "/sbin/mkinitrd", "-v",
"-f", "/boot/%s" % initrd, kernelTag[1:] ], stdout = "/dev/tty5", stderr =
"/dev/tty5", searchPath = 1, root = instRoot)
+     log("Created new initrd %s install root %s ", initrd, instRoot)
+
+     return initrd
+

-    return initrd

 # return (disk, partition number) eg ('hda', 1)
 def getDiskPart(dev):
Comment 1 Jeremy Katz 2001-11-05 15:44:09 EST
Done a little bit different with the updates disk at 
http://people.redhat.com/~katzj/mkinitrd-dd-updates.img.  If you can try and see
if this works for you that would be great
Comment 2 Brent Fox 2001-11-19 12:52:55 EST
Any more info here?
Comment 3 Boji Tony Kannanthanam 2001-11-19 12:58:37 EST
I get a "Page not found error" when I access the URL. Is the link correct ?
Comment 4 Jeremy Katz 2001-11-21 23:57:49 EST
Sorry, it moved after fixing a couple of bugs and is now at
http://people.redhat.com/~katzj/ddinitrd-update.img.  Could you try with this image?
Comment 5 Boji Tony Kannanthanam 2001-11-29 14:50:31 EST
The updates disk works fine. Will this be posted on RH7.2 updates web pages ?
Comment 6 Jeremy Katz 2001-11-29 14:55:13 EST
It will probably be included in a set of updates sometime in the near-ish
future.  Specific planning for it has not yet been made yet.
Comment 7 Michael Fulbright 2002-01-15 15:09:34 EST
*** Bug 54330 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2002-02-03 17:41:48 EST
*** Bug 59202 has been marked as a duplicate of this bug. ***
Comment 9 Eli Spizzichino 2002-02-11 19:10:00 EST
on first boot I have this message:
VPS: cannot open root device 806 or 08:06
Please append a correct "root=" boot option

With rescue floppy all boot well.
This seems to be the same problem with SCSI device not already loaded but it
isn't because it happens imidiatly after the correct module init of my AIC7xxx
SCSI on boot
Comment 10 Dag Richards 2002-07-17 16:55:42 EDT
for search engine : Intel Raid 7.2
for people as dumb as me :  to use this update you seem to need to be doing a
new install
1) make the driver disk with the intel Raid drivers
2) make the disk from http://people.redhat.com/~katzj/ddinitrd-update.img by
downloading it,
make a clean dos disk 'mkfs -t msdos /dev/fd0' , run 'dd if=ddinitrd-update.img
of=/dev/fd0'
this will copy the image to the disk in your first floppy drive.
3) boot from the RedHat CD when you are given the selection prompt give it the
command
type 'linux dd updates' this tells it to both load the disk drivers _and_ the
update, install will now proceed and a reboot will succeed.


Comment 11 Brock Organ 2003-04-16 10:23:42 EDT
I received a report that this is a problem with Red Hat Linux 9 ...

Here is a portion of the email message:
-------------
I've an ISP 2150 with a LG440GX+ Motherboard and a SRCU31L intalled.
When I try to install RH 9 an error occurs because it can't find
any hard drives!!

I've read that there were some problems until RH7.2, and it's supposed to
use a driver disk, but I made a 7.1 driver disk and tried to install 7.1
and the same error occurs!
I've checked the console (ALT-F3 and ALT-F4) for logs, and doesn't appear
any error or something like:
*sugestion gdth device
*found gdth device

I hope that some of you could help me.

I sent for all of you because of "Bug 55037 - Anaconda does not include
updated driver in the initrd image"
--------------------
Comment 12 Jeremy Katz 2003-06-24 17:00:24 EDT
This is not related to dpt_i2o.  
Comment 13 Dag Richards 2003-08-20 18:27:53 EDT
For those as dumb as me ( a year later ).....
I have encountered this error as well on a RH 9 install.  It is simple to work
around. After completing your install do the following ....


1)boot into Rescue mode from the install cd Type "linux rescue" at the boot: prompt

2)Edit the /etc/modules.conf to remove the comment from in the line

alias scsi_hostadapter1 gdth

or if not there put it there

4) make a initrd image ex; type "mkinitrd newinitrd 2.2.5.15"
using the the kernel version you will be booting from

5) copy the new image to your /boot slice

6) edit /etc/grub.conf file to point to the new image
for the boot section you are using


7) reboot and relax

Redhat 9 intel raid srcu31 boot

Note You need to log in before you can comment on or make changes to this bug.