Bug 551685 - [abrt] ekiga - avahi crash in std::_Rb_tree_increment
Summary: [abrt] ekiga - avahi crash in std::_Rb_tree_increment
Keywords:
Status: CLOSED DUPLICATE of bug 539541
Alias: None
Product: Fedora
Classification: Fedora
Component: ekiga
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f60ed3b6fa1da21d76b09ea8795...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-01 10:46 UTC by Mihai T. Lazarescu
Modified: 2010-01-12 17:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-12 17:25:32 UTC


Attachments (Terms of Use)
File: backtrace (39.44 KB, text/plain)
2010-01-01 10:46 UTC, Mihai T. Lazarescu
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 606094 None None None Never

Description Mihai T. Lazarescu 2010-01-01 10:46:49 UTC
abrt 1.0.0 detected a crash.

Comment: Ekiga was open and connectedd to an asterisk server.  A neighbour was displayed under the Neighbours section.  When that neighbour closed its Ekiga client my Ekiga crashed, and this is the report.
Attached file: backtrace
cmdline: ekiga
component: ekiga
executable: /usr/bin/ekiga
kernel: 2.6.31.9-174.fc12.i686
package: ekiga-3.2.6-1.fc12
rating: 4
reason: Process was terminated by signal 11

Comment 1 Mihai T. Lazarescu 2010-01-01 10:46:54 UTC
Created attachment 381161 [details]
File: backtrace

Comment 2 Peter Robinson 2010-01-04 23:54:00 UTC
Is the reliably reproducible?

Comment 3 Mihai T. Lazarescu 2010-01-05 10:33:14 UTC
Yes.  I just crashed Ekiga twice in a row:

1. connect two Ekiga instances (A and B), running on 2 different F12 installations, to the same Asterisk server;
2. call B from A;
3. B answers the call;
4. 5s or so later A closes the call;
5. just a few seconds later Ekiga instance B exits with Ctrl-Q;
6. right after the A Ekiga instance crashes.

I just generated the bug #552488, maybe it grabbed better debug info.  Otherwise it should be a duplicate of this bug.

Comment 4 Mihai T. Lazarescu 2010-01-05 10:36:18 UTC
Comment #3 should have a:

1bis: wait for B and A to show up in the respective neighbour lists;

and step (2) should read:

2. call B from A by double clicking the B entry in the neighbour list;

Comment 5 Peter Robinson 2010-01-05 10:45:13 UTC
*** Bug 552488 has been marked as a duplicate of this bug. ***

Comment 6 Peter Robinson 2010-01-05 11:14:35 UTC
Thanks for the extra info. Reported it upstream, we'll see what they have to say.

Comment 7 Peter Robinson 2010-01-12 17:25:32 UTC

*** This bug has been marked as a duplicate of bug 539541 ***


Note You need to log in before you can comment on or make changes to this bug.