Bug 563745 - No login via kdm or startx possible.
No login via kdm or startx possible.
Status: CLOSED DUPLICATE of bug 566061
Product: Fedora
Classification: Fedora
Component: soprano (Show other bugs)
12
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.4
  Show dependency treegraph
 
Reported: 2010-02-10 19:25 EST by Peter Gückel
Modified: 2010-02-16 21:07 EST (History)
10 users (show)

See Also:
Fixed In Version: 2.4.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 09:45:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2010-02-10 19:25:53 EST
Description of problem:
Unable to log in to a KDE session.

Version-Release number of selected component (if applicable):


How reproducible:
Apply kdelibs-4.4.0-3 from Tuesday, along with the soprano and sesame2 updates that were issued at the same time. Reboot. KDM logs in and the constantine (?) splash screen appears. The dots in the semi-circle appear, and then the last 2 don't. It hangs and no further login happens. Curiously, after a long time, korganizer alert windows do appear, but there is noo plasma desktop and no panel and no plasmoids.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
In trying to get this to work, I downloaded and installed kdelibs-4.4.0-4.fc12.x86_64 from koji, but the result is the same. No login possible. I also, after having read some comments on the forum, edited nepomukserverrc from the command line and disabled (set to false) the arguments that enable both nepomuk and strigi. Still no login possible. I am forced to use gnome. I do not know if i686 is affected, as I dare not update the laptop.

Kevin Kofler asked that one: "mark the bug as "Blocks: kde-4.4" (enter kde-4.4 into the "Blocks" field) so it will show up on the kde-4.4 tracker", but this is not possible, as there is no 'blocks' field where such information can be entered (not even when viewing the advanced fields).
Comment 1 Peter Gückel 2010-02-10 19:27:52 EST
Ok, after submitting the bug, a new window opened and now I am presented with a 'blocks' field.
Comment 2 Kevin Kofler 2010-02-10 21:04:52 EST
Maybe try also getting kdebase-runtime-4.4.0-3.fc12 and kdebase-workspace-4.4.0-2.fc12.1 from Koji?
Comment 3 Kevin Kofler 2010-02-10 21:06:26 EST
(Reason: these, along with kdelibs-4.4.0-4, were built against soprano 2.4.0, it seems there's something between 2.3.73 and 2.4.0 that requires a rebuild of the Nepomuk stuff, see http://lists.kde.org/?l=kde&m=126584264104700&w=2 .)
Comment 4 Peter Gückel 2010-02-10 21:17:13 EST
Ok. I got all of the packages under these heading, with the exception of the noarchs, wallpapers and cursor-themes, but I did get runtime-flags.

I will install and reboot and see what happens.
Comment 5 Kevin Kofler 2010-02-10 21:23:05 EST
Oh, and are you sure this isn't some X11 or driver issue? Try downgrading "pixman" which was updated on Feb 9.
Comment 6 Peter Gückel 2010-02-10 21:31:56 EST
Like I just said, I got the aforementioned packages from koji, not kde-redhat. I rebooted and it is roughly like before: a log hang, about a full 2-3 minutes, then the last 2 dots DO appear, and the splash screen disappears and a plain blue screen appears with my gold mouse pointer in the middle. Yakuake loads and I can access it via F12, but it will not retract. I can move to all 4 virtual desktops, as I have it set so that it just flips over when the mouse moves to the edge, but there is no plasma, no panel and no plasmoids, no cashew, etc. I cannot do anything, no right click, nothing, just the plain blue background. I have to kill X to get out to kdm.
Comment 7 Peter Gückel 2010-02-10 21:36:28 EST
(In reply to comment #5)
> Oh, and are you sure this isn't some X11 or driver issue? Try downgrading
> "pixman" which was updated on Feb 9.    

Usually, KDE does not pose this much problem. I have had a funny feeling about this and I went through all of the updates I could think of last night, but I don't know how to determine, after the fact, what was updated when. I went to some mirror sites and had a look, but they were showing Feb8, not Feb9, so it didn't help me at all. Then I went through the updates-testing mailing list, but they only show updates-testing, not updates, so that didn't help, either.

I have pixman-0.16.6-1.fc12.x86_64 presently. I will search koji and see what the previous one for f12 is and install that.
Comment 8 Peter Gückel 2010-02-10 21:40:49 EST
Ok, I downgraded to pixman-0.16.4-2.fc12.x86_64. I will log out and into kde, or even reboot and see.
Comment 9 Peter Gückel 2010-02-10 22:19:50 EST
Well, that was an unpleasant adventure :-(( After downgrading pixman and rebooting, I no longer had any X at all! The first time, plymouth ran, and then the system just hung. The second time, plymouth ran, then it stopped and rebooted all by itself!!

I had to boot into run level 3 and upgrade pixman again. Now, I have an X (gnome only, no kde) session again.

I noticed that I still have a couple of those .kde44.rpms that were specially made for kde-redhat a while ago. They are webkit and webpart. I cannot uninstall them, because konq-plugins and kdenetwork depend on them. Could they be part of the problem preventing me from logging in to KDE?

...


This is really getting pretty tedious and time-consuming, not to mention unpleasant. I just want to get KDE back (gnome feels like a quadruplegic in a straitjacket). Is there some way I can just get back to the pure fedora versions and remove the kde-redhat stuff? I might still run updates-testing, but kde-redhat is just getting awfully confusing, with so many different versions and incompatibilities (I know it has workded splendidly right up unti yesterday, but this seems too much, a whole day only in gnome, and now, briefly, not even an X session). I need to have a computer that actually works.
Comment 10 Kevin Kofler 2010-02-10 22:28:01 EST
> I noticed that I still have a couple of those .kde44.rpms that were specially
> made for kde-redhat a while ago. They are webkit and webpart. I cannot
> uninstall them, because konq-plugins and kdenetwork depend on them. Could they
> be part of the problem preventing me from logging in to KDE?

I don't think so.
Comment 11 Lukas Middendorf 2010-02-11 04:13:15 EST
I'm also seeing this after yesterday's update to 4.4 from kde-unstable on f12. When I try to login via kdm, I see the KDE splash screen and after minutes my display just goes black with mouse cursor and nothing further happens.

This is no problem with a new user account or with clean ~/.kde. It also happens with my backup of ~/.kde that was last used with KDE 3.3.4, so it is not a problem with config messed up by one of the RCs I had installed.
Comment 12 Kevin Kofler 2010-02-11 08:45:06 EST
As soprano was one of the packages you updated when this started happening, can you please retest with soprano-2.4.0.1-1.fc12?
http://koji.fedoraproject.org/koji/buildinfo?buildID=155619
(Rex also pushed it to kde-unstable.)
Comment 13 Michal Hlavinka 2010-02-11 09:24:44 EST
I have the same problem using packages form koji (I was using rc versions with no problem but I can't tell which package broke this).

I use soprano-2.4.0.1-1.fc12 from koji.

New testing user can log in without any problem.

Odd is even kmail does not start (was working in last rc version), but this is maybe unrelated issue:

"org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"

kmail(7652)/nepomuk (library) <unnamed>::GlobalModelContainer::init: Connecting to local socket "/home/mhlavink/.kde/share/apps/nepomuk/socket"

"/usr/bin/kmail(7652)" Error in thread 139941368653888 : "QLocalSocket::connectToServer: Invalid name"
QMutex::unlock: mutex lock failure: 

<long delay>

Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

back to "no login" problem, I can even hear the login sound after some time (probably some timeout slows it)
Comment 14 Lukas Middendorf 2010-02-11 09:33:43 EST
Seems to be related to comic strip plasma widget. I have removed everything related to the comic widget from .kde/share/config/plasma-desktop-appletsrc and now I can login again. Also when I try to add a new comic widget with a fresh user, the screen freezes.
Comment 15 Kevin Kofler 2010-02-11 09:36:05 EST
So it sounds like it's not a Soprano issue.

The kdepim issue looks like bug 563789.
Comment 16 Michal Hlavinka 2010-02-11 09:42:33 EST
oops, I've missed the last .1 in soprano version. I've used 2.4.0.1 and everything works fine now (login ok, kmail ok)

THANKS
Comment 17 Kevin Kofler 2010-02-11 09:45:51 EST
Fixed in Rawhide and kde-unstable, stable releases not affected, closing.
Comment 18 Michal Hlavinka 2010-02-11 10:55:28 EST
just for the record:

my broken account had a comic strip plasma widget too :)
Comment 19 Kevin Kofler 2010-02-16 21:07:04 EST
Let's make it clear that this and the other 2 Soprano-induced issues are all duplicates of the same (fixed) bug.

*** This bug has been marked as a duplicate of bug 566061 ***

Note You need to log in before you can comment on or make changes to this bug.