This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 563789 - All Kontact Apps fail to start
All Kontact Apps fail to start
Status: CLOSED DUPLICATE of bug 566061
Product: Fedora
Classification: Fedora
Component: soprano (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.4
  Show dependency treegraph
 
Reported: 2010-02-11 01:46 EST by Eli Wapniarski
Modified: 2010-02-16 21:07 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.4.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 09:42:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2010-02-11 01:46:05 EST
As of kdepim 4.4.0 either build 1 or 3 Kontact and all related apps will not start unless I do the following...

One thing to note: On the initial startup of Kontact Akonadi seems to freeze. All kontact related process and akonadi related process need to be killed and then from a console or the run command, one needs to run akonadiconsole to get things to work with the following procedure.

Please refer to:

https://bugs.kde.org/show_bug.cgi?id=218369

It would seem that if one were to go to:

    kontact_summary.rc

and remove the

   kontact_specialdatesplugin

entry. Also...

in:

    korganizerrc

I removed the :

   Special Occasion

entry

Everything else seems to work fine.
Comment 1 Kevin Kofler 2010-02-11 08:48:06 EST
Rex Dieter says this is fixed for him with soprano-2.4.0.1-1.fc12:
http://koji.fedoraproject.org/koji/buildinfo?buildID=155619
(Rex also pushed it to kde-unstable.)

Does anybody still get kdepim crashes with kdepim-4.4.0-3.fc12 and soprano-2.4.0.1-1.fc12?
Comment 2 Kevin Kofler 2010-02-11 09:37:17 EST
Unfortunately, Michal Hlavinka says at https://bugzilla.redhat.com/show_bug.cgi?id=563745#c13 that this still happens with soprano-2.4.0.1. :-(
Comment 3 Kevin Kofler 2010-02-11 09:42:08 EST
Nevermind, he now confirmed on IRC that 2.4.0.1 did fix it (he was actually still using 2.4.0 when he posted that comment).
Comment 4 Eli Wapniarski 2010-02-11 10:41:47 EST
It would see that kontact is working again. However, I'm constantly getting the message that nepomuk indexing agents have been disabled, if nepomuk has been enabled in system settings.
Comment 5 Kevin Kofler 2010-02-11 10:45:36 EST
If you previously used Nepomuk with Virtuoso 5, it will not work with Virtuoso 6 unless you delete or convert Nepomuk's Virtuoso database (and we haven't gotten the converter to work properly, it seems).
Comment 6 Eli Wapniarski 2010-02-11 15:23:56 EST
What seems to happen, is that if Strigy is not activated then I get the error that nepomuk is deactivated.

Akonadi seems to be working, but on startup I get error message that the log files seems to be missing. So.... I was wondering where the log files should be and what they are called?
Comment 7 Eli Wapniarski 2010-02-12 02:32:35 EST
Fixed what I thought were mising error log messages but infact messages stating that "old" error log messages existed. Fixed that by simply deleting the old error logs.

One final issue.... After testing the Akonadi installaton, I constantly got the errors in the mysql error logs that stated.

091029 12:23:04 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
091029 12:23:04 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist


After some digging.... I found the solution at:

http://bbs.archlinux.org/viewtopic.php?id=78358

Which goes on to suggest:

akonadictl stop
rm  -r ~/.local/share/akonadi/db_data
mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data/
akonadictl start

That did the trick.... Which means that Akonadi does not correctly initialize the mysql database on first run.

Which I guess needs to be corrected.
Comment 8 Kevin Kofler 2010-02-16 21:07:21 EST
Let's make it clear that this and the other 2 Soprano-induced issues are all duplicates of the same (fixed) bug.

*** This bug has been marked as a duplicate of bug 566061 ***

Note You need to log in before you can comment on or make changes to this bug.