Bug 56525 - XFree86 4.1.0-6 fails on ATI Radeon Mobility LY
XFree86 4.1.0-6 fails on ATI Radeon Mobility LY
Status: CLOSED DUPLICATE of bug 55675
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 11:14 EST by Didier
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-23 00:12:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config.new (2.45 KB, text/plain)
2001-11-20 11:15 EST, Didier
no flags Details
XF86Config.new log (21.65 KB, text/plain)
2001-11-20 11:16 EST, Didier
no flags Details
XF86Config LinuxCare ( http://www.linuxcare.com/labs/certs/ibm/thinkpad/a30/rh71-config.epl ) (2.26 KB, text/plain)
2001-11-20 11:18 EST, Didier
no flags Details
XF86Config LinuxCare log (21.86 KB, text/plain)
2001-11-20 11:20 EST, Didier
no flags Details
lspci report (4.69 KB, text/plain)
2001-11-20 11:21 EST, Didier
no flags Details

  None (edit)
Description Didier 2001-11-20 11:14:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
When starting XFree86 (up to 4.1.0-6) after an "XFree86 -configure", X
fails to detect the panel size and quits.

Analog to bug report #55675

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. XFree86 -configure
2. XFree86 -xf86config /xyz.file

	

Actual Results:  X crashes.

Expected Results:  X should start :)


Additional info:

IBM A30p, ATI Radeon Mobility M6 LY, LCD panel 1600x1200, XFree86-4.1.0-6.

Tried with different XF86Config's (see attachments) :

- resulting from step 1. (XFree86 -configure)
- example file from LinuxCare for IBM A30 (1400x1050), with and without
'Option "UseFBDev" "True" '
- explicitly stating 'Option "PanelWidth"/"PanelHeigth" '
Comment 1 Didier 2001-11-20 11:15:58 EST
Created attachment 38026 [details]
XF86Config.new
Comment 2 Didier 2001-11-20 11:16:58 EST
Created attachment 38027 [details]
XF86Config.new log
Comment 3 Didier 2001-11-20 11:18:19 EST
Created attachment 38028 [details]
XF86Config LinuxCare ( http://www.linuxcare.com/labs/certs/ibm/thinkpad/a30/rh71-config.epl )
Comment 4 Didier 2001-11-20 11:20:19 EST
Created attachment 38029 [details]
XF86Config LinuxCare log
Comment 5 Didier 2001-11-20 11:21:08 EST
Created attachment 38030 [details]
lspci report
Comment 6 Didier 2001-11-22 07:19:23 EST
"Solved" by compiling and installing latest CVS XFree86 (4.1.99.2, 21/11/2001).

No hardware acceleration due to bug #56526 (agpgart oops)


Related question to Mr. Harris :

Examining the RH XFree86.spec-file from XFree86-4.1.0-6.src.rpm : does it
suffice to remove the patch-files and references, and replace the
XFree86-...-tar.bz2 with the CVS tar.bz2, in order to create a CVS-based RPM ?


Comment 7 Mike A. Harris 2001-11-23 00:12:23 EST
No, removing the patches, and whatnot is not enough to build CVS
in RPM format.  Each release of XFree86 is sufficiently changed
that it requires a fair bit of engineering to twist into RPM format.

I have been working on XFree86 CVS in RPM format now for about 3
weeks.  It mostly builds, but there are some issues that still need
to be resolved.  Then I need to figure out what all new fonts there
are, and straighten out the whole font mess..  and then add new libs,
X extensions, and executables, etc to the files section.  Once I
have packages that build correctly (or appear to at least) and
have all the new files included and intact, I'll test with rpmlint
and fixup, then do installation and upgrade tests.

I expect to have preliminary packages ready within 2-3 weeks, but
it may be sooner than that, or later than that depending on what
all I need to fix.

One thing that is horribly broken is Glide3.  I am likely going to
separate Glide3 back out into separate RPM package and deprecate it,
as it wont build with new libtool/autoconf, gcc3.
Comment 8 Mike A. Harris 2001-11-23 03:28:29 EST

*** This bug has been marked as a duplicate of 55675 ***

Note You need to log in before you can comment on or make changes to this bug.