Bug 5713 - text installer fails at the beginning.
text installer fails at the beginning.
Status: CLOSED DUPLICATE of bug 5575
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
: 6354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-08 03:24 EDT by giampiero.raschetti
Modified: 2015-01-07 18:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 15:32:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description giampiero.raschetti 1999-10-08 03:24:35 EDT
I'm installing from scratch RedHat 6.1 over a Mitac notebook
5033. I have been using redhat 5.2 then 6.0 on the same
notebook from one year and it works great.
Now after loading the kernel, in text mode (graphics mode
hangs my laptop LCD TFT matrix), when installation prompts
for chosing a lenguage, computer completely hangs with any
key. I tried using "text expert" mode at boot time, it goes
ahead that question, but the next screen hangs the same
manner.
Comment 1 Joe Ceklosky 1999-10-14 11:44:59 EDT
I have had the same problem with 5.9, 6.0 and 6.1.  The only way I
was able to get it to install was to go graphic install, but hook
up an external monitor, because the graphic installer will NOT get
the clocks right for the video.
Comment 2 Jay Turner 1999-10-21 07:58:59 EDT
*** Bug 5722 has been marked as a duplicate of this bug. ***

Installation with pcmcia.img hangs on a
Gericom Overdose 6200 Notebook at the
Welcome Screen no matter whether in graphical,
text or expert mode. The chosen install type
was FTP. Loading of second stage was successful,
after language and kbd selection. The keyboard
goes dead - just hitting the power button works -
not even console switching. After 20 tries, I
managed to switch consoles just before the
notebook hung, and apparently the last thing it
tries to do is to insmod raid5.o.

------- Additional Comments From jceklosk@voicenet.com  10/14/99 11:48 -------
I have a Jetta 7050XL (Mitac 5033) with the same problem.
I am going to rebuild the install disk and not install the raid
stuff.  This bug has been in Redhat since 5.9!
Comment 3 Jay Turner 1999-10-21 15:32:59 EDT
*** Bug 6051 has been marked as a duplicate of this bug. ***

On Broadaxe 6280 laptops (PentiumMMX or Winchip 2 CPU),
after selecting the language and keyboard type, at the
welcome screen, the installer locks up. Cannot switch VC's,
cannot 3key-salute. Only a poweroff works.

This happens both for pcmcia/network installs as well as
local CDROM installs.

This has been verified on several different machines.

If I can do anything to provide more information (e.g. add
switches to the LILO prompt & re-run) I will be more than
happy to do so.

Otherwise, if it is possible to run the installer script
itself from an already installed system (i.e. perform an
upgrade) I'd rather do that.


------- Additional Comments From jturner@redhat.com  10/18/99 12:37 -------
Try running the installer in text mode (type "text" at the boot
prompt)  That should allow you to perform the installation.  Reopen
the bug if you are still having problems.

------- Additional Comments From wowbagger@sktc.net  10/18/99 14:51 -------
This happens in both "expert" and "text" mode.

------- Additional Comments From wowbagger@sktc.net  10/18/99 17:24 -------
This happens in both "expert" and "text" mode.
Comment 4 Jay Turner 1999-10-21 15:55:59 EDT
*** Bug 6174 has been marked as a duplicate of this bug. ***

Sorry if this is the wrong module, but I am a newbie.  I am
trying to install on my laptop over ftp with rh6.1 (2.2.12-
20), and after it loads the ram disk from the ftp site.
Console 4 shows something about entering raidlevel(5), and
then it freezes.   I have a compaq LTE5100 (P90, 24mb,
840mb, no cdrom), and using a xircom "CreditCard
ehternet+modem 33.6".   I was looking for a similar bug,
but couldn't find any thing.  It locks up the system, and
you cannot soft reboot, or turn on/off caps and numlock.
Again, I am sorry if I am sending this to the
wrong "componet".

.Ben

------- Additional Comments From notting@redhat.com  10/21/99 13:47 -------
What happens if you hit 'i' to boot in interactive mode.
Which service does it freeze at?
Comment 5 Joe Ceklosky 1999-10-22 10:50:59 EDT
This lock up is STILL happening with the new images just released.  I
know they did not specifically say they fixed it, but it was worth a
shot.  If we think it's the raid stuff, how can we alter the loader
to NOT load the raid stuff?   This bug has been in Redhat since 5.9
Beta when the raid and 2.2 kernel appeared.
Here is what I did.  I booted with the boot image, but did not have
the CD in the drive.  It booted fine with no lockup.  It's when it
loads info from the CD ie. the raid stuff, it locks up.
Also why is the raid stuff even on the boot CD's?  Can you make the
raid stuff an OPTION?


------- Additional Comments From   10/22/99 13:21 -------
I've resolved a similar locking problem on several notebooks by
uncommenting the "#exclude irq3" line which resides in
/etc/pcmcia/config.opts which is in the initrd.img which is in the
pcmcia.img.  Evidently this causes a unresolvable irq conflict on
some laptops.
Comment 6 david.hagood 1999-10-22 14:18:59 EDT
The lockup seems similar to a lockup I experienced when I enabled APM.
I need to try rebuilding the install kernel with APM turned off and
see if that resolves the problem

------- Additional Comments From   10/22/99 14:58 -------
I did some testing, and in my case (Gericom Overdose) it apparently
is NOT the raid module. I rewrote the loader to not insmod the raid
modules, and it still locks up. anaconda and anaconda.real are
started, and right after displaying the welcome screen anaconda.real
(and apparently the kernel) hangs. When anaconda is changed to drop
a shell, the notebook works well. The moment when
   exec anaconda.real <lots of parameters>
is entered, the hangup happens.
Comment 7 david.hagood 1999-10-23 15:45:59 EDT
I tried the RHEA-1999:045 update, and it still locks up. Does the 6.1
install kernel have APM enabled? If it does, can we get a build that
has it disabled? This lockup is suspiciously like a lockup I had when
I actived "Make Idle calls" in the kernel.
Comment 8 Hermann Schichl 1999-10-23 16:45:59 EDT
The configuration file
kernel-2.2.12-i386-BOOT.config
from the kernel package says
 # CONFIG_APM is not set
So APM support is already disabled.
Comment 9 Joe Ceklosky 1999-10-25 09:56:59 EDT
I have the same problem on a Mitac 5033 with AMD K6/2 300Mhz CPU.
Is the make idle CPU calls enabled on the boot disk kernels?
I know this locks my laptop solid if it is.
Comment 10 Joe Ceklosky 1999-10-25 11:47:59 EDT
I have the same problem on a Mitac 5033 with AMD K6/2 300Mhz CPU.
Is the make idle CPU calls enabled on the boot disk kernels?
I know this locks my laptop solid if it is.

------- Additional Comments From   11/01/99 14:59 -------
Hi,
I have the same problem, but not on a'laptop...
I'm trying to install LINUX 6.1 on a 166 mhz pentium PC 32 mb mem.
I found out that if you switch screens from CTRL,ALT,F3 to
CTRL,ALT,F1 at about 5 a'10 seconds after raid5.o loads the
instalation does'nt hang !! (I know this is not a solution, but it
works, sometimes.......

Richard v/d Meer
Comment 11 Jay Turner 2000-02-08 14:04:59 EST
*** Bug 6354 has been marked as a duplicate of this bug. ***
Comment 12 david.hagood 2000-02-08 16:23:59 EST
I received e-mail that my instance of this bug had been fixed, but I cannot find
any updates to the installer to test this. Am I missing something?
Comment 13 Jay Turner 2000-02-11 15:32:59 EST
*** This bug has been marked as a duplicate of 5575 ***

Note You need to log in before you can comment on or make changes to this bug.