Bug 572882 - The number of Devices(and MB) selected displayed incorrectly in Specialized Storage Devices
Summary: The number of Devices(and MB) selected displayed incorrectly in Specialized S...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 576143 589315 (view as bug list)
Depends On:
Blocks: F13Target
TreeView+ depends on / blocked
 
Reported: 2010-03-12 09:17 UTC by He Rui
Modified: 2010-05-24 20:10 UTC (History)
5 users (show)

Fixed In Version: anaconda-13.39-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 20:10:40 UTC


Attachments (Terms of Use)
logs under /tmp/ (34.19 KB, application/x-tar)
2010-03-12 09:17 UTC, He Rui
no flags Details
error1 in screen (136.00 KB, image/png)
2010-03-12 09:18 UTC, He Rui
no flags Details
error2 in screen (137.01 KB, image/png)
2010-03-12 09:18 UTC, He Rui
no flags Details
/tmp/* after 'updates' (47.87 KB, application/x-gzip)
2010-03-15 02:00 UTC, He Rui
no flags Details

Description He Rui 2010-03-12 09:17:05 UTC
Created attachment 399595 [details]
logs under /tmp/

Description of problem:
'0 device(s)(0MB) selected' displayed when actually one device was selected and '-1 device(s)(-8192 MB) selected' displayed when no device selected. Please refer to the attachment.

Version-Release number of selected component (if applicable):
anaconda 13.32

How reproducible:
100%

Steps to Reproduce:
1.During f13-alpha-rc4 installation, select 'Specialized Storage Devices' and click 'next'
2.Select any device(s) and click 'next' 
3.When it prompted to 'Fresh installation or Upgrade' screen, click 'back'
4.The error displayed

Note that step 2,3 is essential.
 
Additional info:
Error screens are attached as well as logs under /tmp/.

Comment 1 He Rui 2010-03-12 09:18:13 UTC
Created attachment 399596 [details]
error1 in screen

Comment 2 He Rui 2010-03-12 09:18:45 UTC
Created attachment 399597 [details]
error2 in screen

Comment 3 Chris Lumens 2010-03-12 15:04:56 UTC
Does updates=http://clumens.fedorapeople.org/568875.img fix this?

Comment 4 He Rui 2010-03-15 01:59:03 UTC
(In reply to comment #3)
> Does updates=http://clumens.fedorapeople.org/568875.img fix this?    

Thanks, but the same issue still happens.

/tmp/* is attached.

Comment 5 He Rui 2010-03-15 02:00:13 UTC
Created attachment 400095 [details]
/tmp/* after 'updates'

Comment 6 Chris Lumens 2010-03-15 19:14:45 UTC
Thanks for the explicit steps to reproduce.  Much easier to figure out exactly what's going on that way.

Comment 7 Chris Lumens 2010-03-23 14:01:34 UTC
*** Bug 576143 has been marked as a duplicate of this bug. ***

Comment 8 He Rui 2010-04-22 08:26:06 UTC
Still reproducible when testing anaconda 13.37.2 of F13 Beta

Comment 9 James Laska 2010-04-22 14:30:26 UTC
I see this as well during the Storage Test Day (anaconda-13.37.2).  The reproducer for me is ...

1) Boot a system with 1 local drive and 1 remote iSCSI drive
2) Select 1 of 2 devices
3) Click Next
4) Click Back
5) Deselect the only selected device

Observe the -1 disk count

Comment 10 James Laska 2010-04-22 14:32:35 UTC
This should get on F13Blocker or CommonBugs.  I'm adding it to F13Target so that we can pull any fix in, but it currently wouldn't block the release.

Certainly would be nice to fix, but I think we can clearly articulate the cause of this failure, so worst case we'll document the issue.

Comment 11 Chris Lumens 2010-04-23 14:47:17 UTC
Okay, this just needed to be cherry-picked over from master.  I've pushed that and updated the Fixed In Version: field to reflect this.

Comment 12 Fedora Update System 2010-04-28 21:08:39 UTC
anaconda-13.39-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.39-1.fc13

Comment 13 Chris Lumens 2010-05-05 20:19:33 UTC
*** Bug 589315 has been marked as a duplicate of this bug. ***

Comment 14 James Laska 2010-05-24 20:09:54 UTC
Confirmed fix in 13.42


Note You need to log in before you can comment on or make changes to this bug.