Bug 574259 - [abrt] crash in libhocr-gtk-0.10.17-5.fc12: sane-pygtk:532:combobox_scanner_changed_cb:IndexError: list index out of range
Summary: [abrt] crash in libhocr-gtk-0.10.17-5.fc12: sane-pygtk:532:combobox_scanner_c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libhocr
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Oron Peled
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c1311aa2
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-16 23:56 UTC by Marcos Braz d e Souza
Modified: 2010-07-08 18:11 UTC (History)
3 users (show)

Fixed In Version: libhocr-0.10.17-6.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 17:39:12 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (457 bytes, text/plain)
2010-03-16 23:56 UTC, Marcos Braz d e Souza
no flags Details

Description Marcos Braz d e Souza 2010-03-16 23:56:16 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: python /usr/bin/sane-pygtk
component: libhocr
executable: /usr/bin/sane-pygtk
kernel: 2.6.31.5-127.fc12.i686.PAE
package: libhocr-gtk-0.10.17-5.fc12
reason: sane-pygtk:532:combobox_scanner_changed_cb:IndexError: list index out of range
release: Fedora release 12 (Constantine)

backtrace
-----
sane-pygtk:532:combobox_scanner_changed_cb:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/sane-pygtk", line 532, in combobox_scanner_changed_cb
    scanner = sane.open(self.sane_devices[scanner_number][0])
IndexError: list index out of range

Local variables in innermost frame:
scanner_number: -1
self: <__main__.MainWindow instance at 0x9e5b52c>
obj: <gtk.ComboBox object at 0x9e67464 (GtkComboBox at 0x9ef1800)>

Comment 1 Marcos Braz d e Souza 2010-03-16 23:56:19 UTC
Created attachment 400602 [details]
File: backtrace

Comment 2 a.aspden 2010-03-28 17:13:13 UTC

How to reproduce
-----
1.Start hocr-gtk
2.click File -> Scan
3.Click Scan


Comment
-----
I don't have a scanner connected.

Comment 3 Simon 2010-06-06 12:44:17 UTC
Package: libhocr-gtk-0.10.17-5.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. I have an epson GT-7000 (scsi) connected and samsung SCX4xx16 on usb
2. But xsane is reporting no devices available
3. The samsung software can scan from the SCX but does not detect the epson


Comment
-----
I have successfully scanned from the epson when I first installed it so something has happened to make it undetected

Comment 4 Fedora Update System 2010-06-07 01:06:59 UTC
libhocr-0.10.17-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12

Comment 5 Oron Peled 2010-06-07 01:29:40 UTC
Since upstream did not address the bugs for a very long time, I decided to
apply a small fix: When a user tries to preview/scan without a scanner
detected, the program now should pop-up a dialog explaining this.

Please review the update. The built packages can be downloaded for testing from:
  https://koji.fedoraproject.org/koji/buildinfo?buildID=177013
You can than comment on the results in:
  http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12
(or here, if you have problems)

This should fix a common problem that was manifested in three separate
bug reports:
  - https://bugzilla.redhat.com/show_bug.cgi?id=574259 (this one)
  - https://bugzilla.redhat.com/show_bug.cgi?id=577657
  - https://bugzilla.redhat.com/show_bug.cgi?id=574631

Simon (comment 3) -- your problem is not related to this bug. Please read on.
The scan function work via sane. As a result, only scanners supported by sane
can be used directly from hocr utilities.

So I can think about two options for you:
 * Quick, but ugly... Work with the Samsung scanner in two steps:
   - Scan using its (proprietary?) software to a supported image file.
   - Use the image in hocr.
 * Check why your epson scanner does not work with *sane* itself. According
   to sane documentation it should:
     http://linux.die.net/man/5/sane-epson
   If this fails, try to collect as much information as you can and open a
   new bug report against sane.

Comment 6 Fedora Update System 2010-06-07 22:33:20 UTC
libhocr-0.10.17-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libhocr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12

Comment 7 Fedora Update System 2010-07-06 22:32:09 UTC
libhocr-0.10.17-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc13

Comment 8 Fedora Update System 2010-07-07 17:37:15 UTC
libhocr-0.10.17-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libhocr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc13

Comment 9 Fedora Update System 2010-07-07 17:38:57 UTC
libhocr-0.10.17-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-07-08 18:11:23 UTC
libhocr-0.10.17-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.