Bug 577657 - [abrt] crash in libhocr-gtk-0.10.17-5.fc12: sane-pygtk:282:button_scan_clicked_cb:IndexError: list index out of range
Summary: [abrt] crash in libhocr-gtk-0.10.17-5.fc12: sane-pygtk:282:button_scan_clicke...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libhocr
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Oron Peled
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1c4c67e0
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-28 17:19 UTC by a.aspden
Modified: 2010-07-08 18:11 UTC (History)
2 users (show)

Fixed In Version: libhocr-0.10.17-6.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 17:39:16 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (443 bytes, text/plain)
2010-03-28 17:19 UTC, a.aspden
no flags Details

Description a.aspden 2010-03-28 17:19:27 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: python /usr/bin/sane-pygtk --file /home/drwbns/.hocr-gtk/temp_sane_image.png
component: libhocr
executable: /usr/bin/sane-pygtk
kernel: 2.6.32.9-70.fc12.i686.PAE
package: libhocr-gtk-0.10.17-5.fc12
reason: sane-pygtk:282:button_scan_clicked_cb:IndexError: list index out of range
release: Fedora release 12 (Constantine)

backtrace
-----
sane-pygtk:282:button_scan_clicked_cb:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/sane-pygtk", line 282, in button_scan_clicked_cb
    scanner = sane.open(self.sane_devices[scanner_number][0])
IndexError: list index out of range

Local variables in innermost frame:
scanner_number: -1
self: <__main__.MainWindow instance at 0x8d275ac>
obj: <gtk.Button object at 0x8d33694 (GtkButton at 0x8d6b9f8)>

Comment 1 a.aspden 2010-03-28 17:19:29 UTC
Created attachment 403118 [details]
File: backtrace

Comment 2 Oron Peled 2010-03-28 21:57:48 UTC
 * A similar (but not identical) bug is #574631
 * A mail was sent to upstream maintainer today:
 > ...
 > While you are at it, note that people bumped into a variant of the
 > same problem:
 >   https://bugzilla.redhat.com/show_bug.cgi?id=577657
 > From the callback name, it looks like it happen when someone uses
 > the "scan" button and not the "preview" button as was the original
 > report:
 >   https://bugzilla.redhat.com/show_bug.cgi?id=574631
 >
 > However, the stack-trace in bug 577657 indicate that in this case the
 > application crash and does not throw an exception.

Comment 3 Fedora Update System 2010-06-07 01:07:03 UTC
libhocr-0.10.17-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12

Comment 4 Oron Peled 2010-06-07 01:31:29 UTC
Further info in: https://bugzilla.redhat.com/show_bug.cgi?id=574259

Comment 5 Fedora Update System 2010-06-07 22:33:26 UTC
libhocr-0.10.17-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libhocr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12

Comment 6 Simon 2010-06-09 09:56:49 UTC
Package: libhocr-gtk-0.10.17-5.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1.every time I use an application to scan
2.from Epson GT-7000
3.it isn't detected, and sometimes there's a crash too

Comment 7 Fedora Update System 2010-07-06 22:32:14 UTC
libhocr-0.10.17-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc13

Comment 8 Fedora Update System 2010-07-07 17:37:20 UTC
libhocr-0.10.17-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libhocr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc13

Comment 9 Fedora Update System 2010-07-07 17:39:02 UTC
libhocr-0.10.17-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-07-08 18:11:29 UTC
libhocr-0.10.17-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.