Bug 574631 - [abrt] crash in libhocr-gtk-0.10.17-5.fc12: sane.py:151:_getSaneSignature:RuntimeError: no scanner available
Summary: [abrt] crash in libhocr-gtk-0.10.17-5.fc12: sane.py:151:_getSaneSignature:Run...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libhocr
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Oron Peled
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:14f98787
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-18 01:33 UTC by Marcos Braz d e Souza
Modified: 2010-07-08 18:11 UTC (History)
1 user (show)

Fixed In Version: libhocr-0.10.17-6.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 17:39:21 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (658 bytes, text/plain)
2010-03-18 01:33 UTC, Marcos Braz d e Souza
no flags Details

Description Marcos Braz d e Souza 2010-03-18 01:33:31 UTC
abrt 1.0.8 detected a crash.

architecture: i686
cmdline: python /usr/bin/sane-pygtk
component: libhocr
executable: /usr/bin/sane-pygtk
kernel: 2.6.31.5-127.fc12.i686.PAE
package: libhocr-gtk-0.10.17-5.fc12
reason: sane.py:151:_getSaneSignature:RuntimeError: no scanner available
release: Fedora release 12 (Constantine)

backtrace
-----
sane.py:151:_getSaneSignature:RuntimeError: no scanner available

Traceback (most recent call last):
  File "/usr/bin/sane-pygtk", line 213, in button_preview_clicked_cb
    scanner = sane.open(self.sane_devices[scanner_number][0])
  File "/usr/lib/python2.6/site-packages/sane.py", line 288, in open
    new=SaneDev(devname)
  File "/usr/lib/python2.6/site-packages/sane.py", line 143, in __init__
    d['sane_signature'] = self._getSaneSignature(devname)
  File "/usr/lib/python2.6/site-packages/sane.py", line 151, in _getSaneSignature
    raise RuntimeError('no scanner available')
RuntimeError: no scanner available

Local variables in innermost frame:

Comment 1 Marcos Braz d e Souza 2010-03-18 01:33:34 UTC
Created attachment 400929 [details]
File: backtrace

Comment 2 Oron Peled 2010-03-28 21:55:00 UTC
 * A mail was sent to author on 2010-03-18 (there is no open bug-tracker for
   that project in berlios.org:
 > ...
 > I am sending you this directly since the bug tracker in the berlios
 > project page is turned off.
 >
 > Since Fedora started using ABRT (Automatic Bug Reporting Tool), we got
 > some bugzilla reports (which is nice, since it proves someone actually
 > tries to use libhocr). These bugs were directed at me, as a maintainer
 > of the Fedora package.
 >
 > The two latest bugs seems to require simple fixes to the UI:
 > 1. A crash due to un-caught exception when there is no scanner available:
 >     https://bugzilla.redhat.com/show_bug.cgi?id=574631
 > 2. A crash because of unidentified file format:
 >     https://bugzilla.redhat.com/show_bug.cgi?id=574630
 >
 > I tried to reproduce the second bug because the original error messages
 > looks like they are in Portugese (what are they doing with libhocr ;-)
 >
 > So I ran hocr-gtk, chose 'New' and selected a PDF file.
 > The result was a bit different -- the UI of hocr-gtk was frozen (not
 > crashed) and on the terminal was the following trace:
 >
 >  Traceback (most recent call last):
 >    File "/usr/bin/hocr-gtk", line 1139, in on_toolbutton_open_clicked
 >      self.on_imagemenuitem_new_activate(self, None)
 >    File "/usr/bin/hocr-gtk", line 761, in on_imagemenuitem_new_activate
 >      pixbuf = gtk.gdk.pixbuf_new_from_file (self.filename)
 >  glib.GError: Couldn't recognize the image file format for file
 >  '/home/oron/print.pdf'
 >
 > Aside from handling the exception, you may want (as a bonus) to filter
 > the file list in the dialog, so it only shows supported files (obviously
 > this should be done only after verifying the fix for the real bug
 > works).
 >

 * Upstream replied on the same day:
 >> i could not reproduce the first bug (with or without a scaner :-()
 >> but it is also an exception i did not catch.
 >>
 >> i will mail you when i put a version with fixes in sourceforge.

Bug #577657 is related to this bug but is not duplicate -- Crashing by pressing
scan button without a scanner.

Comment 3 Fedora Update System 2010-06-07 01:07:08 UTC
libhocr-0.10.17-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12

Comment 4 Oron Peled 2010-06-07 01:31:35 UTC
Further info in: https://bugzilla.redhat.com/show_bug.cgi?id=574259

Comment 5 Fedora Update System 2010-06-07 22:33:31 UTC
libhocr-0.10.17-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libhocr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc12

Comment 6 Fedora Update System 2010-07-06 22:32:19 UTC
libhocr-0.10.17-6.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc13

Comment 7 Fedora Update System 2010-07-07 17:37:26 UTC
libhocr-0.10.17-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libhocr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libhocr-0.10.17-6.fc13

Comment 8 Fedora Update System 2010-07-07 17:39:06 UTC
libhocr-0.10.17-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-07-08 18:11:34 UTC
libhocr-0.10.17-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.