Bug 574743 - NameError: global name 'request' is not defined
NameError: global name 'request' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:dbd5d7e27bbd79af6...
:
: 575463 576038 (view as bug list)
Depends On: 576529
Blocks: F13Beta/F13BetaBlocker
  Show dependency treegraph
 
Reported: 2010-03-18 08:20 EDT by James Laska
Modified: 2013-09-02 02:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.37-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 00:54:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (316.39 KB, text/plain)
2010-03-18 08:20 EDT, James Laska
no flags Details
anacdump.txt (using updates-574743.img) (298.74 KB, text/plain)
2010-03-22 13:36 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2010-03-18 08:20:05 EDT
The following was filed automatically by anaconda:
anaconda 13.35 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 1139, in convertToActions
    origlv.format = request.originalFormat
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 990, in run
    return self.convertToActions()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1712, in editLVMVolumeGroup
    actions = vgeditor.run()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1634, in editCB
    self.editLVMVolumeGroup(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1141, in treeActivateCB
    self.editCB()
NameError: global name 'request' is not defined
Comment 1 James Laska 2010-03-18 08:20:08 EDT
Created attachment 400999 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2010-03-18 08:26:30 EDT
= steps to reproduce =

1. Install F-12 with encrypted logical volumes for '/' and '/home'
2. Attempt install of F-13-Beta-TC0 using the following partition selections
   * Re-use existing encrypted logical volume '/home'
   * Re-use and format existing logical volume 'swap'
   * Create a new encrypted logical volume for '/'

I believe this falls under the Final release criteria [1] point #5

 "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"

However, until we can determine whether this bug affects *all* lvm installs, I'm requesting this a F13Beta blocker.

[1] https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria
Comment 3 James Laska 2010-03-18 08:58:42 EDT
I can work around this traceback with the following change, but I'm not sure if it's the *correct* change.

--- iw/lvm_dialog_gui.py	2010-03-18 08:49:27.000000000 -0400
+++ /tmp/updates/iw/lvm_dialog_gui.py	2010-03-18 08:40:20.598118902 -0400
@@ -1136,7 +1136,7 @@
                         # pretty much impossible to be sure we cancelled them
                         # in the correct order. make sure things are back to
                         # their original state.
-                        origlv.format = request.originalFormat
+                        origlv.format = self.vg.format
                         if origlv.format.type == "luks":
                             try:
                                 usedev = devicetree.getChildren(origlv)[0]
Comment 4 James Laska 2010-03-19 10:45:20 EDT
I think the patch in comment#3 is an adjustment to the commit http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=fcd6820064d924464d07d3151ff4e503b8591df2
Comment 5 James Laska 2010-03-19 12:31:21 EDT
Reviewed during 2010-03-19 F13Beta blocker review.  The group agreed this bug was a valid Beta blocker and should be considered for F13-Beta.
Comment 6 Dave Malcolm 2010-03-19 14:14:54 EDT
pylint detects this error (using grep "^E:" to show only errors; it's possible to write a config file to get it to shut up about all the non-PEP8-isms), note the error reported in line 1139 below:

[david@surprise anaconda-14.0]$ pylint iw/lvm_dialog_gui.py|grep '^E:'
No config file found, using default configuration
Exception RuntimeError: 'maximum recursion depth exceeded while calling a Python object' in <type 'exceptions.RuntimeError'> ignored
Exception RuntimeError: 'maximum recursion depth exceeded while calling a Python object' in <type 'exceptions.RuntimeError'> ignored
E:283:VolumeGroupEditor.clickCB: Instance of 'WideCheckList' has no 'get_model' member
E:351:VolumeGroupEditor.createAllowedLvmPartitionsList: Instance of 'WideCheckList' has no 'append_row' member
E:368:VolumeGroupEditor.updateAllowedLvmPartitionsList: Instance of 'WideCheckList' has no 'store' member
E:369:VolumeGroupEditor.updateAllowedLvmPartitionsList: Instance of 'WideCheckList' has no 'store' member
Exception RuntimeError: 'maximum recursion depth exceeded while calling a Python object' in <type 'exceptions.RuntimeError'> ignored
E:500:VolumeGroupEditor.editLogicalVolume.<lambda>: Using variable 'maintable' before assignment
E:566:VolumeGroupEditor.editLogicalVolume: Class 'vbox' has no 'pack_start' member
E:878:VolumeGroupEditor.getSelectedPhysicalVolumes: Instance of 'WideCheckList' has no 'get_model' member
E:1139:VolumeGroupEditor.convertToActions: Undefined variable 'request'
E:1458:VolumeGroupEditor.__init__: Class 'vbox' has no 'pack_start' member


(this is with cvs-dist/anaconda/devel: anaconda-14.0.tar.bz2)
Comment 7 James Laska 2010-03-22 08:19:34 EDT
*** Bug 575463 has been marked as a duplicate of this bug. ***
Comment 8 James Laska 2010-03-22 11:52:00 EDT
Updated image available for testing - http://dlehman.fedorapeople.org/updates-574743.img
Comment 9 James Laska 2010-03-22 13:34:16 EDT
(In reply to comment #8)
> Updated image available for testing -
> http://dlehman.fedorapeople.org/updates-574743.img    

Using the updates.img noted earlier, I do not get a traceback, but the installer doesn't seem to let me add a mount point to an existing LVM logical volume.

See before (http://jlaska.fedorapeople.org/Screenshot-1.png) and after (http://jlaska.fedorapeople.org/Screenshot-2.png)
Comment 10 James Laska 2010-03-22 13:36:14 EDT
Created attachment 401829 [details]
anacdump.txt (using updates-574743.img)

(In reply to comment #9)
> (In reply to comment #8)
> > Updated image available for testing -
> > http://dlehman.fedorapeople.org/updates-574743.img    
> 
> Using the updates.img noted earlier, I do not get a traceback, but the
> installer doesn't seem to let me add a mount point to an existing LVM logical
> volume.
> 
> See before (http://jlaska.fedorapeople.org/Screenshot-1.png) and after
> (http://jlaska.fedorapeople.org/Screenshot-2.png)    

Additionally, I get the attached traceback while attempting to create a new logical volume using the provided updates.img
Comment 11 James Laska 2010-03-23 07:55:15 EDT
*** Bug 576038 has been marked as a duplicate of this bug. ***
Comment 12 James Laska 2010-03-24 15:45:43 EDT
No longer experiencing this failure when using the revised updates.img (http://dlehman.fedorapeople.org/updates-576529.img)
Comment 13 Fedora Update System 2010-03-26 23:26:28 EDT
anaconda-13.37-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.37-1.fc13
Comment 14 Fedora Update System 2010-03-27 00:53:12 EDT
anaconda-13.37-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.