Bug 576795 - KSH default path missing 'cwd' /bin:/usr/bin missing colon at the end
KSH default path missing 'cwd' /bin:/usr/bin missing colon at the end
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
5.5
All Linux
medium Severity low
: ---
: ---
Assigned To: Ivana Varekova
: ManPageChange, Reopened
Depends On:
Blocks: 590060 699641 702008
  Show dependency treegraph
 
Reported: 2010-03-25 04:49 EDT by Tomas Smetana
Modified: 2011-07-21 03:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The sh(1) man page now contains fixed information about the default value of the PATH variable.
Story Points: ---
Clone Of:
: 699641 (view as bug list)
Environment:
Last Closed: 2011-07-21 03:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (674 bytes, patch)
2011-04-27 03:10 EDT, Michal Hlavinka
no flags Details | Diff

  None (edit)
Description Tomas Smetana 2010-03-25 04:49:17 EDT
per ksh93 man page: "The default path is /bin:/usr/bin: (specifying /bin, /usr/bin, and the current directory in that order)."

This appears to only include /bin:/usr/bin
This breaks compatability with Solaris/AIX and related scripts expecting consistent ksh behaviour across platforms when there is no environment variable 
set (for example, non interactive login sessions via rsh).

How to reproduce:

/bin/ksh
cp /bin/ls /tmp/testls
cd /tmp
unset PATH
testls
-ksh: testls: not found [No such file or directory]
Comment 2 Michal Hlavinka 2010-03-25 05:24:39 EDT
Severity: Low =	Problem is minor loss of function, or other problem where *easy workaround is present*.

you can use following workaround

export PATH=$PATH:

Also do not expect any change at all, because upstream would definitely refuse this AND it would break compatibility a lot (with other shells) AND it would be insecure AND it would break users expectations.

The only thing I can do is to remove/fix that confusing sentence in man page.

This can be reproduced with latest ksh version released by upstream, which is expected because from functionality POV this is notabug.
Comment 10 Tomas Smetana 2010-05-04 03:24:13 EDT
I think this bugzilla should be closed as WONTFIX now.

Thank you.
Comment 11 Tomas Smetana 2010-05-04 03:42:41 EDT
Eh. Forget the previous comment please.  There is still the manual page which should be fixed.

Sorry....
Comment 13 RHEL Product and Program Management 2010-08-09 14:41:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 Michal Hlavinka 2010-10-06 07:32:37 EDT
why was this closed as wontfix?
Comment 17 RHEL Product and Program Management 2011-01-11 16:10:33 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 18 RHEL Product and Program Management 2011-01-11 17:43:01 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 21 Michal Hlavinka 2011-04-27 03:10:32 EDT
Created attachment 495119 [details]
patch
Comment 28 Miroslav Svoboda 2011-07-15 12:21:19 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The sh(1) man page now contains fixed information about the default value of the PATH variable.
Comment 29 errata-xmlrpc 2011-07-21 03:36:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-1009.html

Note You need to log in before you can comment on or make changes to this bug.