Bug 577851 - Unable to boot from PXE, Cannot boot from non-existent NIC
Unable to boot from PXE, Cannot boot from non-existent NIC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 572495 580411 583714 583907 (view as bug list)
Depends On:
Blocks: 579714
  Show dependency treegraph
 
Reported: 2010-03-29 09:13 EDT by Jan ONDREJ
Modified: 2013-01-09 06:32 EST (History)
21 users (show)

See Also:
Fixed In Version: qemu-0.12.3-8.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 19:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My guest configuration. (1.43 KB, text/plain)
2010-03-29 09:13 EDT, Jan ONDREJ
no flags Details

  None (edit)
Description Jan ONDREJ 2010-03-29 09:13:57 EDT
Created attachment 403288 [details]
My guest configuration.

Description of problem:
When trying to boot from network (PXE) using current virt-preview repository on Fedora 12 it says, that I am trying to boot from non-existent NIC.
After downgrade it works again, but only after bochs-bios was downgraded.

Version-Release number of selected component (if applicable):
qemu-common-0.12.3-6.fc12.i686
qemu-system-cris-0.12.3-6.fc12.i686
qemu-system-ppc-0.12.3-6.fc12.i686
python-virtinst-0.500.2-1.fc12.noarch
bochs-bios-2.4.2-1.fc12.noarch
virt-top-1.0.4-1.fc12.1.i686
qemu-user-0.12.3-6.fc12.i686
python-virtualenv-1.3.3-2.fc12.noarch
virt-mem-0.3.1-9.fc12.i686
virt-manager-0.8.3-2.fc12.noarch
gpxe-roms-1.0.0-1.fc12.noarch
libvirt-python-0.7.7-2.fc12.i686
gpxe-roms-qemu-1.0.0-1.fc12.noarch
qemu-kvm-0.12.3-6.fc12.i686
libvirt-client-0.7.7-2.fc12.i686
fence-virt-0.2.1-2.fc12.i686
virtuoso-opensource-6.1.0-2.fc12.i686
qemu-img-0.12.3-6.fc12.i686
qemu-system-arm-0.12.3-6.fc12.i686
qemu-system-x86-0.12.3-6.fc12.i686
virt-viewer-0.2.1-1.fc12.i686
libvirt-0.7.7-2.fc12.i686

How reproducible:
always

Steps to Reproduce:
1. configure PXE boot from network
2. virsh start ...
  
Actual results:
This message is displayed in virt-manager or after virsh start:
  Cannot boot from non-existent NIC

Expected results:
system boot

Additional info:
With current bochs-bios and all other components older is starts, but no NIC found in GPXE BIOS.
Comment 1 Paul Jenner 2010-04-09 16:32:39 EDT
Looks like the same issue that an upstream patch has been posted for here:

http://lists.gnu.org/archive/html/qemu-devel/2010-04/msg00378.html
Comment 2 Eduardo Habkost 2010-04-20 08:56:16 EDT
*** Bug 583907 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2010-04-20 12:16:57 EDT
*** Bug 583714 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-04-22 20:02:02 EDT
qemu-0.12.3-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qemu-0.12.3-8.fc13
Comment 5 Fedora Update System 2010-04-23 02:04:50 EDT
qemu-0.12.3-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qemu-0.12.3-8.fc13
Comment 6 Patrick Boutilier 2010-04-28 20:02:44 EDT
Starts booting from PXE but DHCP doesn't work. I don't see any bootps traffic on br0. If I interrupt PXE boot with Ctrl-B, "dhcp net0" from gPXE command line works.
Comment 7 Fedora Update System 2010-05-04 19:51:55 EDT
qemu-0.12.3-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Cole Robinson 2010-05-18 15:59:54 EDT
*** Bug 572495 has been marked as a duplicate of this bug. ***
Comment 9 Cole Robinson 2010-05-18 16:01:04 EDT
*** Bug 580411 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.