Bug 578029 - lang-specific overrides rule doesn't work as expected
lang-specific overrides rule doesn't work as expected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-assamese-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On: 578015
Blocks: F13Target 586852
  Show dependency treegraph
 
Reported: 2010-03-29 23:41 EDT by Akira TAGOH
Modified: 2010-04-28 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: lohit-assamese-fonts-2.4.3-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586852 (view as bug list)
Environment:
Last Closed: 2010-04-25 09:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2010-03-29 23:41:13 EDT
Description of problem:
All of detailed information is available on my post at the fonts list:
http://lists.fedoraproject.org/pipermail/fonts/2010-March/001117.html

binding="same" in the fontconfig config file prevents to apply the rule for the
specific
language only properly. As a result, fonts is used for non-targetted languages
and it may gives different look and feel in some cases.

I'd propose to get rid of binding="same" from:
 66-lohit-assamese.conf
Comment 1 Fedora Update System 2010-04-15 06:40:10 EDT
lohit-assamese-fonts-2.4.3-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lohit-assamese-fonts-2.4.3-4.fc13
Comment 2 Pravin Satpute 2010-04-16 01:55:39 EDT
lohit-assamese-fonts-2.4.3-4.fc14
Comment 3 Fedora Update System 2010-04-16 19:38:45 EDT
lohit-assamese-fonts-2.4.3-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-assamese-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lohit-assamese-fonts-2.4.3-4.fc13
Comment 4 Akira TAGOH 2010-04-21 21:33:47 EDT
Testing result:
# rpm -q lohit-assamese-fonts
lohit-assamese-fonts-2.4.3-4.fc13.noarch
# fc-match monospace:lang=en
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=en-us
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
# fc-match monospace:lang=as
Lohit-Bengali.ttf: "Lohit Bengali" "Regular"
# fc-match monospace:lang=as-in
Lohit-Bengali.ttf: "Lohit Bengali" "Regular"
# fc-match serif:lang=en
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=en-us
DejaVuSerif.ttf: "DejaVu Serif" "Book"
# fc-match serif:lang=as
Lohit-Bengali.ttf: "Lohit Bengali" "Regular"
# fc-match serif:lang=as-in
Lohit-Bengali.ttf: "Lohit Bengali" "Regular"

No monospaced fonts nor serif fonts are assigned in lohit-assemese-fonts (and no packages available in Fedora? otherwise we are missing it in comps). so the above result should be ok so far. please have the certain rules if you want to use the different fonts for monospace and serif for Assamese.

# fc-match sans:lang=en
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=en-us
DejaVuSans.ttf: "DejaVu Sans" "Book"
# fc-match sans:lang=as
Lohit-Bengali.ttf: "Lohit Bengali" "Regular"
# fc-match sans:lang=as-in
Lohit-Bengali.ttf: "Lohit Bengali" "Regular"

This result is because of 66-lohit-assamese.conf is lower priority than 65-nolatin.conf. the result itself is ok for this bug. but to correct the wrong query result above, rename 66-lohit-assamese.conf to 65-0- or something like that.

# for i in $(ls /usr/share/locale|grep -v -E '^as$'); do fc-match sans:lang=$i|grep "Lohit Assamese"; [ $? = 0 ] && echo $i; done
#

FWIW after renaming 66-lohit-assamese.conf (and 66-lohit-bengali.conf as well) to 65-0-.

Lohit-Assamese.ttf: "Lohit Assamese" "Regular"
bn

this may be an orth file issue. fontconfig is figuring out "bn" contains "as". for workaround, that would be good to get rid of compare="contains" and use as-in instead of as. see my recent post on the fonts list for more details of this issue.

Anyway, all the above issues are different issues for this. so I'd waive them so far.
Comment 5 Fedora Update System 2010-04-25 09:57:58 EDT
lohit-assamese-fonts-2.4.3-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.