This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 582583 - The next button cannot be clicked in the install screen examine and change in partitionning
The next button cannot be clicked in the install screen examine and change in...
Status: CLOSED ERRATA
Product: Fedora Localization
Classification: Fedora
Component: French [fr] (Show other bugs)
unspecified
All Linux
low Severity high
: ---
: ---
Assigned To: Martin-Gomez Pablo
Kendall Fay
: CommonBugs
: 586672 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker 589516 589519 589520 589556
  Show dependency treegraph
 
Reported: 2010-04-15 07:21 EDT by alex.monnier.pub
Modified: 2010-05-10 16:28 EDT (History)
13 users (show)

See Also:
Fixed In Version: 13.39-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 589516 589519 589520 589556 (view as bug list)
Environment:
Last Closed: 2010-05-10 09:04:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
French translation too long (118.12 KB, image/png)
2010-04-21 17:16 EDT, Brian Lane
no flags Details

  None (edit)
Description alex.monnier.pub 2010-04-15 07:21:59 EDT
Description of problem:

The next button cannot be clicked in the install screen "examine and change in partitionning".

It means a checkbox is always catching the click and that the next button is like behind the following option checkbox :"Examiner et modifier la structure de partitionnement".

This has to be a internationalization problem probably only in french.

Version-Release number of selected component (if applicable):
anaconda 13.37.2 of Fedora 13 beta

How reproducible:
Try a standard new installation in french.

Actual results:
The Next "suivant" button is not clickable. The checkbox is catching the event.

Expected results:
Next would have to be clickable.

Additional info:
My workaround: use alt-u to go next.
Comment 1 Electron 2010-04-16 16:39:34 EDT
Same for me.
F13 Beta, in french.
Another workaround: click on the top or bottom edge of the button ;-)
Comment 2 Brian Lane 2010-04-21 17:16:48 EDT
Created attachment 408186 [details]
French translation too long
Comment 3 Brian Lane 2010-04-21 17:17:49 EDT
Some of the translations used in the autopart dialog are too long. French and German at the least. When they are too long they block clicking on the Prev / Next buttons.

See the attached screenshot. The bottom checkbox should be above the buttons, not even with them.
Comment 4 Thomas Canniot 2010-04-22 17:50:24 EDT
However the buttons remain 'clickable' with the keyboard. (Tab & space)
Comment 5 Martin-Gomez Pablo 2010-04-22 18:17:28 EDT
As this bug is quite critical for french (and german) users, I put it as an F13Blocker in order to be able to demand a rebuild of the anaconda package when it will be fixed. We will have commited the fixed po for the week end I think.
Comment 6 Adam Williamson 2010-04-23 13:13:34 EDT
Discussed at today's blocker bug review meeting. We agree this is a blocker. Also should be commonbugs noted for F13Beta. It would be nice if anaconda somehow avoided this happening if the translations are too long, anaconda team is aware of the issue and has thoughts in that direction. Of course, the sooner you can get the updated translations in, the better :) Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Martin-Gomez Pablo 2010-04-24 13:12:16 EDT
I've just check the .po file of other languages, and could be possible that Portuguese, Dutch or Polish face to the same problem (someone to comfirm?). The easiest work around is to remove 2 '\n' but it's not ideal...
Comment 8 Martin-Gomez Pablo 2010-04-25 13:11:46 EDT
It should be fixed for french and for german.
Comment 9 Martin-Gomez Pablo 2010-04-28 04:43:36 EDT
*** Bug 586672 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2010-05-03 16:32:08 EDT
It looks like the changes got into the F13 anaconda branch on April 25th. 13.39 was built April 29th, so it should have the fixes. Setting as fixed in that version, I will test and confirm.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2010-05-03 19:45:47 EDT
TC1 results: French = OK, German = OK, Dutch = slightly affected (about a 5-8 pixel overlap, you can't click the tops of the buttons, but most of the button areas are OK), Portuguese = similar to Dutch, slightly larger overlap (10 px), Polish = OK.

So we're not horrible here, but there are two languages which could stand to be fixed (removing a single newline would probably do the job for both).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Rui Gouveia 2010-05-04 19:40:18 EDT
Portuguese PO of anaconda corrected in f13 branch as specified here.

Thanks for the warning.
Comment 13 Adam Williamson 2010-05-04 20:35:02 EDT
anaconda team, still time to pull in the updated translation?
Comment 14 Peter Bojtos 2010-05-06 03:10:07 EDT
Sorry for the late, but the hungarian translate was also affected with this problem.
I uploaded the fixed file to transifex. Is it still possible to apply the changes?

thanks
Comment 15 Adam Williamson 2010-05-06 09:49:22 EDT
we still need an anaconda 13.41 build so I believe it ought to be possible - Dave, Chris?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2010-05-06 09:51:10 EDT
looking at anaconda git - it looks like the change was committed to the f13 branch and 13.41 hasn't been tagged  yet, so we should be good, it should get in the 13.41 build.
Comment 17 Chris Lumens 2010-05-06 10:08:04 EDT
Comments #15 and 16 are correct.  Since we're planning on doing a 13.41 build, we'll pick up all translation changes since the last build.
Comment 18 He Rui 2010-05-10 04:03:56 EDT
Confirmed fix in anaconda 13.41 when installing in French.
Comment 19 Adam Williamson 2010-05-10 09:04:43 EDT
we pulled in 13.41 with all translations available at that point, so I think let's just close this now, and say all translators please be aware of this problem window and try to keep the translations short enough for F14 :) thanks!
Comment 20 Thomas Canniot 2010-05-10 09:34:56 EDT
(In reply to comment #19)
> we pulled in 13.41 with all translations available at that point, so I think
> let's just close this now, and say all translators please be aware of this
> problem window and try to keep the translations short enough for F14 :) thanks!    

Or maybe the DevTeam could try to create less verbose screen ;)

My 2 cents
Comment 21 Piotr Drąg 2010-05-10 16:14:04 EDT
(In reply to comment #20)
> Or maybe the DevTeam could try to create less verbose screen ;)
> 
> My 2 cents    

I agree. Let's fix the cause, not the effects.
Comment 22 Chris Lumens 2010-05-10 16:22:38 EDT
> Or maybe the DevTeam could try to create less verbose screen ;)
> 
> My 2 cents    

This screen is verbose on purpose - it's trying to explain the subtle differences in five different broad partitioning layouts.  This is a screen we've received lots of bug reports on in the past talking about how it needs to make everything more explicit.
Comment 23 Piotr Drąg 2010-05-10 16:28:41 EDT
I understand. I don't want to truncate the text on the screen. I was thinking more of making impossible for GTK to overlap the buttons. Then even if it looks ugly, it would be still usable.

Note You need to log in before you can comment on or make changes to this bug.