Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 589520 - The next button cannot be clicked in the install screen examine and change in partitionning
The next button cannot be clicked in the install screen examine and change in...
Status: CLOSED DUPLICATE of bug 589516
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: CommonBugs
Depends On: 582583
Blocks: 576455
  Show dependency treegraph
 
Reported: 2010-05-06 07:13 EDT by A S Alam
Modified: 2013-07-02 21:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 582583
Environment:
Last Closed: 2010-05-06 08:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2010-05-06 07:13:33 EDT
Effecting RHEL6 also,
Tested with Punjabi (pa_IN), Malayalam (ml_IN). with following detail:
-------
RHEL6.0-Snapshot-2
anaconda-13.21.32-1.el6.x86_64.rpm
installation with: Virtual Machine
------

+++ This bug was initially created as a clone of Bug #582583 +++

Description of problem:

The next button cannot be clicked in the install screen "examine and change in partitionning".

It means a checkbox is always catching the click and that the next button is like behind the following option checkbox :"Examiner et modifier la structure de partitionnement".

This has to be a internationalization problem probably only in french.

Version-Release number of selected component (if applicable):
anaconda 13.37.2 of Fedora 13 beta

How reproducible:
Try a standard new installation in french.

Actual results:
The Next "suivant" button is not clickable. The checkbox is catching the event.

Expected results:
Next would have to be clickable.

Additional info:
My workaround: use alt-u to go next.

--- Additional comment from electron@myself.com on 2010-04-17 02:09:34 IST ---

Same for me.
F13 Beta, in french.
Another workaround: click on the top or bottom edge of the button ;-)

--- Additional comment from bcl@redhat.com on 2010-04-22 02:46:48 IST ---

Created an attachment (id=408186)
French translation too long

--- Additional comment from bcl@redhat.com on 2010-04-22 02:47:49 IST ---

Some of the translations used in the autopart dialog are too long. French and German at the least. When they are too long they block clicking on the Prev / Next buttons.

See the attached screenshot. The bottom checkbox should be above the buttons, not even with them.

--- Additional comment from thomas.canniot@mrtomlinux.org on 2010-04-23 03:20:24 IST ---

However the buttons remain 'clickable' with the keyboard. (Tab & space)

--- Additional comment from pablo.martin-gomez@laposte.net on 2010-04-23 03:47:28 IST ---

As this bug is quite critical for french (and german) users, I put it as an F13Blocker in order to be able to demand a rebuild of the anaconda package when it will be fixed. We will have commited the fixed po for the week end I think.

--- Additional comment from awilliam@redhat.com on 2010-04-23 22:43:34 IST ---

Discussed at today's blocker bug review meeting. We agree this is a blocker. Also should be commonbugs noted for F13Beta. It would be nice if anaconda somehow avoided this happening if the translations are too long, anaconda team is aware of the issue and has thoughts in that direction. Of course, the sooner you can get the updated translations in, the better :) Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from pablo.martin-gomez@laposte.net on 2010-04-24 22:42:16 IST ---

I've just check the .po file of other languages, and could be possible that Portuguese, Dutch or Polish face to the same problem (someone to comfirm?). The easiest work around is to remove 2 '\n' but it's not ideal...

--- Additional comment from pablo.martin-gomez@laposte.net on 2010-04-25 22:41:46 IST ---

It should be fixed for french and for german.

--- Additional comment from pablo.martin-gomez@laposte.net on 2010-04-28 14:13:36 IST ---

*** Bug 586672 has been marked as a duplicate of this bug. ***

--- Additional comment from awilliam@redhat.com on 2010-05-04 02:02:08 IST ---

It looks like the changes got into the F13 anaconda branch on April 25th. 13.39 was built April 29th, so it should have the fixes. Setting as fixed in that version, I will test and confirm.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from awilliam@redhat.com on 2010-05-04 05:15:47 IST ---

TC1 results: French = OK, German = OK, Dutch = slightly affected (about a 5-8 pixel overlap, you can't click the tops of the buttons, but most of the button areas are OK), Portuguese = similar to Dutch, slightly larger overlap (10 px), Polish = OK.

So we're not horrible here, but there are two languages which could stand to be fixed (removing a single newline would probably do the job for both).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

--- Additional comment from rui.gouveia@gmail.com on 2010-05-05 05:10:18 IST ---

Portuguese PO of anaconda corrected in f13 branch as specified here.

Thanks for the warning.

--- Additional comment from awilliam@redhat.com on 2010-05-05 06:05:02 IST ---

anaconda team, still time to pull in the updated translation?

--- Additional comment from ptr@ulx.hu on 2010-05-06 12:40:07 IST ---

Sorry for the late, but the hungarian translate was also affected with this problem.
I uploaded the fixed file to transifex. Is it still possible to apply the changes?

thanks
Comment 2 Chris Lumens 2010-05-06 08:43:06 EDT

*** This bug has been marked as a duplicate of bug 589516 ***

Note You need to log in before you can comment on or make changes to this bug.