Bug 584512 - python-twisted-core-8.2.0-6 breaks jabbim
python-twisted-core-8.2.0-6 breaks jabbim
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-twisted-core (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
:
: 587069 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 14:46 EDT by Michal Schmidt
Modified: 2010-09-29 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: 10.1.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-29 14:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2010-04-21 14:46:29 EDT
Description of problem:
I cannot connect to my Jabber account using Jabbim after updating to python-twisted-core-8.2.0-6.

Version-Release number of selected component (if applicable):
python-twisted-core-8.2.0-6.fc13.x86_64
jabbim-0.5-0.13.svn20100201.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1. Run jabbim
2. Try to connect to an account
  
Actual results:
Jabbim stays on the "connecting" screen forever. In jabbim.log there is a traceback from Twisted.

Expected results:
jabbim should connect properly

Additional info:
This is the traceback:
        Traceback (most recent call last):
          File "/builddir/build/BUILD/Python-2.6.4/Modules/pyexpat.c", line 656, in EndElement
            
          File "/usr/lib64/python2.6/site-packages/twisted/words/xish/domish.py", line 797, in _onEndElement
            self.ElementEvent(self.currElem)
          File "/usr/lib64/python2.6/site-packages/twisted/words/xish/xmlstream.py", line 107, in onElement
            self.dispatch(element)
          File "/usr/lib64/python2.6/site-packages/twisted/words/xish/utility.py", line 317, in dispatch
            callbacklist.callback(obj)
        --- <exception caught here> ---
          File "/usr/lib64/python2.6/site-packages/twisted/words/xish/utility.py", line 107, in callback
            methodwrapper(*args, **kwargs)
          File "/usr/lib64/python2.6/site-packages/twisted/words/xish/utility.py", line 27, in __call__
            self.method(*nargs, **nkwargs)
          File "/usr/lib64/python2.6/site-packages/twisted/words/protocols/jabber/xmlstream.py", line 394, in onProceed
            self.xmlstream.transport.startTLS(ctx)
          File "/usr/lib64/python2.6/site-packages/twisted/internet/tcp.py", line 562, in startTLS
            if Connection.startTLS(self, ctx, client):
          File "/usr/lib64/python2.6/site-packages/twisted/internet/tcp.py", line 405, in startTLS
            self.socket = SSL.Connection(ctx.getContext(), self.socket)
          File "/usr/lib64/python2.6/site-packages/twisted/internet/_sslverify.py", line 697, in getContext
            self._context = self._makeContext()
          File "/usr/lib64/python2.6/site-packages/twisted/internet/_sslverify.py", line 739, in _makeContext
            sessionName = md5("%s-%d" % (reflect.qual(self.__class__), _sessionCounter())).hexdigest()
        exceptions.TypeError: 'module' object is not callable


I am starting to think that the effort to make Twisted 8.2 free of deprecation warnings is misguided. Instead the goal should be to get 10.0 into devel/. And bringing any changes to Twisted in F-12 is definitely more trouble than it's worth.
Comment 1 Julian Sikorski 2010-07-14 17:14:56 EDT
*** Bug 587069 has been marked as a duplicate of this bug. ***
Comment 2 Julian Sikorski 2010-07-14 17:16:24 EDT
10.0.0 and 10.1.0 fix this problem for telepathy-sunshine at least. Bug 572372 contains a link to updated packages, please test.
Comment 3 Julian Sikorski 2010-09-23 16:36:37 EDT
Hi, I am the new twisted stack co-maintainer. A rebase to 10.1.0 was just submitted as an update to F-14. If that's not a problem, could you please test whether the bug is still present there? Thanks.
Comment 4 Michal Schmidt 2010-09-24 03:47:49 EDT
I tested Jabbim with your Twisted 10.1 packages back in July and reported success in https://bugzilla.redhat.com/show_bug.cgi?id=572372#c6
I will retest soon with the F-14 packages you have submitted to updates-testing.
Thank you for taking care of Twisted.
Comment 5 Julian Sikorski 2010-09-29 14:54:35 EDT
Closing as per the update comment.

Note You need to log in before you can comment on or make changes to this bug.