Bug 58650 - listings crashes with babel
Summary: listings crashes with babel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 68684 69987 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-22 10:37 UTC by Horst H. von Brand
Modified: 2013-07-02 22:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 21:44:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Horst H. von Brand 2002-01-22 10:37:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
When using the listings package in LaTeX article with babel, it crashes.

Version-Release number of selected component (if applicable): 1.0.7-38.2


How reproducible:
Always

Steps to Reproduce:
1. Set up tetex to allow spanish (english gives other errors...)
2. Run the following through latex(1)

\documentclass[spanish]{article}
\usepackage{babel}
\usepackage{listings}
\begin{document}
\end{document}

Actual Results:  ! LaTeX error: No counter 'chapter' defined

Additional info:

The current listings package on CTAN fixes this, and also fixes a number of
other annoying bugs. Beware, there are some incompatibilities, like the way of
labeling floating listings.

Comment 1 Tim Waugh 2002-07-12 15:40:53 UTC
*** Bug 68684 has been marked as a duplicate of this bug. ***

Comment 2 Tim Waugh 2002-07-28 17:25:53 UTC
*** Bug 69987 has been marked as a duplicate of this bug. ***

Comment 3 Jindrich Novy 2004-11-04 21:44:59 UTC
Horst, this is fixed in tetex-2.0.2 present in recent releases.

thanks,
Jindrich


Note You need to log in before you can comment on or make changes to this bug.