Bug 5875 - Install program (python/anaconda) from HD crashes when scanning packages
Install program (python/anaconda) from HD crashes when scanning packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-12 05:05 EDT by diego.santacruz
Modified: 2015-01-07 18:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-21 13:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description diego.santacruz 1999-10-12 05:05:31 EDT
I downloaded the ISO image and burned a CD-ROM, after giving
up with CD-ROM install (see bug #5873) I copied the files to
a HD (VFAT, FAT16 partition) and installed from there.
Everything went fine until it starts scanning the packages
on the HD. The python/anaconda install program crashes with
the following message:

File "/usr/bin/anaconda.real",
  line 225, in ?
  intf.run(todo, test = test)
File
  "/tmp/lib/python1.5/site-packages/te
  xt.py", line 1000, in run
  rc = apply (step[1](), step[2])
File
  "/mnt/redhat/comps/install/6.1/i386/
  misc/src/trees/hdimage/user/lib/pytho
  n1.5/site-packages/textw/packages.py
  ", line 10, in __call__
File
 "/tmp/lib/python1.5/site-packages/to
  do.py", line 90, in getHeaderList
  self.hdList =
  self.method.readHeaders()
File
  "/tmp/lib/python1.5/site-packages/ha
  rddrive.py", line 46, in readHeaders
  return HeaderList(hl)
File
  "/tmp/lib/python1.5/site-packages/co
  mps.py", line 50, in __init__
  name = h[rpm.RPMTAG_NAME]
  TypeError: unscriptable object

The I have the option to debug or "OK", Hitting "OK" halts
(i.e. shutdown procedure)  the machine.

Probably the same as bug #5551.
Comment 1 jun.yang 1999-10-13 20:02:59 EDT
I have encountered exactly the same problem.  In the Python debugger,
I printed out h=NONE; rpm.RPMTAG_NAME=1000; h[0][1000]=netscape-comm;
h[1][1000]=netscape-communicator; etc.  It failed on a FAT FS on a
SCSI drive and a ext2fs on an EIDE driver.  Hope this helps.
Comment 2 Anonymous 1999-10-14 00:59:59 EDT
Ive Been getting the exact same error on a new install.  Ive got the
entire 6.1 dist on a ext2 hard disk.  Ive tried many different
install options and hd locations.  Currently, the drive is /dev/hdc1
I think this is the same as bug number 5749
Comment 3 Craig Kelley 1999-10-15 21:49:59 EDT
I have noticed the same behavior:

Boot with bootnet, and when you get to the partitioning type, select
fdisk and then continue (without editing any drives).  The error
messages will be there.


------- Additional Comments From   10/20/99 19:59 -------
I have the exact same problem when installing from a CD-ROM.  The ISO
was downloaded from ftp.redhat.com and it was burned.

When upgrading from 6.0 to 6.1 the installer crashes and creates the
same messsage as seen above.

Celerom 366, 64mb ram, 1G HD, Abit BM6 MB,
I doubt it's a system problem as i was running 6.0 with a uptime of
over 30 days before attempting this upgrade.

I do not have any wierd partitions on my drive either.  NO Fat16,
Fat32, NTFS or anything else like that.  Just a Swap partition and my
linux partition.

All 3 install options do not work, whether text, graphical or expert,
Comment 4 Jay Turner 1999-10-21 13:38:59 EDT
Please refer to bug #5555, and #5768, as there are problems which we
know are out there.  If neither of these bugs covers the problem which
you are seeing, then please reopen this bug with more details about
the specific failure that you are seeing as well as fstab and fdisk
dumps.

Note You need to log in before you can comment on or make changes to this bug.