Bug 587863 - Cannot deactivate mouse clicks with touchpad
Cannot deactivate mouse clicks with touchpad
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: control-center (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Control Center Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 03:29 EDT by Mathieu Baudier
Modified: 2010-11-15 08:53 EST (History)
6 users (show)

See Also:
Fixed In Version: control-center-2.28.1-18.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 08:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Baudier 2010-05-01 03:29:34 EDT
Description of problem:

In GNOME > System > Preferences > Mouse > Touchpad it is not possible to uncheck 'Enable mouse clicks with touchpad'

This is a problem because since it is a MacBook Pro touchpad (with one button) one makes massive use of the multi-finger touch (two fingers for right-click, three finger for middle-click) which often causes a single-click to be performed.

A workaround is to install gconf-editor and go into:
/desktop/gnome/peripherals/touchpad and uncheck tap_to_click
(but it will be checked again if one open the GNOME > System > Preferences > Mouse > Touchpad dialog again)

Version-Release number of selected component (if applicable):

RHEL 6 Beta 20100414

How reproducible:

Always

Steps to Reproduce:
1. Go to GNOME > System > Preferences > Mouse > Touchpad
2. Try to uncheck  'Enable mouse clicks with touchpad'
  
Actual results:

The 'Enable mouse clicks with touchpad' checkbox is not enabled

Expected results:

This behavior should be configurable.

Additional info:
Comment 2 RHEL Product and Program Management 2010-05-01 05:14:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Bastien Nocera 2010-05-14 06:17:22 EDT
Peter, didn't we already fix something similar?
Comment 4 Peter Hutterer 2010-05-16 18:17:30 EDT
Yes, GNOME bug 606793. It's a rather trivial fix too.

https://bugzilla.gnome.org/show_bug.cgi?id=606793
Comment 5 Tomas Pelka 2010-05-27 10:26:33 EDT
Reproducer in description, giving qa_ack.
Comment 6 Bastien Nocera 2010-06-01 13:32:48 EDT
Fixed in control-center-2.28.1-18.el6
Comment 7 Tomas Pelka 2010-06-22 09:26:36 EDT
Mathieu,
please could you confirm that this issue is fixed?

No apple hardware available.

Thanks,
Tom
Comment 8 Mathieu Baudier 2010-06-22 09:36:43 EDT
I'd test with pleasure, but where are the update supposed to come from?

Last time I tried yum update on my RHEL 6 Beta, nothing was available.
Or is a RHEL 6 Beta 2 available? (I would probably have been aware of this)

Please note that I am not (yet) a Red Hat customer.
Comment 9 Tomas Pelka 2010-06-22 11:19:37 EDT
(In reply to comment #8)
> I'd test with pleasure, but where are the update supposed to come from?
> 
> Last time I tried yum update on my RHEL 6 Beta, nothing was available.
> Or is a RHEL 6 Beta 2 available? (I would probably have been aware of this)
> 
> Please note that I am not (yet) a Red Hat customer.    

Please be patient, update should be available soon.

Thanks
Cheers,
Tom
Comment 11 Mathieu Baudier 2010-07-02 05:25:03 EDT
I updated my installation from the RHEL 6 Beta 2 Workstation CDROM (fresh install now crashes, I'll book another bug).

The checkbox is still greyed, so I'm afraid that this is not fixed.
Comment 12 Vladimir Benes 2010-09-16 11:05:14 EDT
Mathieu,
any update here? have you installed beta 2? if not could you try create a new user and test it there?

thanks,
Vladimir
Comment 13 Mathieu Baudier 2010-09-16 11:29:34 EDT
I just created a new user but it also has the same problem (checkbox "Enable mouse clicks with touchpad" checked and greyed).

As I said in comment #11, I could not install RHEL 6.0 Beta 2 from scratch because of bug 610510 (marked as duplicate of bug 597925) and I updated my Beta 1 installation using the CDROM as a yum repo.

Unfortunately I cannot afford to wipe the laptop completely since I have quite a few operating systems on it, and I use it on customer sites.
The installation issue was apparently fixed in RHEL6.0-20100701.0 (see Comment 11 of bug 597925), so if I can get access to a later version I'm happy to try a fresh install.

As I put previously, the issue is much more serious that it sounds because it makes multi-touch more or less unusable (this is especially bad on one-button Apple hardware, but I guess these are not really targeted by RHEL...)

Don't hesitate to tell me if I can try something more: the lack of support for this particular touchpad in RHEL/CentOS 5 (I think support for it was included around 2.6.27) is really a pain for me (and forces me to use Ubuntu in parallel).
So, I'm really motivated to have RHEL 6 working properly on this laptop.
Comment 14 Vladimir Benes 2010-09-16 11:53:42 EDT
Sorry, I am afraid we cannot ship out anything newer now. I am looking for a MacBook Pro here to test in-house. Will keep you updated.
Comment 15 Mathieu Baudier 2010-09-16 12:09:15 EDT
Ok, don't hesitate to tell me if I can do anything else without a fresh install (this RHEL 6 Beta install is not used for anything else than testing/reporting)

Probably an OT question but: can a MacBook Pro hardware be officially supported by Red Hat? (I'm considering buying a RHEL Desktop when 6.0 is out...)
Comment 16 Mathieu Baudier 2010-09-17 04:03:09 EDT
I have a good and a bad news:
- the good is that after cleaning up a bit my LVM I could install a fresh RHEL 6 Beta 2
- the bad is that the problem is still there
Comment 17 Tomas Pelka 2010-09-17 04:31:00 EDT
Hey Mathieu,
thank you for your effort, unfortunately there is chance that Vlad will be able to find some MacBook here. Please stay tuned.

Thanks
Tom
Comment 18 releng-rhel@redhat.com 2010-11-15 08:53:00 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.