Bug 588374 - gfs2_convert manpage and documentation updates
gfs2_convert manpage and documentation updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Abhijith Das
Cluster QE
: Documentation
Depends On:
Blocks: 594510 601315 605371
  Show dependency treegraph
 
Reported: 2010-05-03 11:23 EDT by Abhijith Das
Modified: 2011-01-13 18:20 EST (History)
5 users (show)

See Also:
Fixed In Version: gfs2-utils-0.1.62-25.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 594510 601315 (view as bug list)
Environment:
Last Closed: 2011-01-13 18:20:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
manpage update to document recent changes to gfs2_convert (1.75 KB, patch)
2010-05-20 16:37 EDT, Abhijith Das
no flags Details | Diff

  None (edit)
Description Abhijith Das 2010-05-03 11:23:29 EDT
The recent fixes/updates to gfs2_convert changes its behavior in a few cases such as handling of CDPNs, converting full filesystems etc. This needs to be documented in the manpage and the gfs2-utils documentation.
Comment 1 Steven J. Levine 2010-05-20 16:11:41 EDT
Abhi:

Just for reference (to keep this info attached to this bug), here's the current RHEL 5 gfs2_convert documentation. I'll need to run it by you for review.

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Global_File_System_2/gfs_upgrade.html

Here's the RHEL 6 version (for completeness's sake):

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Global_File_System_2/gfs_upgrade.html
Comment 2 Abhijith Das 2010-05-20 16:37:46 EDT
Created attachment 415505 [details]
manpage update to document recent changes to gfs2_convert
Comment 3 Steven J. Levine 2010-05-20 17:23:05 EDT
Abhi: 

Is this for 6.0 as well?

I'll file a separate bug to update the gfs2 document for 5.6, to add these additional caveats.

I'm not sure if you were looking for an edit of the updates to the man page, or just feedback on the clarity of the information. It all seems clear enough to me, but I might slightly change these wordings (although they are not incorrect, per se):

> It is possible to reissue the gfs2_convert command on such a filesystem to
> completely convert it to GFS2.

The "it is possible to" is a little unclear. It may be possible to reissue the command, but is that what we're saying is the procedure?  Maybe something like:

  When this occurs, reissue the gfs2_convert command on the partially converted
  filesystem to complete the conversion process.

> The administrator can use bind mounts on these directories to get
> the same effect of CDPNs.

Very tiny, but I'd say "as CDPNs" rather than "of CDPNs".

As I say, I'll open a separate bug for my document for 5.6. If this information applies to 6.0, I'll open a bug for that as well.
Comment 4 Steven J. Levine 2010-05-21 13:21:56 EDT
The new bug for the GFS2 manual is BZ#594510
Comment 5 Robert Peterson 2010-09-17 11:54:29 EDT
Build 2768496 successful.  Changing status to Modified.
This fix is in gfs2-utils-0.1.62-25.el5.

Note that the patch in distcvs does not match the patch in git.
The patch in git fixes gfs-utils and gfs2-utils, but crossing
components is not allowed in cvs since they are two separate
rpms.  Therefore the patch in distcvs is only the gfs2 portion.
We will likely have to do another build for gfs-utils to
build the gfs-utils half of the git patch.  Depending on brew
and such, we may need to temporarily reset the bug back to POST.
Comment 7 Nate Straz 2010-12-03 09:47:02 EST
Verified new language is in the gfs2_convert man page in gfs2-utils-0.1.62-28.el5.
Comment 9 errata-xmlrpc 2011-01-13 18:20:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0135.html

Note You need to log in before you can comment on or make changes to this bug.