Bug 594510 - gfs2_convert manpage and documentation updates
gfs2_convert manpage and documentation updates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
Depends On: 588374 601315
Blocks: 605371
  Show dependency treegraph
 
Reported: 2010-05-20 17:27 EDT by Steven J. Levine
Modified: 2011-04-14 00:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 588374
: 605371 (view as bug list)
Environment:
Last Closed: 2011-04-14 00:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2010-05-20 17:27:35 EDT
Cloning the bug as a documentation bug to assign to myself for updating the GFS2 manual for RHEL 5.6.



+++ This bug was initially created as a clone of Bug #588374 +++

The recent fixes/updates to gfs2_convert changes its behavior in a few cases such as handling of CDPNs, converting full filesystems etc. This needs to be documented in the manpage and the gfs2-utils documentation.

--- Additional comment from slevine@redhat.com on 2010-05-20 16:11:41 EDT ---

Abhi:

Just for reference (to keep this info attached to this bug), here's the current RHEL 5 gfs2_convert documentation. I'll need to run it by you for review.

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Global_File_System_2/gfs_upgrade.html

Here's the RHEL 6 version (for completeness's sake):

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Global_File_System_2/gfs_upgrade.html

--- Additional comment from adas@redhat.com on 2010-05-20 16:37:46 EDT ---

Created an attachment (id=415505)
manpage update to document recent changes to gfs2_convert

--- Additional comment from slevine@redhat.com on 2010-05-20 17:23:05 EDT ---

Abhi: 

Is this for 6.0 as well?

I'll file a separate bug to update the gfs2 document for 5.6, to add these additional caveats.

I'm not sure if you were looking for an edit of the updates to the man page, or just feedback on the clarity of the information. It all seems clear enough to me, but I might slightly change these wordings (although they are not incorrect, per se):

> It is possible to reissue the gfs2_convert command on such a filesystem to
> completely convert it to GFS2.

The "it is possible to" is a little unclear. It may be possible to reissue the command, but is that what we're saying is the procedure?  Maybe something like:

  When this occurs, reissue the gfs2_convert command on the partially converted
  filesystem to complete the conversion process.

> The administrator can use bind mounts on these directories to get
> the same effect of CDPNs.

Very tiny, but I'd say "as CDPNs" rather than "of CDPNs".

As I say, I'll open a separate bug for my document for 5.6. If this information applies to 6.0, I'll open a bug for that as well.
Comment 2 RHEL Product and Program Management 2010-08-09 14:14:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 Steven J. Levine 2010-12-21 16:39:28 EST
I have updated the gfs2_convert appendix in the RHEL 5.6 version of the gfs2 manual and checked my changes in to the svn repository. This update will be reflected at the 5.6 release.

Note You need to log in before you can comment on or make changes to this bug.