Bug 597739 - Syncevolution broken in F13
Syncevolution broken in F13
Status: CLOSED DUPLICATE of bug 606647
Product: Fedora
Classification: Fedora
Component: syncevolution (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
: Reopened
: 603525 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-30 06:33 EDT by Andrea Musuruane
Modified: 2010-07-19 16:30 EDT (History)
8 users (show)

See Also:
Fixed In Version: syncevolution-1.0-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 16:30:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Musuruane 2010-05-30 06:33:50 EDT
Description of problem:
Syncevolution no longer works in F13

Version-Release number of selected component (if applicable):
syncevolution-1.0beta3-1.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1. Run syncevolution from command line
  
Actual results:
You get the following error: "syncevolution: error while loading shared libraries: libgdbus.so.0: cannot open shared object file: No such file or directory"

Expected results:
It should work.

Additional info:
None.
Comment 1 Alexander Osipenko 2010-05-31 05:30:22 EDT
Missing package dependency: libgdbus

Still remains broken!

How reproducible:
Always

Steps to Reproduce:
1. Install libgdbus (libgdbus-0.2-4.fc12.i686)
   yum install libgdbus
2. Run syncevolution from command line

Actual results:
Segmentation fault (core dumped)

Expected results:
It should work.
Comment 2 Peter Robinson 2010-05-31 06:20:51 EDT
Known issue https://bugzilla.redhat.com/show_bug.cgi?id=591786
Comment 3 Kenneth Soerensen 2010-06-14 14:28:29 EDT
*** Bug 603525 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-06-20 16:52:34 EDT
syncevolution-1.0-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/syncevolution-1.0-2.fc13
Comment 5 Fedora Update System 2010-06-21 17:41:59 EDT
syncevolution-1.0-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update syncevolution'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/syncevolution-1.0-2.fc13
Comment 6 Kenneth Soerensen 2010-06-22 13:58:50 EDT
The segmentation fault persists after updating - the following is from abrt:

[New Thread 10619]
Core was generated by `syncevolution -s two-way scheduleworld'.
Program terminated with signal 11, Segmentation fault.
#0  0x00000031e301175b in ?? ()

Thread 1 (Thread 10619):
#0  0x00000031e301175b in ?? ()
No symbol table info available.
#1  0x0000000000000025 in ?? ()
No symbol table info available.
#2  0x00000031e300b4f7 in ?? ()
No symbol table info available.
#3  0x0000000000000000 in ?? ()
No symbol table info available.
From                To                  Syms Read   Shared Object Library
0x00000031dd800af0  0x00000031dd818934  Yes         /lib64/ld-linux-x86-64.so.2
Address of symbol "__abort_msg" is unknown.
No symbol "__glib_assert_msg" in current context.
rax            0x0	0
rbx            0x1	1
rcx            0x31e302ea26	214262016550
rdx            0x31e302ec98	214262017176
rsi            0x0	0
rdi            0x1	1
rbp            0x0	0x0
rsp            0x7fff530fc540	0x7fff530fc540
r8             0x1b2	434
r9             0x1	1
r10            0x7fff530fc2d0	140734586929872
r11            0x31e3011750	214261897040
r12            0x0	0
r13            0x0	0
r14            0x7fff530fcd60	140734586932576
r15            0x7fff530fc950	140734586931536
rip            0x31e301175b	0x31e301175b
eflags         0x246	[ PF ZF IF ]
cs             0x33	51
ss             0x2b	43
ds             0x0	0
es             0x0	0
fs             0x0	0
gs             0x0	0
No function contains program counter for selected frame.
Debuginfo absent: 0e3b9cfec704b61e2431c57d49a5aae42479cb65
Debuginfo absent: 0ff567aa68dc213e4da48b254bfd392eba34e9f7
Debuginfo absent: 15ae8e02dd165a2fed66c3bd515d5c2aeb0132bf
Debuginfo absent: 790123ef36a30e531df07ea47f9a830fa7276ae3
Debuginfo absent: 86d46a1a46c541875e7efb3377679ff6d6cc7a51
Debuginfo absent: 9f2283b794c9a4907640d0ebe48ccea273e1410c
Debuginfo absent: c058b2b714fdbb845fb3e9902e27be5c28ccce16
Debuginfo absent: d43dfb83ae703d8bc578f94b6b42ecd44359d662
Debuginfo absent: ee8ed62e9f56891a4201f88479941dcbdd88bab6
Comment 7 Fedora Update System 2010-06-25 14:11:38 EDT
syncevolution-1.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Andrea Musuruane 2010-06-27 10:25:15 EDT
This bug is still present on version 1.0-2. I wonder why pushed this version after Kenneth noticed and closed this bug report. Reopening!
Comment 9 Olivier Crête 2010-06-27 11:13:03 EDT
FYI, there is an explanation and a patch on bug #606647 for the problem.
Comment 10 Axel Thimm 2010-07-19 16:30:10 EDT

*** This bug has been marked as a duplicate of bug 606647 ***

Note You need to log in before you can comment on or make changes to this bug.